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Preface

Purpose

This guide provides all the information that you need to use Esshase Spreadsheet
Add-in for Microsoft Excel. It explainsthe features and options and discussesthe

concepts, processes, procedures, formats, tasks, and examplesthat you need to use
the software.

Essbase is an online analytical processing (OLAP) solution that satisfies the
complex calculation requirements of financial, accounting, and marketing
professionals. Esshase operates in a client-server computing environment on a
local area network (LAN). In this environment, multiple users can use their
desktop computers to retrieve and analyze centralized data.

Y ou can create reports from the data residing on the Essbase server in severd
ways:

e Generate database reports through a spreadsheet interface, called Esshase
Spreadsheet Add-in, as explained in this guide.

e Use Esshase Application Manager Report Writer to create areport script and
run areport. For moreinformation, seethe Essbase Database Administrator’s
Guide.

e UseEsshase Application Programming Interface (API) to create and run
database reports. For moreinformation, seethe Essbase API Referencein your
docs directory.

e Usereporting tools, such as Hyperion Reporting for Essbase.
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Audience

Thisguideisfor Esshase end users who are responsible for some or al of the
following tasks:

e Starting Essbase and connecting and disconnecting from Essbase databases
e Retrieving data from a database into a worksheet

e Drilling down, drilling up, and navigating through aworksheet to analyze and
arrange data from multiple viewpoints

e Working with linked reporting objects and linked partitions

e Updating data on the Essbase server

e Using the worksheet to load and calculate data in the database
e Creating multiple sheets from data

e Working with currency conversions

Document Structure

The main sections of this guide are structured as tutorials that take you
step-by-step through basic and advanced tasks in Essbase Spreadsheet Add-in.
This document contains the following information:

e ‘“Introducing Release6.2” on page xv providesinformation on migrating from
previous versions of Essbase to Release 6.2 and lists all new features and
enhancements.

e Chapter 1, “Introducing Essbase,” introduces you to basic concepts of
retrieving and manipulating data through the spreadsheet interface.

e Chapter 2, “A Basic Esshase Tutorial,” provides a step-by-step tutoria of
basic data navigation, ad hoc retrieval, and reporting techniques.

e Chapter 3, “An Advanced Essbase Tutorial,” describes advanced reporting
and retrieval techniques for users that need special reports or formatted data
views.

viii @ Essbase Spreadsheet Add-in for Excel
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e Chapter 4, “Using Drill-Through,” provides a brief overview of the Esshase
Integration Services drill-through product.

e The containsalist of termsand their page numbers. Select or look up anindex
entry to view the page to which the entry refers.

Note: The Essbase Spreadsheet Add-in online help provides a comprehensive section
on Esshase Spreadsheet Toolkit. This section enables you to customize and automate
your use of Essbase by using Excel macros and Visual Basic for Applications (VBA)
functions. For more information on the Essbase Spreadsheet Add-in online help, see
“Accessing Online Help” on page 37.

The Essbase Spreadsheet Add-in User’s Guide for Excel is provided in the

\ Hyper i on\ Essbhase\ docs\ pdf directory in. pdf format for online viewing
and printing in Adobe® Acrobat Reader® (Release 3.0.1 or higher). The. pdf file
isnamed Essexcel . pdf . Y ou can download Adobe Acrobat Reader from the
Essbase CD-ROM or fromht t p: / / www. adobe. com Onthe Essbase CD-ROM,
the Acrobat Reader executable fileis located in the Adobe directory under the
appropriate platform and language-version subdirectories. To install Adobe
Acrobat Reader, launch the executable file, follow the prompts, and provide the
information requested.

Sample Databases and Files

Thisbook providestutorial stepsthat are based on sample databases and files that
are provided with the Essbase server software. Y ou use the Sample Basic database
for most tasks in Chapter 2 and Chapter 3. Y ou use a sample Essbase Currency
Conversion application for the section on currency conversion. See Chapter 3,“An
Advanced Essbase Tutorial.” For information on the Sample Basic database, see
Chapter 2, “A Basic Essbase Tutorial.”

In addition to these sample applications and databases, you also use several
sample Excel filesin the advanced tutoria in Chapter 3. The individual at your
organization who installs the server is responsible for making these applications,
databases, and files avail able to you. Contact the Essbase system administrator for
more information.

Essbase Spreadsheet Add-in for Excel W ix
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Related Documentation

When you licensed Hyperion Essbase, you received the following printed
documentation:

e TheEsshaseInstallation Guide, which showsyou how toinstall and configure
the Esshase server, Esshase Spreadsheet Add-in, Essbase Application
Manager, Essbase SQL Interface, Essbase API, Runtime Client, and sample
applications.

e The Esshase New Features booklet, which describes the new features that
have been added for this release of Hyperion Essbase.

In addition to the printed documentation and this Essbase Spreadsheet Add-in
User’s Guide for Excel, you have access to the following online documentation:

e The Esshase Migration Guide booklet, which provides the steps necessary to
upgrade from earlier releases and migrate from one platform; for example,
such as Windows 2000 to Solaris.

e The Essbase Documentation Roadmap, which lists all the Esshase
documentation and tells you how to access the online information.

e The Essbase Quick Path Card, which provides an overview of the tasks
involved in creating, using, and maintaining Essbase databases.

e Theonline Essbase Database Administrator’s Guide in the docs directory,
which explains the architecture of Essbase, how to design databases, how to
design calculations, how to set up Esshase security, how the databaseis stored,
and how to optimize Essbase.

e The Esshase Application Manager Online Help file, which explains how to
use the Application Manager user interface.

e The Technical Referenceinthedocs directory, which lists and describes
Esshase functions, calculation commands, report commands, ESSCMD
commands, and configuration file (.cf g file) settings.

e The Esshase Spreadsheet Add-in User’s Guide for Lotus 1-2-3,
which explains how to use Essbhase Spreadsheet Add-in features with Lotus
1-2-3 for Windows. This guide is provided in the
\ Hyper i on\ Essbase\ docs\ pdf directory in. PDF format for online
viewing and printing in Adobe Acrobat Reader (Version 3.0.1 or later). Adobe
Acrobat Reader is provided on the Essbase CD-ROM, and can also be
downloaded from ht t p: / / ww. adobe. com
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e The Essbase Spreadsheet Add-in online help files, which explain how to use
Esshase Spreadsheet Add-in, and provide all the spreadsheet macrosand VBA
functions.

e The API Referencein your docs directory, which lists and describes
programmatic functions available through the Essbase API, and provides
information to help you start programming with these functions.

e TheEsshase SQL Interface Guide, which contains information on how to
set up systemsto load databy means of Esshase SQL Interface. Thisguide
isprovided in the \ Hyper i on\ Essbase\ docs\ pdf directory in. PDF
format for online viewing and printing in Adobe Acrobat Reader (Version
3.0.1 or later). Adobe Acrobat Reader is provided on the Essbase
CD-ROM, and can also be downloaded from ht t p: / / ww. adobe. com

e The Essbase Adminstration Services Online Help which you can access
by launching Essbase Administration Services and clicking Help in the
main menu.

Online Help

To access online help, click the Help button in any Essbase dialog box or select
Essbase Help from the Excel Help menu.

To print an online help topic, display the topic and select File> Print, or right-click
and select Print from the pop-up menu.

To access HTML documentation, from the Start menu, select Programs >
Hyperion Solutions > Hyperion Essbase 6.2 > OLAP Server Documentation.

Note: You must have first installed HTML documentation to access it.
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Online Guides

Online guides are electronic versions of printed documentation.

To display an online guide, start Adobe Acrobat Reader, and then open one of
the Esshase. pdf fileslocated in your \ Hyper i on\ Essbase\ docs\ pdf

directory.

Conventions

The following table shows the conventions that are used in this document:

xii W

Table i: Conventions Used in This Document

Item Meaning

> Arrows indicate the beginning of a procedure, which
consists of one or more sequential steps.

Brackets|[] In examples, brackets indicates that the enclosed
elements are optional.

Bold Bold text indicates words or characters that you type

exactly asthey appear on the page. Bold in procedural
steps highlight major interface elements.

CAPITAL LETTERS

Capital |etters denote commands and various I Ds.
(Example: CLEARBLOCK command)

Example text Courier font indicates that the material shown is acode
or syntax example.
Ctrl +0 K eystroke combinations shown with the plus symbol

(+) indicate that you should press the first key and
hold it while you press the next key. Do not type
the + symbol.

Courieritalics

Courier italic text indicates avariable field in command
syntax. Substitute avalue in place of the variable shown
in Courier italics.

Italics

Italicsin aproduct-related term in the body of a book
indicates that the term is included in the glossary of
the book.
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Table i: Conventions Used in This Document (Continued)

Item Meaning

Ellipses (...) Ellipsis points indicate that text has been omitted from
an example.

M ouse orientation This document provides examples and procedures using

aright-handed mouse. If you are using a left-handed
mouse, adjust the procedures accordingly.

Menu options Options in menus are shown in the following format:
Menu name > Menu command > Extended menu
command

For example: File > Desktop > Accounts

n, X The variable n indicates that you must supply ageneric
number; the variable x indicates that you must supply a
generic letter.

Additional Support

In addition to providing the documentation and online help, Hyperion offers the
following support for product information.

Documentation Orders

A complete set of documentation isincluded on the CD in PDF or HTML format,
or inthe form of online help as part of the installed product. For moreinformation
on how to order printed documentation, visit our Web site at www.hyperion.com,
call Customer Service at 877.901.4975, or contact your local support office.

Training Services

Hyperion offers avariety of training options, including instructor-led training,
custom training, and multimediatraining. Thistraining covers all Hyperion
applications and technologies and is geared to end users, administrators, and
information systems (I1S) professionals.

Instructor-led training isdelivered in formats and in locations suited to Hyperion's
diverse, global customers. Hyperion Authorized Training Centers offer courses
that they develop, as well as those developed by Hyperion. Custom training—
training on the configured and tailored applications that employees use on the
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job—is another option to enhance user productivity and to ensure smooth
day-to-day operations. Multimedia trai ning—including computer-based training,
Web-based training, and interactive distance learning—provides a cost-effective
means of giving users a hands-on introduction to product features and functions.
Computer-based training (CBT) provides high-quality interactive training at the
user’s convenience, regardless of location.

A list of al Hyperion training classes can be found at www.hyperion.com.
For more information about training, contact your local training services
representative.

Consulting Services

Hyperion Consulting Services assists customers in maximizing the use of, and the
return on investment in, Hyperion products. Experienced Hyperion consultants
and Hyperion Alliance Partners assist organizations in tailoring solutions to their
particular requirements, such as reporting, analysis, modeling, and planning.
Specific services include implementation consulting, custom business solutions,
dataintegration, and technical consulting. Additionally, Hyperion offersavariety
of Services Packages and Reviews.

For more information about Consulting Services, Services Packages, and
Reviews, as well as the services offered by Alliance Partners, contact your

local consulting services representative. A list of all Hyperion Alliance Partners
can be found at www.hyperion.com.

Technical Support

xiv

Hyperion provides tel ephone and Web-based support to ensure that clientsresolve
product issues quickly and accurately. This support is available for all Hyperion
products at no additional cost to clients with a current maintenance agreement.
Additional support isavailable for clients with 24x7 coverage needs or global
regquirements that include multiple languages and time zones.

When standard support does not meet specific requirements, a Hyperion support
package that meets your needs can usually be designed. For more information,
contact your local support office.
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Introducing Release 6.2

This chapter provides compatibility information for Essbase Release 6.2 and
previous releases of Essbase, including migration information and new feature
descriptions and enhancements. It contains the following sections:

e “Migrating to Release 6.2 on page xv
e “What'sNew in Release 6.2" on page xvi

Migrating to Release 6.2

Asyou migrate (upgrade) from previous rel eases of Esshase to Release 6.2, keep
in mind that Release 6.2 of Esshase Spreadsheet Add-in is designed to work with
Release 6.2 of the Esshase server. If the Essbase system administrator upgradesthe
Essbhase server to Release 6.2, Release 5.x of Esshase Spreadsheet Add-in works
on only alimited basis. Upgrade to Essbase Spreadsheet Add-in to Release 6.2 as
soon as possible.

Read the Essbase Migration Guide bookl et and the Essbase I nstal lation Guide
for detailed information about migrating from previous rel eases of Essbase.
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Introducing Release 6.2

What's New in Release 6.2

Updated Client Platform Support

A new client platform, Lotus 1-2-3 Millennium Release 9.6, is now supported
alongwith Lotus1-2-3 Millennium Release 9.5 and Microsoft Excel 97 and 2000.

Improved Add-in Support of Excel in Browsers

Essbase supportsthe ability access the Esshase Spreadsheet Add-in features when
Microsoft Excel isinvoked from Internet Explorer.

If you drill downinan Excel spreadsheet accessed using Internet Explorer, Excel
refreshes the browser and displays the requested data automatically. Users need
not perform any additional steps to refresh the browser view.

Spreadsheet Add-in Support of Citrix

Essbase supports the Spreadsheet Add-ins for Microsoft Excel 2000 and L otus
1-2-3, Release 9.6 in Citrix Metaframe 1.8 on a Windows 2000 server. The Citrix
software enables users to access and execute client applications from the Citrix
server, thereby eliminating the need to install these client applications on
individual client computers. See the Essbase Installation Guide for details.

xvi H Essbase Spreadsheet Add-in for Excel



Introducing Essbase

Essbase is multidimensional database software that is optimized for planning,
anaysis, and management reporting applications. Essbase uniquely blends an
innovative technical design with an open, client-server architecture. Esshase
enables you to extend your decision support systems beyond ad hoc queries and
reports on historical performance to dynamic, operational systems that combine
historical analysisand future planning. By consolidating and staging historical and
projected datafor detailed analysis, you gain perspectives about your businessthat
enable you to take appropriate actions.

Essbase provides both power and flexibility. Thus, it can be used for abroad range
of online analytical processing (OLAP) applications including the following:

e Budgeting

e [Forecasting and seasona planning

e Financia consolidations and reporting

e Customer and product profitability analysis
e Price, volume, and mix anaysis

e Executive information systems (EIS)

Essbase enables you and others in your organization to share, access, update, and
analyze enterprise data from any perspective and at any level of detail without
learning new tools, query languages, or programming skills.

Essbase Spreadsheet Add-in for Excel m 17
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Typical Users of Essbase

Essbase isdesigned for usein many different applications. Financial analysts have
found Hyperion Essbase to be invaluable in budget analysis, currency conversion,
and consolidation. Cost accountants apply the powerful capabilities of Essbase to
evaluate allocation and elimination scenarios. Product managers and analysts use
Essbase to plan and analyze multiple product lines and distribution channels.
Esshase can also be used as arepository database for spreadsheet data. Anyone
who uses a spreadsheet is a potentia user of Essbase.

Because Essbaseis applicableto such abroad variety of environments, individuas
using it at your organization may fill one or more rolesin implementing and
running applications. This guide refers to specific roles by three titles. However,
in actuality, arole may be performed by one person or by several people working
collaboratively.

e Essbasesystemadministrator. The Esshase system administrator typically has
experience in networking, installing software packages, and administering
system functions. In addition to installing the Essbase software, the Esshase
system administrator may also set up Essbase user accounts, set up the
security system, and maintain the Essbase server.

e Application designer. The application designer sets up the Esshase database,
creates the database outline, and devel ops calculation and report scripts. The
responsibilities of the Essbase system administrator and the application
designer may overlap in some areas. The application designer has probably
developed spreadsheet or database applications and understands the
operational problems and the tools being employed to solve them.

e User. The user interacts with Esshase databases through spreadsheets, using
Microsoft Excel for Windows or Lotus 1-2-3. Users are typically analysts and
managerswho use spreadsheet programsastheir primary tool for viewing and
analyzing data.
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Introducing Essbase

Components of the Client-Server Environment

Client-server computing refers to the architecture in which individual PC
workstations are connected to a powerful server by means of alocal areanetwork
(LAN). The PC workstation acts as a client by requesting data from the server.
The server processes the request and returns the desired result to the client.

Esshase is built as a client-server system. System performance and multiuser
capabilities are greatly enhanced in the Esshase client-server environment.
Figure 1 illustrates the Essbase components and their relationships.

Figure 1: Essbase Components

=
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The Server

Essbase server isamultidimensiona database that supports analysis of an
unlimited number of datadimensions and an unlimited number of memberswithin
these dimensions. Developed using a true client-server architecture, all data, the
database outline, the calculations, and the data security controls reside on the
Essbase server.

The Essbase server operates on Windows 98, Windows NT 4.0, Windows Me,
Windows 2000 and UNIX operating systems.

Essbase Spreadsheet Add-in

Essbase Spreadsheet Add-in is a software program that merges seamlessly with
Microsoft Excel and Lotus 1-2-3. After Essbaseisinstalled, a special menu is
added to Excel. The menu provides enhanced commands such as Connect, Pivot,
Drill-down, and Calculate. Users can access and analyze data on the Esshase
server by using simple mouse clicks and drag-and-drop operations. Essbase
Spreadsheet Add-in enables multiple users to access and update data on the
Esshase server simultaneously.

The Network

20 m

Essbase runs on PC-based L ANSs that support the Named Pipes or TCP/IP
protocol.

Note: Supported network environments and technical requirements are discussed in

detail in the Essbase Installation Guide, which is included with the Essbase server
package.
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Essbase Application Products

Several optional products, designed to extend and enhance the scope of
OLAP applications, can be addressed using the Essbase server. The following
sections describe these products.

Essbase Spreadsheet Toolkit

Esshase Spreadsheet Toolkit includes over 20 macro and Visual Basic for
Applications (VBA) functions that enable you to build customized Microsoft
Excel and L otus 1-2-3 applications. The applications incorporate Essbase
commands. Commands such as EssCascade, EssConnect, and EssDisconnect
provide al of the functionality of their corresponding Essbase menu commands.
For more information, see the Essbase Spreadsheet Add-in online help.

Essbase Partitioning Option

Esshase Partitioning option enables you to define areas of data that are shared or
linked between data models. Partitioning can affect the performance and
scalability of Esshase applications. Partitioning provides more effective response
to organizational demands, reduced calculation time, increased reliability and
availability, and incorporation of detail and dimensionality. For moreinformation,
see “Accessing Linked Partitions’ on page 194.

Essbase Structured Query Language Interface

Esshase SQL Interface enables access to PC and structured query language (SQL)
relational databases by making the Essbase server operate as an open database
connectivity client. Using Essbase SQL Interface, data can be moved easily from
these diverse corporate data sources into the Esshase server for user access and
analysis. For more information, see the Essbase SQL Interface Guide.
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Essbase Application Programming Interface

Essbase A pplication Programming Interface (A PI) enables application devel opers
to create custom applications quickly by using standard tools while taking
advantage of the robust data storage, retrieval, and manipulation capabilities of
Esshase. Esshase API supports Visual Basic and C. For more information, see the
API Reference in your docs directory.

Essbase Currency Conversion

Essbase Currency Conversion translates, analyzes, and reportson foreign financial
data. Any exchange rate scenario can be modeled, and you can even perform ad
hoc currency conversions of data directly from the spreadsheet. The Currency
Conversion product is compliant with Financial Accounting Standards Board 52
(FASB52). For more information, see “Working with Currency Conversions’ on
page 207.

Essbase Integration Services

22l

Essbase | ntegration Services works with Essbase, Microsoft Excel, and Lotus
1-2-3. Essbase Integration Servicesisa suite of tools and data integration services
that serve as a bridge between relational data sources and the Essbase server.
Integration Server drill-through is one of the tools of Essbase Integration Services.
Using Integration Server drill-through, you can view and customize spreadsheet
reportsthat display dataretrieved fromrelational databases. For moreinformation,
see Chapter 4, “Using Drill-Through.”

Hyperion Objects

Hyperion Objects are ActiveX controls that enable you to build application
programs quickly and easily to access and manipulate data residing in Essbase
servers. Y ou can combine objects with other controlsin avisual design
environment to construct new programs.
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The Multidimensional Database

The Essbase multidimensional database stores and organizes data. It is optimized
to handle applications that have large amounts of numeric data and are
consolidation-intensive or computation-intensive. In addition, the database
organizes datain away that reflects how the user wants to view the data.

Definition of Multidimensional

A dimension is a perspective or view of a specific dataset. A different view of
the same datais an alternate dimension. A system that supports simultaneous,
alternate views of datasetsis multidimensional. Dimensions are typically
categories such as time, accounts, product lines, markets, budgets, and so on
(see Figure 3). Each dimension contains additional categories that have various
relationships one to another.

In contrast to the multidimensional view, worksheets stores data in two
dimensions, usually time and accounts, as follows:

Figure 2: Two-Dimensional Representations of Data in a Worksheet

A [ B [ € [ o [ E T F T 6 ]
1| Jan Feb Mar Apr May Jun
2 |Sales 1212 1421 1354 1178 1254 1465
'3 |[COGS 345 352 387 321 320 401
' 4 | Margin 857 1029 =t a57 934 1064
]
| 6 |Marketing 45 24 a5 1 56 ]
| 7 |Freight 21 71 a3 23 a5 21
| 8 |Discounts 2 24 52 14 53 jte]
| 9 | Total Expenses =iz 118 240 48 197 g5
10
|11 | Gross Profit 758 210 72T a09 737 979
| 12 |
|13 |
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An Essbase application contains an unlimited number of dimensions, so you can
analyzelarge amounts of datafrom multipleviewpoints. Thefollowingillustration
shows four views of multidimensional data. Y ou can retrieve and analyze the data
with the Esshase Spreadsheet Add-in software:

Figure 3: Multiple Views from a Five-Dimensional Database
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Introducing Essbase

Understanding the database outlineisthe key to understanding Essbase. To define
amultidimensional database, you design its database outline. The database outline
contains the database organi zation (structure), the database members, and the

database rules, as shown in Figure 4:

[ Database: Basic (Current Alias Table: Default)

—@Yeg Time (Active Dynarmic Time Series Members: H-T-D, Q-T-D, M-T-0)
Qtrl [+
Qtr2 (+)
Qtr3 [+

Qtrd [+

sures Accounts

Profit (+)

Irventary (~)

Ratios (~)

uct {Caffeinated, Intro Date, Ounces, Pky Type }
100 (+) (Alias: Colas)

200 (+) (Alias: Root Beer)

300 (+) (Alias: Cream Soda)

400 (+) (Alias: Fruit Soda)

Diet (~) (Alias: Diet Drinks)

et {Population }

East (+)

West (+)

South i+)
4

ario

Actual (+)

Budget (~)

Yariance (~)

L_|%ariance % (~)

— | Caffeinated Attribute (Type: Boolean)
[]Intra Date Attribute (Type: Date)
COunces Attribute (Type: Nurmeric)
Pkyg Type Attribute (Type: Text)
Population Attribute (Type: Mumeric)

KIKILIE

|
>
T2 T

|
{%l

KI<I<I<I<E [(KI<I<]

)
e

2 KKK

2 2 T

Figure 4: Essbase Database Outline

Note: The application designer or Essbase system administrator usually creates the
database outline. For more information on creating the database outline, see the

Essbase Database Administrator’'s Guide.
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The components of the database outline are the following:
e Dimensions

e Members

e Attributes

e Formulas

o Aliases

e Consolidations

Refer to the following sections for descriptions of the outline components.

Dimensions

Dimensions are the most basic categorical definitions of data within the database
outline. Y ou need at |east two dimensions to make any meaningful reference to
data; for example, atime dimension and an accounts dimension. Other dimensions
may categorize products, markets, and scenarios. Using dimensional organi zation,
you can define any consolidation structure or any slice of data that isrelevant to
the application. Essbase supports an unlimited number of dimensions.

Members

Members are the names of the elements within adimension. A dimension
can contain an unlimited number of members. The calculation, reporting, and
dimension-building facilities in Essbase use the following terms to describe
members.
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e Parents. A parent isamember with a consolidation branch below it. For
example, intheillustration below, Qtrl is a parent member because thereisa
branch containing monthly members below it.

Figure 5: Relationships Among Database Members

Databasze: Basic (Current Alias Table: Default)
E'Year Time (Active Dynamic Time Series Members: H-T-Dy, @-T-0, M-T-L (Crynamic Calc)
— [ @trt (+) (Dynamic Calc)

Jan (+)
Feh (+)
Mt [+]

Gt [+ (Crynamic Calc)

Apr (+)
My [+
Jun [+

Q3 [+ (Dynamic Calc)

Jul i+
AL (+)
Sep (+]

— E‘Q‘trd- [+) (Dynamic Calc)
— Ot (+)
— Mow [+
— Dec (+1

e Children. A childisamember with a parent above it. For example, Jan, Feb,
and Mar are children of the parent Qtr1.

| |
B &

e Shlings. A sibling isa child member of the same parent and on the same
branch (samelevel). For example, Jan, Feb, and Mar are siblings. Aprisnot a
sibling of Jan, Feb, or Mar, however, because it has a different parent, Qtr2.

e Descendants. A descendant isa member at any level below a parent. For
example, each member that fallsin the Year branch is a descendant of Year.
Thefollowing membersareal descendantsof Year: Qtrl, Jan, Feb, Mar; Qtr2,
Apr, May, Jun; Qtr3, Jul, Aug, Sep; Qtr4, Oct, Nov, Dec.

e Ancestors. An ancestor isamember of abranch above a member. For
example, Qtr2 and Year are ancestors of Apr.

e Generations. The term generation describes the branch number of amember.
Generations count from the root of the tree (generation 1, which isthe
dimension name) toward the leaf node.

e Levels Thetermlevel describesthe branch number of amember. Levelscount
from the leaf node (level 0) toward the root (the dimension name).
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Attributes

Attributes describe characteristics of data, such as the size and color of products.
Through attributes, you can group and analyze members of dimensions based
on their characteristics. Attribute dimensions must be associated with base
dimensions. For more information, see the Essbase Database Administrator’s
Guide.

Formulas

Each database member can have one or more formulas associated with it in the
database outline. For example, the Variance members of the Scenario dimension,
as shown in Figure 4, contain formulas. Formulas can be simple or complex. For
more information, see the Essbase Database Administrator’s Guide.

Aliases

Essbase supports alternative names, or aliases, for database members. Aliases are
useful when various labels are used for the same member in various worksheets.
Oneworkshest, for example, may refer to Cost_of Goods _Sold as COGS. Aliases
also can be used for reporting in alternative languages or for more formal output
name sets, such as account numbers.

Consolidations

Consolidations in Esshase applications are defined by member branches. The
database outline determines consolidation paths. The determination is based onthe
location of members within a dimension. Indentation of one member below
another indicates a consolidation relationship. Indenting members is important
for the drill-down capabilities in Essbase Spreadsheet Add-in. Asyou navigate
your way through data, you can drill down through levels of consolidations. The
database outline is the roadmap that determines the levels of data navigation.
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When you add Essbase Spreadsheet Add-in to Microsoft Exce , most Excel
operations remain unchanged; Essbase Spreadsheet Add-in simply adds a new
menu, a Essbase toolbar, and mouse shortcuts with which you can access the
Essbase server.

Thetasks described in thistutorial are basic tasks. That is, these are tasks that you
probably use often when working with Essbase. Chapter 3 describes more
advanced tasks.

Thistutorial chapter contains the following sections:

“Getting Acquainted with Essbase Spreadsheet Add-in” on page 30
“Preparing to Begin the Tutorial” on page 40

“Retrieving Data” on page 46

“Pivoting, Retaining, and Suppressing Data” on page 60
“Formatting the Worksheet” on page 75

“Creating Queries Using Esshase Query Designer” on page 91
“Deleting Queries’ on page 105

“Viewing Messages and Confirmations’ on page 105
“Accessing Help” on page 107

“Selecting Members” on page 110

“Saving and Disconnecting” on page 119

“Moving on to Advanced Tasks’ on page 121

Note: Each tutorial task builds upon the previous task. Therefore, tasks must be
completed in succession.
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Theexamplesused in thistutorial are based on the sampl e database (called Sample
Basic) that isincluded with the Essbase installation. Contact the Essbase system
administrator for information about accessing the Sample Basic database or about
accessing other databases on the Essbase server.

Getting Acquainted with Essbase
Spreadsheet Add-in

This section provides the following information to help you get acquainted with
Esshase Spreadsheet Add-in:

e “Adding Esshase Spreadsheet Add-in” on page 30
e “Starting Essbase Spreadsheet Add-in” on page 31
e ‘“Installing the Essbase Toolbar” on page 33

“Using the Essbase Toolbar” on page 34
e “Accessing Online Help” on page 37

“Enabling Mouse Actions” on page 38

Adding Essbase Spreadsheet Add-in

30

If you manually update your environment settings or if you have removed Esshase
Spreadsheet Add-in from the Microsoft Excel environment, you must use the
Excel facility to add Esshbase Spreadsheet Add-ininto Excel. Thefacility adds the
Essbase menu to the Excel menu bar and points Excel to the Esshase Spreadsheet
Add-infilein the\ Essbase\ bi n directory. Thisfileison the hard drive of your
PC, if that iswhere you installed Essbase Spreadsheet Add-in, or on the network
driveif that is where you set up your PC operating environment to run Essbase
Spreadsheet Add-in.

Note: essexcl n. x| | is the add-in file for Excel 97 and Excel 2000. Adding Essbhase
Spreadsheet Add-in into Excel 97 and Excel 2000 modifies the Windows 98, Windows
Me, Windows 2000, or Windows NT Registry. The. i ni file and Registry point to where
the Essbase Spreadsheet Add-in file is installed.
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» To add Esshase Spreadsheet Add-in to Excel:
1. InExcd, select Tools> Add-Ins.
Excel displays the Add-Ins dialog box.
2. Click the Browse button.
Excel displays the Browse dialog box.

3. Sdectthefileessexcl n. x| inthebi n directory where you installed
Essbase Spreadsheet Add-in on your PC hard drive (if you installed Essbase
Spreadsheet Add-in there) or in the bi n directory where the Essbase system
administrator installed Essbase Spreadsheet Add-in on anetwork drive (if you
set up your PC operating environment to run Essbase Spreadsheet Add-in
there).

4. Click OK twice to close the dialog boxes and start Essbase Spreadsheet
Add-in.

The Essbase startup screen is displayed.

If you do not see the Essbase startup screen or if your system does not list the
Essbase Spreadsheet Add-in menu options, seethe Essbase I nstallation Guide
for troubleshooting information.

Starting Essbase Spreadsheet Add-in

Because Essbase Spreadsheet Add-in software for Excel isimplemented as an
Excel add-in, you must start Excel from Windows to use Essbase Spreadsheet
Add-in software.

Y ou must open aworksheet before attempting to connect to the Hyperion Essbase
server. An attempt to connect to the Hyperion Essbase server without opening a
worksheet resultsin an error message.

Essbase Spreadsheet Add-in for Excel H 31



A Basic Essbase Tutorial

320

» To begin a Essbase session:

1. Start Excel.

After the Excelstartup screen disappears, the Essbase startup screenis

displayed.

The Hyperion Essbase menu should be displayed in the Excel menu bar. If you
do not see the Hyperion Esshase menu, you may need to usethe Excel add-in
facility to add Essbase Spreadsheet Add-in into Excel. For more information,
see “Adding Essbase Spreadsheet Add-in” on page 30.

The Essbase toolbar should also be visible. If you do not see the Esshase
toolbar, see “ Installing the Essbase Toolbar” on page 33 and “Using the

Esshase Toolbar” on page 34.

2. From the Excel menu bar, select Essbase to open the menu.

Figure 6: The Essbase Menu

Retrieve
Keep Only
Remaove Only
Zoorn In
Zoorn Cuk
Piwaok

Mavigate Without Data

Linked Objects. ..
Query Designer. ..

FlashBack
Options. ..

Member Selection. ..
Currency Repart. .,

Cascade. ..

Retrieve & Lock
Lock.

Unlock.

Send
Calculation, ..

Conneck. ..
Disconneck, ..

Note: If the Excel status bar is not displayed, you can display it by selecting View >

Status Bar.
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Installing the Essbase Toolbar

Essbase Spreadsheet Add-in provides a convenient toolbar that displays buttons
for accessing most of the common Essbase commands without having to open the
Essbase menu. Prior to using the Essbase toolbar, you must install the toolbar by
opening an Excel file that is provided as part of the default Essbase installation.
For more information on using the toolbar, see “Using the Essbase Toolbar” on

page 34.

» Toinstal the Esshase toolbar:
1. Start Excel.
2. Select File> Open.

3. Fromthe\ essbase\ client\ sanpl e directory, opentheesst ool b. x| s
file.

Depending on how software is installed on your PC, the file may not be
available or may belocated in adifferent directory. Contact the Essbase
system administrator for more information.

A blank worksheet opens.

o] o]~

Figure 7: esst ool b. x| s File

Note: If you are using Excel 97, two dialog boxes may be displayed when you
open the esst ool b. xI s file. If so, click the Enable Macros button on the first
dialog box, and click OK on the second dialog box.

4. Select File> Closeto closetheesst ool b. x| s file. You do not need to
modify or save thefile.

Y ou should not haveto perform the tool bar install ation procedure again unlessyou
del ete the Essbase toolbar from the Toolbars dialog box in Excel. If you delete the
toolbar, perform the installation procedure again.

Note: If you have toolbars turned off in Excel, you do not see the Essbase toolbar
immediately. You must first enable toolbars. For more information, see “Using the
Essbase Toolbar” on page 34.
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Using the Essbase Toolbar

Essbase Spreadsheet Add-in for Excel features a convenient toolbar that displays
buttons for accessing most of the common Essbase commands without having to
open the Essbase menu. Y ou can view a short description of a button in a pop-up
on the toolbar by moving your cursor over the button.

Note: Before you can view the Essbase toolbar, you must install it. See “Installing the
Essbase Toolbar” on page 33.

To view the Essbase toolbar, select View > Toolbars > Essbase from the Excel
menu bar. A check box must be displayed next to Essbase in the menu.

Note: If you select the Essbase check box and click Delete, you must reinstall the
toolbar. See “Installing the Essbase Toolbar” on page 33 for instructions.

The toolbar provides the following buttons:

Table 1: Essbase Toolbar

Button Purpose Description
o Connect Enables you to connect to an Essbase server.
| When you click the Connect button on the toolbar,
Essbase displays the Esshase System Login dialog
box.
i Navigate with or | Togglesthe Navigate Without Data feature, which
! without data tells Essbase to retrieve or not to retrieve data

when you perform navigational operations, such
as pivot, zoom in, zoom out, keep only, and
remove only.

This button serves the same function as the
Navigate Without Data check box in the
Essbase Options dialog box (Global tab).
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Table 1: Essbase Toolbar (Continued)

Button

Purpose

Description

o

Retrieve

Retrieves data into the active worksheet. A
retrieve regquest places data at the beginning of
the active worksheet. When you click the Retrieve
button, if you are not already connected to an
Essbase server, the Essbase System Login dialog
box is displayed.

Tip: If you have mouse actions enabled, you

can retrieve data by double-clicking the primary
mouse button in any empty cell in the worksheet.
To enable double-click support, select

Essbase > Options, select the Global tab, and
select the Enable Double-Clicking option. For more
information, see “Enabling Mouse Actions” on
page 38.

Keep only

Retains only the selected member (the active cell)
or member range in the worksheet. When you
click the Keep Only button, all unselected
members are removed from the worksheet.

Remove only

Removes the selected member (the active cell)
or member range from the worksheet. When you
click the Remove Only button, all unselected
members are retained in the worksheet.

Zoomin

Retrieves and expands data from the Essbase
server according to the options specified in the
Essbase Options dialog box.

Tip: If you have mouse actions enabled, you

can drill down on data by double-clicking the
primary mouse button in the cell that contains

the member you want to expand. To enable
double-click support, select Essbase > Options,
select the Global tab, and select the Enable
Double-Clicking option. For more information, see
“Enabling Mouse Actions” on page 38.
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Table 1: Essbase Toolbar (Continued)

Button

Purpose

Description

L

Zoom out

Collapses the view according to the options
specified in the Essbase Options dialog box in the
cell that contains the member that you want to
collapse. To enable double-click support for
drilling up, select Esshase > Options, select

the Global tab, and select the Enable
Double-Clicking option.

Open Esshase
Query Designer

Opens the Essbase Query Designer, which makes
it easy to define a page orientation for dimensions
and sel ected database members. You can also save
queriesfor later use. Essbase Query Designer isa
new feature designed to create report queries,
view attributes, and perform cal cul ations based on
attributes.

FlashBack

Restores the previous worksheet view.

B

Set options

Enables you to set display, zoom, mode, style, and
global options for the active worksheet to
customize the behavior of Essbase Spreadsheet
Add-in software. When you click the Options
button, Essbase displays the Esshase Options
dialog box.

Select members

Enables you to select members from the
multidimensional database outline. When you
click the Member Selection button, Essbase
displays the Esshase Member Selection dialog
box.

Attach linked
objects

Enables you to attach comments or files to data
cells. When you click the linked objects button,
Essbase displaysthe linked objects browser dialog
box.

36 N
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Accessing Online Help

Essbase Spreadsheet Add-in includes a context-sensitive online help system. You
access the Esshase Spreadsheet Add-in online help in one of three ways. Which
way you choose depends on the type of information that you need,

e Access the entire online help system for browsing or searching for
information. To access the entire help system, selectHelp > Essbase Help.
After you access online help, you can browse or search through the system to
view general information on Essbase Spreadsheet Add-in, Essbase command
descriptions, procedural information for completing tasks, Spreadsheet
Toolkit macros, and Visual Basic for Applications (VBA) function
descriptions.

e Access context-specific information fromdial og boxesin Essbase Spreadsheet
Add-in. Each dialog box in Essbase Spreadsheet Add-in featuresaHelp button
that accesses online help topics that are specific to the particular dialog box.
The buttons enable you to find the information you need without having to
search through the entire help system.

Figure 8: Excel Help Button
k‘?|

Note: The Essbase Spreadsheet Add-in online help also provides a
comprehensive section on Essbase Spreadsheet Toolkit, which enables you to
customize and automate your use of Essbase by using Excel macros and VBA
functions.

e Accessinformation on a specific Hyperion Essbase Query Designer function.
Access What's This? Help in the Hyperion Essbase Query Designer dialog
box, and then click an item in the dialog box to access information on that
item.

Figure 9: EQD Help Button
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Enabling Mouse Actions

The following terms are used throughout this guide to describe mouse operations:

Primary mouse button and secondary mouse button describe the buttons on a
two- or three-button mouse. Usually, right-handed users configure the left
mouse button as the primary button and the right mouse button as the
secondary mouse button. The primary mouse button is the one that you use to
start Windows applications, such as Excel; the secondary mouse button isused
for auxiliary operations. The term click refers to use of the primary mouse
button. The term right-click refers to use of the secondary mouse button.

Select chooses the object that is under the cursor when you press and release
the primary mouse button. You can select aworksheet cell, for example, by
moving the cursor to the cell and pressing and releasing the primary mouse
button.

Click (that is, both click and right-click) describes a quick press-and-release
action on acommand object. You can click a button, for example, to execute
acommand.

Double-click describes two quick press-and-release actions that are executed
in rapid succession. You can double-click an application icon, for example, to
start a Windows application.

Drag describes a press, hold, and move action. You place the cursor on an
object, press amouse button, hold the mouse button and move the object, and
release the mouse button when you reach your goal. For example, you can
highlight arange of cellsin an Excel worksheet by dragging the cursor over
the cells.

Note: Hyperion Essbase uses a drag operation called a pivot. A pivot requires use
of the secondary mouse button. To execute a pivot, you must press and hold the
secondary, rather than the primary, mouse button while dragging the selection.

Esshase offers enhanced mouse actionsin Excel. Y ou can use the mouse to do any
of the following:

Retrieve data

Drill down and drill up on database members
Pivot (move or transpose) data rows and columns
Access linked reporting objects

Access linked partitions
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» To enable double-clicking to retrieve, drill down, and drill up on Essbase data:
1. Select Essbase > Options.
2. Inthe Essbase Options dialog box, select the Global tab.
3. Select the Enable Double-Clicking check box.

When the Enable Double-Clicking check box is selected, you can retrieve
and drill down to more detailed data (primary mouse button) and drill up to
less detailed data (secondary mouse button). When the double-clicking option
is enabled, the Excel in-cell editing feature is overridden.

Figure 10: Essbase Options Dialog Box—Global Tab

Essbase Options E

Displayl Zoom | Maode | Style  Global |

Mo — Display Messages
ek ' Information
[¥ Enable Double-Clicking C Warmings
V¥ Enable Linked Object Browsing & Enars
' Mone
— Memory ™ Display Unknown Members
[V Enable Flashback
—Log File
Member Select———————— | F Boute Messages to Log File
™ Display Save Dialog V¥ Purge Log File Every Session
—Mode
™ Mavigate withaut Data Addns. . |

QK I Cancel Help

4. Click OK to return to the worksheet.

For information about setting the primary mouse button to display the Linked
Objects Browser dialog box when you double-click a data cell, see the Essbase
Spreadsheet Add-in online help.
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Preparing to Begin the Tutorial

Before you begin the basic tutorial, read the following important sections:
e “Setting Essbase Options’ on page 40

e “Following Guidelines During the Tutorial” on page 44

e “Reviewing the Sample Basic Database” on page 46

Setting Essbase Options

Before you begin the tutorial steps, make sure that the worksheet options are set to
theinitial settings asillustrated in Figure 11 through Figure 14. If the option
settings are different, theillustrations presented in this chapter may not match the
worksheet view.

Note: For information about each option in the Essbase Options dialog box, see the
Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.
2. Inthe Essbase Options dialog box, select the Display tab.
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3. Select the appropriate check boxes and option buttons so that your display of
the Display tab matches the following illustration:

Figure 11: Initial Settings for Display Options

Essbase Options

4. Select the Zoom tab.
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5. Select the appropriate check boxes and option buttons so that your display of
the Zoom tab matches the following illustration:

Figure 12: Initial Settings for Zoom Options

Essbase Options

O
(]
(]
(]
(]
(]
(]

6. Select the Mode tab.
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7. Select the appropriate check boxes and option buttons so that your display of
the Mode tab matches the following illustration:

Figure 13: Initial Settings for Mode Options

Essbase Options

Note: If you are already connected to a Essbase database, the Essbase Options
dialog box also displays a Style tab. You can skip this tab for now.

8. Select the Global tab.
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9. Select the appropriate check boxes and option buttons so that your display of
the Global tab matches the following illustration:

Figure 14: Initial Settings for Global Options

Essbase Options E
Display I Zoom I Mode I Style  Global |
—Mouse Actions———— [~ Display Messages
' Information
[¥ Enable Double-Clicking C Warmings
V¥ Enable Linked Object Browsing & Enars
' Mone
— Memory ™ Display Unknown Members
[V Enable Flashback
—Log File
Member Select———————— | F Boute Messages to Log File
™ Display Save Dialog V¥ Purge Log File Every Session
—Mode
™ Mavigate withaut Data Addns. . |

QK I Cancel | Help |

Note: You should have already selected the appropriate boxes for Mouse Actions,
as described in “Enabling Mouse Actions” on page 38.

10. Click OK to save the settings for this session and close the Essbase Options
dialog box.

Following Guidelines During the Tutorial
Keep in mind the following guidelines during this tutorial:

e Tasksthat should not be performed as part of the tutorial are displayed in gray
boxes. These tasks are included only for your future reference. You can find
more information on these tasks in the Essbase Spreadsheet Add-in online
help.

e Youmust beconnected to the Sample Basic database during thetutorial. If you
are not connected to this database, the illustrations presented in this chapter
will not match the worksheet view.
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e You can access many Essbase commandsin any one of these ways:
— By selecting the command from the Essbase menu
— By clicking the appropriate button on the Essbase toolbar

—  For the Zoom In and Zoom Out commands, by double-clicking either the
primary mouse or the secondary mouse button

e You must set the options in the Essbase Options dial og box as described in
“ Setting Essbhase Options’ on page 40. If the option settings are different, the
illustrations presented in this chapter may not match the worksheet view.

e After you change aworksheet option in the Esshase Options dialog box, you
must perform aretrieval or adrill-down operation to have the new setting take
effect.

e Besureto follow each step in the tutorial. Each tutorial task builds upon the
previous task. Do not skip the final steps at the end of sections, because these
steps are often necessary to prepare you for the next tutorial task.

e If youmakeamistake during thetutorial, you can select Essbase > FlashBack
to return to the previous worksheet view.

e Thevaluesinthe Sample Basic database that represent ratios or percentages
are calculated to avery high level of precision (for example, 55.26162826). In
Excel, you can apply acell format to control the number of decimal placesthat
are displayed in data values. For more information, see the Excel
documentation.

e The numeric values that are shown in theillustrations used throughout this
tutorial may not match the values stored in your database. The values shown
in theseillustrations reflect afreshly loaded database.

e Some worksheet columns have been adjusted for clarity in theillustrations.
You do not need to change the width of columnsin theworksheet to follow the
tutorial steps. The Adjust Columns option in the Essbase Options dialog box
(Display Tab) adjusts columns for you.
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Reviewing the Sample Basic Database

The Sample Basic database that you use for the tutorial is based on a hypothetical
company inthe beverageindustry. The major products of the company are various
kinds of sodas. These products are sold in U.S. markets, which are categorized by
state and region. Financial datafor the company is collected monthly and is
summarized by quarter and by year. The company uses Essbase to calculate
financial and accounting data, such as sales, cost of goods sold, and payroll. The
company tracks both actual and budget data, as well as the variance and percent
variance between the two.

Retrieving Data

46 W

Now that you are more familiar with the Essbase environment, you can connect to
the Essbhase server and start using Essbase and Essbase Spreadsheet Add-in. The
following section guides you through atypical Essbase session where you connect
to adatabase and retrieve data in various ways.

This section outlines the following basic retrieval tasks:
e “Connecting to a Database” on page 47

e “Changing aPassword” on page 49

e “Retrieving Datafrom a Database” on page 49

e “Canceling a Data Retrieval Request” on page 51

e “Restoring the Previous Database View” on page 51
e “Dirilling Down to More Detail” on page 52

“Drilling Up to Less Detail” on page 56
e “Customizing Drill-Down and Drill-Up Behavior” on page 57

Note: Make sure that you followed the steps in “Setting Essbase Options” on page 40.
If the settings in the Essbase Options dialog box are different from the settings
previously illustrated, the worksheet view will differ from the illustrations shown in this
chapter.
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Remember that you can perform common data retrieval tasks by doing any of the
following:

e Selecting commands from the Essbase menu on the Excel menu bar
e Clicking the appropriate buttons on the Essbase toolbar

e Double-clicking the primary or the secondary mouse button in the appropriate
cell (for Retrieve, Zoom In, and Zoom Out commands)

Connecting to a Database

To access Essbase data, you must first connect to a database on the server. This
tutorial assumesthat you have the appropriate privilegesto connect to aserver, an
application, and a database.

Note: Essbase does not support multiple instances of Excel.

1. Select Essbase > Connect
Essbase displays the Essbase System L ogin dialog box.
Figure 15: Essbase System Login Dialog Box

Essbase System Login E

Server: ILDcthost j K I
Username: W Cancel |

Pazsword: l— Help |

[EhanaeFassword.. |
Application/D atabase:
[ pdate |
Tote.. |

Note: To complete the steps that follow, you need to know the name of the
Essbase server, your username, and your password. If you do not have this
information, contact the Essbase system administrator.
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2. From the Server list box, select the server that you want to access. (If the
server name that you want does not appear in thelist, you can typein the name
of the server you want to access.)

3. Press Tab to move to the User name text box; type your username in the
text box.

4. Press Tab to move to the Password text box; type your password in the text
box.

Note: You can change your password when you are connected to a server. To
change your password, see “Changing a Password” on page 49.

5. To connect to the server, click OK.

Essbase displays alist of available application/database pairsin the
Application/Database list box. An Essbase server enables simultaneous
accessto multiple applications. An application can contain multiple databases.
Only the databases to which you have security access are shown in the list.

For thistutorial, you use the Sample Basic database. If the Sample Basic
database wasinstalled as part of the Essbaseinstallation, it isshowninthelist.
If Sample Basic is not shown in the Application/Database list box, ask the
Esshase system administrator to install it.

Figure 16: Available Application and Database Pairs

Essbase System Login E

Server. ILocthost j oK I
Usemame: W ﬂl
Password: lm Help |

LChange Password... |

Application/D atabase:

Demo Basic Update |

S ampeast East

Sample Internt! Mate... |

S ample Hchgrate
S amppart Company
Sourcel Basic
Targetl Basic

6. IntheApplication/Database list box, double-click Sample Basic. You can
also select Sample Basic from the list box and click OK.
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If the applicationisnot already running, Essbase automatically startsit. There may
be a brief pause as the application loads. The time required to start an application
depends on the number of databases, the sizes of the databases, and the sizes of the
indexes of the databases contained within the application.

Changing a Password

Y ou can change your password only if you are connected to a server.

Note: Remember, tasks that you should not perform as part of the tutorial are shown
in gray boxes.

» To change your password:

1. Inthe Essbase System L ogin dialog box, select the Change Password

button.

2. Inthe Change Password dialog box inthe New Password text box, type

your new password.
3. Inthe Confirm Password text box, type the password again.
The passwords must be identical.
. Click OK to change your password.
5. Click OK again to close the Esshase System L ogin dialog box.

Retrieving Data from a Database

Each time you retrieve information from an Essbase server, the following actions
occur:

Esshase Spreadsheet Add-in requests data from the server.
The server processes the request and prepares the data.
The server transmits the data to Essbase Spreadsheet Add-in.

Excel receives the data from Essbase and organizes it in aworksheet.

Essbase Spreadsheet Add-in for Excel
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To help you monitor these operations, Essbase uses three custom cursors.

Table 2: Essbase Custom Cursor

This cursor: Is displayed when:

N Esshase requests information from the server.
N The server is processing the request.

il The server returns the data.

Note: Small retrieval actions display the cursors very quickly; you may not notice
changes in the direction of the arrow when retrieving small amounts of data.

» To retrieve datainto an empty worksheet:

1. Openanew worksheet by selecting File> New or by clicking the g button.

Note: You should be connected to the Sample Basic database. If you are not
connected, follow the steps in “Connecting to a Database” on page 47.

2. Select Essbase > Retrieve.
Essbhase retrieves data into the Excel worksheet.

Figure 17: Initial Data Retrieval from Sample Basic

A

B | ¢ [ o | E [ F

Year

o] w|m]~

Measures Product | Market Scenatio
105522

Because you selected the Enable Double-Clicking box in the Essbase
Options dialog box (Global Tab), you can double-click in an empty cell to
retrieve data. Y ou can also click the Retrieve button on the Essbase toolbar.
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When you retrieve datainto an empty worksheet, Esshase returns datafrom thetop
levels of each database dimension. The top level is used as a starting point to
navigate, or drill down, into levels of detailed data. In the Sample Basic database,
thefollowing fivedimensions areretrieved: Measures, Product, Market, Scenario,
and Year.

For the remainder of tasksin thistutorial, you can retrieve data by double-clicking
in adata cell, selecting Essbase > Retrieve, or by clicking the Retrieve button on
the Essbase toolbar.

Canceling a Data Retrieval Request

Occasionally, you may want to cancel aretrieval request. For instance, you may
want to stop arequest if aretrieval istaking longer than expected or if you
mistakenly double-click.

Because Esshase returns data so quickly to the worksheet, you may not be able to
cancel aretrieval beforetheretrieval iscomplete. The cancel featureis most useful
when you need to stop alarge retrieval request.

To cancel dataretrievals, press the Esc key during aretrieval action.

Note: You can cancel a retrieval only while Essbase is processing in Essbase
Spreadsheet Add-in. You cannot cancel a retrieval when Essbase is processing from
the server.

Restoring the Previous Database View

The FlashBack command restores the previous database view. A database view is
simply what you see in the worksheet after aretrieval or navigation operation.
FlashBack is similar to the Excel Edit > Undo command, which reverses the last
action. The FlashBack command uses the memory of your machine to store the
current view before processing an Essbase retrieval request. Y ou can use
FlashBack to undo only the most recent operation. FlashBack cannot undo
multiple operations.

Throughout this tutorial, you should follow all stepsin the order that they are
presented. If you make amistake or find yourself out of step with the tutorial, you
can usethe FlashBack command from the Essbase menu or tool bar to undo the last
command and return to the previous database view. If you want to start the tutorial
over from the beginning, select the entire worksheet and select Edit > Clear > All.
Then press Enter or click OK to empty the worksheet and start again.
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Y ou can disable FlashBack during normal operationsto conserve memory on your
local machine. Do not disable FlashBack for this tutorial.

» To disable Flashback:

1. Select Esshbase > Options and click the Global tab.
2. Clear the Enable FlashBack check box.

Drilling Down to More Detail

With Essbase, you can drill down to variouslevels of multidimensional datainthe
worksheet. For example, if you want to view data for a specific quarter or month
rather than an aggregate data value for the whole year, you can drill down on the
Y ear dimension to see more detailed data.

Y ou have three options for drilling down on a member:
e Select the member and select Essbase > Zoom In.
e Select the member and double-click the primary mouse button.

e Select the member and click the Zoom In button on the Essbase tool bar.

» Todrill down to lower levels of the Year dimension:
1. OnYearincell A2, double-click the primary mouse button.

Thedrill-down action retrieves datafor thelevel below (the children of) Y ear:
Qtrl, Qtr2, Qtr3, and Qtr4.

Figure 18: Result of Drilling Down on the Year Dimension

A | B [ ¢ [ ] E ] F | &
1 Measures Product Market Scenario
2 |0t I 24703
L3 [Gtr2 27107
L4 |Gtr3 27912
L5 |Gitrd 25500
L6 | ‘Year 105522
7

Note: For a discussion of the relationships among Essbase database members,
see “Database Outlines” on page 25.
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With Essbase, you can retrieve members into grouped, or nested, columns or
rows. Row groups containing more than one level of data are nested within
single-member row groups. For example, arow group containing Qtrl, Qtr2,
Qtr3, and Qtr4 may be nested within a single-member row for a specific
region, such as East (see the following illustration). Drilling down to lower
levels of database members is one way to retrieve data into nested groups.

2. Incell D1, double-click to drill down on Market and create nested groups of
rows down the worksheet.

Figure 19: Result of Drilling Down on the Market Dimension (Nested Rows)

A [ B [ ¢ T b [ E T F [ &
L1 Measures|Pr0duct!Scenari0
L2 |East Gitrl 5380
3 | Gitr2 5459
4 | Q3 6346
5 | Citrd 5936
L6 | ‘fear 24181
L7 |West Gitrl 7137
I8 | Gitr2 75148
9 | Q3 7939
10| Citrd 7270
1 Wear 29561

Because worksheets can accommodate more rows than columns, Essbase is
preset to retrieve data into rows when you drill down on a member. Y ou can
change this default behavior and display the results of adrill-down across
columns. Drilling across columns applies only to the top-level member of a
dimension (for example, Market or Scenario).

Follow these stepsto drill down on Scenario and retrieve its respective members
into columns rather than rows:

1. Pressand hold the Alt key.
2. Double-click Scenario (in cell E1).
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3. Releasethe Alt key.
Essbase displays the data in columns across the worksheet.

Figure 20: Result of Drilling-Down on the Scenario Dimension
(Nested Columns)

A [ B C D E F G | H

L1 Measures Product 1

L2 | Actual Budget “ariance “ariance % Scenario
L3 |East Gitrl 5380 B&00)  -1120) -17.23076923 5380
4 | Gitr2 6459 7a80  -1081 -13.920529% 5459
5 | Q3 6346 7a50  -1204) -15.94701987 6346
6 | Citrd 5936 6790 854 -12.57731959 5936
L7 | Wear 24161 283300 4229 -14.89609017 24161
I8 |West Gitrl 7137 8960 -1823) -20.34595214 7137
9 | Gitr2 7818 82900 1775 -19.10B5662 75148
10| Q3 7939 5870 -1931 -19.56433637 7939
11| Citrd 7270 S0B0  -1790) -19.75717439 7270
12 Wear 29861 371800 7319 -19.6G531463 29561

Drilling Down on Attribute Members

Y ou can use the Essbase attribute feature to retrieve and analyze in terms of
characteristics, or attributes, of dimensions. For example, you can analyze product
profitability based on size or packaging. Attribute dimensions are associated with
base dimensions.

Y ou can use an attribute dimensionto drill down on the base dimension withwhich
it is associated. In the Sample Basic database, the Product base dimension is
associated with several attribute dimensions, such as Caffeinated, Ounces, and
Pkg_Type. Each attribute dimension consists of level O attribute members. Level
0 attribute members are the lowest level attributes that are associated with
members of a base dimension. The Pkg_Type attribute dimension, for instance,
has two level 0 members, Bottle and Can.

Y ou can extract information on all products sold in a can by entering manually
the name Can in the worksheet. Y ou can a so use Essbase Query Designer or the
Essbase Member Selection dialog box to select the attribute and display it in the
worksheet.
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Open aworksheet, connect to the Sample Basic database, and select
Esshase > Retrieve. Select Product and replace it with Can by typing Can
manually. Click anywhere outside of cell C1 and select Essbase > Retrieve
again. The result is displayed below:

Figure 21: An Attribute Member in a Report

A | B [ ¢ b | E
1 Measures Can Market | Scenario
2 |VYear 39578

Drill down to all products sold in acan by double-clicking Canin cell C1. Cola,
Diet Cola, and Diet Cream are the members of Product that have the Can attribute.
The result is displayed below:

Figure 22: Result of Drilling Down on an Attribute Member

A [ B | € [ o | E [ F
1] l Weaswes Market | Scenario
| 2 |Year Can Cala 2577
| 3 | Diet Cola 5708
4 Diet Cream 11093

Drilling Down on Level 0 Attribute Members

The following is a description of the general behavior of Essbase Spreadsheet
Add-in when you drill down on alevel 0 attribute member:

e If thelevel O attribute member isin acolumn, adrill-down pivotsthe attribute
to the innermost row of the worksheet.

e If thelevel 0 attribute member isin arow, adrill-down does not change the
position of the attribute in the worksheet.

e A drill-down on alevel 0 attribute member displays the associated base
members to the right of the level 0 attribute.

e |If thereismorethan onelevel 0 attribute member in aworksheet, adrill-down
on one attribute displays other attributes to the |eft of the level 0 attribute
member. Level 0 attribute members in columns pivot to rows, and level 0
attribute members already in rows remain in rows.

e A drill-down on non-level 0 attribute membersisthe same asthe current drill-
down behavior for other types of members.
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The drill-down behavior for non-level 0 attribute members is the same as the
current drill-down behavior for other types of members. See the Esshase
Spreadsheet Add-in online help for examples of drilling down on level 0 attribute
members. For more information on attributes, refer to the Essbase Database
Administrator’s Guide.

Drilling Up to Less Detail

With Essbase, you can drill up to higher levelsin the multidimensiona database
outline by collapsing the current member tree. For example, if you previously
drilled down on adimension, such as Scenario, to view datafor Actual and Budget,
you may need to drill up to view aggregate data for the Scenario dimension.

Y ou have three options for drilling up on a member:
e Select the member and select Essbase > Zoom Out.
e Select the member and double-click the secondary mouse button.

e Select the member and click the Zoom Out button on the Essbase tool bar.

» Todrill up on the Scenario dimension in the current worksheet:

1. Onany member of the Scenario dimension (that is, cell C2, D2, E2, F2, or
G2), double-click the secondary mouse button.

Essbase collapses the members of the Scenario dimension.

Figure 23: Result of Drilling Up On the Scenario Dimension

A [ B [ € [ b [ E ] F [ 6 | H

L1 Measures Product

L2 | Scenario 1

L3 |East Gitrl 5380

4 | Gitr2 5459

5 | Q3 6346

6 | Citrd 5936

7 ‘ear 241681
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In cell A3, double-click the secondary mouse button to drill up on East.

Esshase collapses East, West, South, and Central into the single Market
dimension and keeps the dimension in the A column.

Figure 24: Result of Drilling Up On East

[ E [ F [ 6 [ H

A [ B ]

]

2

3 [Market  lCtr1
L4 | Qtr2
L5 | Qtr3
L6 | Qtrd

7 Year

Measures Product
Scenatio

Customizing Drill-Down and Drill-Up Behavior

Y ou can customize the behavior of the Zoom In and Zoom Out commands in the
Essbase Options dialog box. The following stepsillustrate some drill-down and
drill-up techniques.

» To retrieve all members of adimension with a single drill-down operation:
1. Select Essbase > Options and select the Zoom tab.

Essbase displays the Zoom Tab.

Figure 25: Zoom In and Member Retention Option Settings

—Zoom |n

" Bottom Level
' Sibling Level
' Same Level

" Same Generation
' Fomulas

— Member Retention
¥ Include Selection

™ ‘within Selected Group

™ Remove Unselected Groups

The Zoom | n option group contains items that enable you to customize
drilling behavior. Y ou can specify which members are returned to the
worksheet during a drill-down operation. For example, if you select Bottom
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Level, Esshase retrieves data for the lowest level of membersin adimension.
With thisoption, adrill-down on Y ear retrieves Jan, Feb, Mar, Apr, May, Jun,
Jul, Aug, Sep, Oct, Nov, and Dec.

The Member Retention option group contains items that enable you to
customize drilling retention characteristics. The default selection, Include
Selection, retai nsthe sel ected member a ong with the other membersretrieved
asaresult of adrill down. For example, if you drill down on Qtrl, Essbase
retrieves data for Jan, Feb, and Mar, as well asfor Qtrl. When this option is
disabled, Essbhaseretrievesdataonly for Jan, Feb, and Mar; Qtrl iseliminated.

Note: For more information on the Zoom In and Member Retention option groups,
see the Essbase Spreadsheet Add-in online help.

In the Zoom In option group, select the All L evels option and click OK to
save the setting.

In cell A3, drill down (double-click) on Market.

In cell C2, drill down (double-click) on Scenario.

Essbase retrieves all members of Market and Scenario. For the Market
dimension, Essbase drilled down two levels to get to the bottom-most
members, which are individual states. The Scenario dimension has only one
member level, so the members of Scenario would also be retrieved if you
selected Next Level in the Zoom In option group.

Figure 26: Result of Drilling Down to All Member Levels

I n 8 [ ¢ [ o [ E | F e [ ]

1 1 | Measuras Produst

2 Actual  Budget Variance Variance % Scenario
3 Mew York Gt 1656 2000 -344 -17.2 1656
4 Gitr2 2363 2610 -247 -9.46360153 2363
5 Gitra 1943 2290 -347 -16.1528384 1943
6 Gitrd 2240 2320 -80 -3.448275846 2240
7 Year g202 9220 1018 -11.0412148 g202
8 husetts Gt 1632 1690 -168 -9.34911243 1632
9 Gitr2 1750 1900 -180 -7.89473684 1750
10 Gitra 1936 2100 -164 -7.80952381 1936
11 Gitrd 1494 1610 -116 -7.20496894 1494
12 Year 6712 F300 588 -8.05479452 6712

5. Select Essbase > Options and select the Zoom tab.
6. Returnthe Zoom | n option setting to Next Level.

If you want to drill up on only one quarter of the year, select Within Selected

Group in the Member Retention option group.
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» Todrill up only on Qtrl:

1. Inthe Member Retention option group on the Zoom Tab, click the Within
Selected Group check box and click OK.

Make sure that I nclude Selection is aso still checked.
2. Todrill up on Qtr 1 (in cell B3), double-click the secondary mouse button.

Noticethat drilling up tothe Y ear dimension affectsonly New Y ork. All other
states show datafor all four quarters.

Figure 27: Result of Drilling Up Within a Selected Group

I n 8 [ ¢ [ o [ E | F e [ ]

1 1 | Measuras Produst

2 Actual  Budget Variance Variance % Scenario
3 Mew York Year g202 9220 1018 -11.04121478 g202
4 |Massachusetts  Gtrl 1632 1690 -168 -9.349112426 1632
5 Gitr2 1750 1900 -180 -7.894736842 1750
6 Gitra 1936 2100 -164 -7.80952381 1936
7 Gitrd 1494 1610 -116 -7. 204968944 1494
8 Year 6712 F300 588 -8.054794524 6712
9  |Florida Gt 1070 1300 -230 -17.69230769 1070
10 Gitr2 1339 1670 -2 -14.7133758 1339
11 Gitra 1495 1730 -235 -13.58381503 1495
12 Gitrd 1125 1300 175 -13.46163846 1125

3. Before moving on with the tutorial, disable the Within Selected Group
option:

a. Select Esshase > Options and select the Zoom tab.

b. Inthe Member Retention option group, clear the Within Selected
Group check box.

4. Select File > Close to close the worksheet. You do not need to save the
worksheet.
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Pivoting, Retaining, and Suppressing Data

After you retrieve datainto the worksheet, you may want to manipulatethe datain
various ways. For example, you may want to move rows and columnsto different
positions in the worksheet, or you may want to tell Essbase to suppress or retain
specific data during dataretrievals.

60 W

To help you manipulate worksheet data, this section steps you through the
following procedures:

“Pivoting Rows and Columns’ on page 60

“Retaining a Data Subset” on page 64

“Removing a Data Subset” on page 67

“Navigating Through the Worksheet Without Retrieving Data” on page 67

“Suppressing Missing Values, Zero Values, and Underscore Characters’ on
page 72

Pivoting Rows and Columns

With the Pivot command, you can change the orientation of worksheet data. Use
the Pivot command to do any of the following:

Move arow group to a column group
Move a column group to arow group
Change the order of row groups

Change the order of column groups

Y ou can execute the Pivot command in two ways:

Select the member cell that you want to pivot, and select Essbase > Pivot. This
method applies only to moving a row group to a column group or acolumn
group to arow group.

Click in the center of the member cell that you want to pivot, press and hold
the secondary mouse button, and drag the group to the desired location. This
method appliesto swapping row and column groups and to changing the order
within groups.
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» To pivot Year datafrom arow group to a column group:

1. To open anew worksheet, select File > New or click the QI icon.

Note: You should already be connected to the Sample Basic database. If you are
not connected, follow the steps in “Connecting to a Database” on page 47.

Select Essbase > Retrieve.

3. Drill down (double-click) on Measures and Product (in cellsB1 and C1,
respectively).

4. Pressand hold the Alt key, and, in cell E1, drill down (double-click) on
Scenario.

Figure 28: View Before Pivoting

A B [Cc] D [ E [ F [ G [ H |
L1 tarket
L2 | Actual Budget Wariance “arance % Scenario
L3 [100 Profit Wear 30465 415840 -11472) -27 35336195 30465
4 | Inventary Wear 29445 31590 2142 6780626751 29445
5 | Ratios Year 5727288145 &7 6240049 0351123447 -0.609335377 67 27288145
6 | Measures fear 30465 415840 -11472) -27 35336195 30465
|7 [200 Profit Wear 27554 35540 7996 -22.24200275 27554
I8 | Inventary Wear 33000 31090 -1910) -6.1434544687 33000
9 | Ratios Year 5553966595 57 46674162 -1.927075664 | -3.353375551 5553966595
10| Measures fear 27554 35540 7996 -22.24200275 27554
|11 {300 Profit Wear 25799 29360 3861 -12.1287 4659 25799
12 | Inventary Wear 26865 27140 -1725) -6.355932203 26865
113 | Ratios Wear 5423795671 57.13950487 -2.9015458161 -6.078007152 54 23795671
|14 | Measures fear 25799 29360 3861 -12.1287 4659 25799
|15 [400 Profit Wear 213M 22130 -829| -3.746046091 213M
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5. Incell C3, seect Year and select Essbase > Pivot.

Figure 29: Result of Pivoting a Row Group to a Column Group

A B [ C [ D [ E [ F |
L1 ‘fear tarket
L2 | Actual Budget Wariance “ariance %
L3 [100 Profit 30465 415840 -11472) -27 35336195
4 | Inventary 29445 31590 2142 6780626751
5 | Ratios 5727288145 &7 6240049 -0.351123447 | -0.609335377
6 | Measures 30465 415840 -11472) -27 35336195
|7 [200 Profit 27554 35540 7996 -22.24200275
I8 | Inventary 33000 31090 -1910) -6.1434544687
9 | Ratios 55.53966595 57 46674162 -1.927075664 | -3.353375551
10| Measures 27554 35540 7996 -22.24200275
|11 {300 Profit 25799 29360 3861 -12.1287 4659
12 | Inventary 26865 27140 -1725) -6.355932203
113 | Ratios 54.2379567 1 57.139504587 -2.9015458161 | -6.075007152
14 | Measures 25799 29360 3861 -12.1287 4659

6. Asanother example, in cell C2, select Actual.
7. Right click and drag Actual to product 100 in cell A3.

Figure 30: Pivoting a Column Group to a Row Group

A B [ C [ D [ E [ F |
L1 ‘fear tarket

2 Actual Budget Yariance Yariance %

3 100 [sctual Budget Yariance Yariance% Scenario| 1472 -27.35336135
L4 | Trventary iR E 3190 2142 B.780626731
5 | Ratios 5727288145 &7 6240049 -0.351123447 | -0.609335377
6 | Measures 30465 415840 -11472) -27 35336195
|7 [200 Profit 27554 35540 7996 -22.24200275
I8 | Inventary 33000 31090 -1910) -6.1434544687
9 | Ratios 55.53966595 57 46674162 -1.927075664 | -3.353375551
10| Measures 27554 35540 7996 -22.24200275
|11 {300 Profit 25799 29360 3861 -12.1287 4659
12 | Inventary 26865 27140 -1725) -6.355932203
113 | Ratios 54.2379567 1 57.139504587 -2.9015458161 | -6.075007152
14 | Measures 25799 29360 3861 -12.1287 4659

Note: The member label box that is displayed under the cursor during the pivot
operation displays the names of the members that you are pivoting. The orientation
of the member label box, however, does not determine the orientation of the pivot
result. Essbase determines the data orientation by the location of the destination
cell.

62 W Essbase Spreadsheet Add-in for Excel



A Basic Essbase Tutorial

Essbase pivots the Scenario members (Actual, Budget, Variance, and
Variance%) from a column group to arow group that is displayed to the left
of the Product members.

Figure 31: Result of Pivoting a Column Group to a Row Group

A [ B ] C [ D [ E ] F |
L1 ‘fear tarket
2 |Actual 100 Profit 30465
3 I Inventary 29445
4 | Ratios 57. 27288145
L9 | Measures 30465
6 | 200 Profit 27554
L7 | Inventary 33000
I8 | Ratios 55.53966595
L9 | Measures 27954
10| 300 Profit 25799
11| Inventary 28865
12 | Ratios 54.2379567 1
113 | Measures 26795
14 | 400 Profit 213M

» To transpose the order of row groups:
1. Incel A2, select Actual.
2. Right-click and drag Actual to Profit (cell C2).

Figure 32: Pivoting the Order of Row Groups

A [ B [ C [ D [ E ] F [ G |

L1 ‘fear tarket

| 2 |Actual 100 [Eroft_Betual Budget Variance Variance% Scenario|
L3 | Inventary iR E

4 | Ratios 57. 27288145

L9 | Measures 30465

6 | 200 Profit 27554

L7 | Inventary 33000

I8 | Ratios 55.53966595

L9 | Measures 27954

10| 300 Profit 25799

11| Inventary 28865

12 | Ratios 54.2379567 1

113 | Measures 26795

|14 | 400 Profit 213M

115 | Inventary 26032

|16 | Ratios 53.59966755
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The pivot changes the order of the row groups.

Figure 33: Result of Pivoting the Order of Row Groups

A B [ C [ D E | F |
L1 ‘fear tarket
L2 [100 Profit IActuaI _| 30465
3 | Budget 415840
L4 | Wariance -11472
L9 | “arance % -27 35336195
L6 | Scenario 30465
L7 | Inventary Actual 25445
I8 | Budget 31590
L9 | Wariance 2142
|10 | “arance % 670626731
11| Scenario 25445
|12 | Ratios Actual a7 27285145
113 | Budget 57 6240043
|14 | Wariance -0.351123447
115 | “arance % 0605335377
|16 | Scenario | 57 27285145

In this example, notice that both the source cell and the destination cell are
now members. Whenever the source cell and the destination cell are members
of different row groups, Essbase exchanges the member groups. Y ou must
select a destination cell that contains a member name to exchange row
members. Y ou can also exchange column members by choosing adestination
cell in another column that contains a member name.

Retaining a Data Subset

The Keep Only command retains only selected member rows or columns and
removes all other data from the worksheet view. This command provides a
powerful way to remove dimensional slices without having to delete individual

cdls.
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» To keep only Actual and Budget data in the current worksheet:
1. Incel C2, select Actual and, in cell C3, select Budget.

Figure 34: Selecting Members for the Keep Only Command

A B [ C [ D [ E [ F
L1 ‘fear tarket
L2 [100 Profit Actual 30465
3 | I} 415840
L4 | Wariance -11472
L9 | “arance % -27 35336195
L6 | Scenario 30465
L7 | Inventary Actual 25445
I8 | Budget 31590
L9 | Wariance 2142
|10 | “arance % 670626731
11| Scenario 25445
|12 | Ratios Actual a7 27285145
113 | Budget 57 6240043
|14 | Wariance -0.351123447
115 | “arance % 0605335377
|16 | Scenario | 57 27285145

2. Select Esshase > Keep Only.

A B [ € ] D [ E [ F
L1 ‘fear tarket
L2 [100 Profit Actual 30465
3 | I} 415840
L4 | Inventary Actual 25445
5 | Budget 31590
L6 | Ratios Actual | 67 27283145
L7 | Budget | 57 6240043
L8 | Measures Actual 30465
9 | Budget 415840
|10/ {200 Profit Actual 27554
11| Budget 35540
|12 | Inventary Actual 33000
113 | Budget 31090
|14 | Ratios Actual | 55535966595
115 | Budget | 57 46674162
|16 | Measures Actual 27954

Occasionally, the datathat you want to remove from the worksheet doesnot liein
an adjacent range of cells.
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» To select and retain nonadjacent cells.

1.
2.

Press and hold the Alt key, and, in cell D1, zoom in (double-click) on Year.
Select Qtr2 (in cell E2).
Press and hold the Ctrl key and select Qtr4 (in cell G2).

Figure 36: Selecting Nonadjacent Members for the Keep Only Command

B [ C D E [ F [ G |
1
2| atrt
L3 [100 Profit Actual 7048 7872 8511 7037
4 | Budget 9780 10660 11440 10050
L9 | Inventary Actual 25445 25860 36461 35811
6 | Budget 31590 29550 34830 32340
L7 | Ratios Actual | 67 40178857 67 28473167 57 395509978 56.99467561
I8 | Budget | 57 7376566 57.39041794 57 45231167 57 96344648
L9 | Measures Actual 7043 7E72 3511 7037
10| Budget 9780 10660 11440 10050
|11 [200 Profit Actual 6721 7030 70048 7158
12 | Budget 8480 8540 8530 9800
113 | Inventary Actual 33000 31361 35243 3Z7E0
|14 | Budget 31090 28040 30260 26460
115 | Ratios Actual | 5538738674 5549797453 55.06764011 ) 56.21773123
|16 | Budget | 57 36255286 57.40395375 57.111436%6 57 9954955
17 | Measures Actual G721 7030 7005 7193

Figure 37: Result of Retaining a Data Subset (Nonadjacent Cells)

B [ C D E [ F [ G |

L1 tarket

L2 | Qtr2 Oitrd

L3 [100 Profit Actual 7872 7037
4 | Budget 10660 10050
L9 | Inventary Actual 25860 35811
6 | Budget 29550 32340
L7 | Ratios Actual | 67 28473167 56.99467561
I8 | Budget | 57.390417594 57 96344645
L9 | Measures Actual 7E72 7037
10| Budget 10660 10050
|11 [200 Profit Actual 7030 7158
12 | Budget 8540 9800
113 | Inventary Actual 31361 3Z7E0
|14 | Budget 28040 26460
115 | Ratios Actual | 5549797453 56.21773123
|16 | Budget | 57.40395375 57 9954955
17 | Measures Actual 7030 7193
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Removing a Data Subset

The Remove Only command is the counterpart to the Keep Only command. With
Remove Only, you can remove selected member rows or columns and retain all
other data in the worksheet view.

A Basic Essbase Tutorial

» To remove a data subset from the current worksheet view:

1. Incell B7, select Ratios.

2. Pressand hold Ctrl, and, in cell B9, select Measures.

3. Select Essbase > Remove Only.

Esshase removes data for Ratios and Measures but retains data for Profit and

Inventory.

Figure 38: Result of Removing a Data Subset

A | B [ cJ oD E [FIG[HT]1]

L1 tarket

L2 | Qtr2  Citrd
L3 [100 Profit  |Actual | 7872 7037
4 | Budget | 10660 100&0
L9 | Inventory Actual | 259860 35311
6 | Budget | 29950 32340
|7 [200 Profit  |Actual | 7030 7198
I8 | Budget | 5840 59800
L9 | Inventory Actual | 31361 32760
10| Budget | 25040 26460
|11 {300 Profit  |Actual | B763)  B403
12 | Budget | 7680 7000
113 | Inventary Actual | 30334 35142
14 | Budget | 28460 35460

Navigating Through the Worksheet Without

Retrieving Data

With the Navigate Without Datafeature, you can perform navigational operations,
such as pivot, zoom in, zoom out, keep only, and remove only, without retrieving

any data into the worksheet.

Thisfeatureisespecially useful when dealing with dynamic cal culation members,
which are usually specified by the application designer. By activating Navigate
Without Data, you are effectively telling Essbase not to dynamically calculate
values (that is, calculate the database at retrieval time) while you are creating the
spreadsheet report. Dynamic calculation is discussed in more detail in “Retrieving

Dynamic Calculation Members’ on page 160.
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» To navigate through the worksheet without retrieving data:
1. Select Essbase > Navigate Without Data.

Essbase displays a check mark next to the menu item.

Note: You can also enable Navigate Without Data by selecting the appropriate
option in the Essbase Options dialog box (Global Tab) or by clicking the Navigate
Without Data button on the Essbase toolbar (Excel only).

2. Incell D2, double-click the secondary mouse button to drill up on Qtr2.

Essbase shows the collapsed Y ear dimension but withholds retrieving any
datathat is changed as aresult of drilling up. The cells where data would
normally be displayed are blank.

Figure 39: Result of Zooming Out (Navigate Without Data Enabled)

A [ B [c[D[ETJF[G[H]I]
L1 tarket
L2 | ‘fear
L3 (100 Prafit Actual
L4 | Budget
L9 | Inventary Actual
L6 | Budget
¥ (200 Prafit Actual
L8 | Budget
L9 | Inventary Actual
|10 | Budget
|11 (300 Prafit Actual
|12 | Budget
113 | Inventary Actual
14 | Budget

3. Incell D2, drill down (double-click) on Year by pressing and holding the Alt

x
2

Essbase drills down without retrieving data.
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4. InCell C3, select Actual and select Essbase > Pivot.
Esshase executes the pivot but does not retrieve data.
Note: You get the same result by pivoting any of the other Scenario members.
Figure 40: Result of Pivoting (Navigate Without Data Enabled)
A | B [c|[p[] EJF] G [H[I1] J JTEJL]
L1 tarket
L2 | I _lActuaI Budget
L3 | Otrl Qe Gtr3 Oted Year Ol Ot Qb3 Qtrd Year
4 |00 Profit
L9 | Inventary
6 |200 Profit
L7 | Inventary
'8 |00 Profit
L9 | Inventary
[0 ]400 Profit
11| Inventary
|12 |Diet Prafit
113 | Inventary
14| Product Profit
5. Incell G1, click the secondary mouse button on Market and drag Market to

product 100 (cell A4).

Essbase executes the pivot without retrieving data.

Figure 41: Result of Pivoting (Navigate Without Data Enabled)

A [ B [ C

[DTET F

[GIH] VI TJ] K L]

Market 100 Profit
I Inventary
200 Profit
Irventory
Profit
Irventory
Profit
Irventory
Profit
Irventory
Profit
Irventory

300

400

Diet

Product

TEEEE

Actual
Qtrl Q2 Otr3

Budget

Qtrd [ Year Qtrl Ot2 Qi3 Otrd

Navigating without data also works with the Keep Only and Remove Only

commands.
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» To navigate without data when using the Kegp Only or Remove Only command:
1. Select Qtrl (cell D2) and Qtr2 (cell E2) and select Essbase > Keep Only.

Essbase retains only the selected members and does not retrieve data.

Figure 42: Result of Keep Only (Navigate Without Data Enabled)

[E] F

Al B ]
1]
| 2 |
L3 [Market 100
1 4]
5 | 200
6 |
L7 | 300
I8 |
9 | 400
10|
11| Diet
12 |
113 | Praduct

Profit
Irventory
Profit
Irventory
Profit
Irventory
Profit
Irventory
Profit
Irventory
Profit

[G[HT 1 ]J]
Budget
B Ctr Qtr2

2. Select products 300 (cell B7), 400 (cell B9), and Diet (cell B11) and select

Essbase > Remove Only.

Essbase executes the Remove Only command without actually querying the

database for information.

Figure 43: Result of Remove Only (Navigate Without Data Enabled)

Al B ]

C

[E] F

[GIH ]V [J]

Market 100

200

70 B

Product
L

Profit
Irventory
Profit
Irventory
Profit
Irventory

Budget

Qtr2 Q1 Qtr2
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» To turn off Navigate Without Data when you are ready to retrieve data:

1.

Select Essbase > Navigate Without Data.

Essbase removes the check mark next to the menu item.

Note: You can also disable Navigate Without Data by clearing the appropriate
option in the Essbase Options dialog box (Global Tab) or by clicking the Navigate
Without Data button on the Essbase toolbar (Excel only).

In cell A3, drill down (double-click) on Market.

Essbase drills down on the Market dimension and also retrieves datainto the
worksheet.

Figure 44: Result of Drilling down (Navigate Without Data Disabled)

A [ B [ € [ b JETJ]FJ[66 [JHTIL]

L1 Actual Budget

2 Qitrl Qtr2 Gt Qtr2
3 |East l100 Prafit 2747 33520 2880 3480
L4 | Inventory 5384 4450 5200 3530
L5 | 200 Prafit 562 510 950 1070
L6 | Inventory 5957 B442 5610 5910
L7 | Product | Profit 5380 6429 G500 7sE0
L8 | Inventory 25744 26214 24710 24030
L9 |West 100 Prafit 1042 849 2380 2130
|10 | Inventory B892 9656 10250 10950
11| 200 Prafit 2325 2423 25700 220
1112 | Inventory 11755 11643 11070 10900
|13 | Product | Profit 7137 7815 8960 9290
14 | Inventory | 35751 41574 39020 42820

Note: If you want to retrieve data without changing the current worksheet view,
you can also retrieve data by simply double-clicking in any data cell or by
selecting Essbase > Retrieve (after disabling Navigate Without Data).
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Suppressing Missing Values, Zero Values, and
Underscore Characters

Severa types of data can be returned to aworksheet view:
e Numeric datavalues

e #NoAccess strings, which are displayed when you do not have the proper
security accessto view adata value

e #Missing strings, which indicate that no data exists for that member
intersection

e Zerodatavalues

A missing valueis not the same as a zero value that is|oaded into the Essbase
database. When data does not exist for adata cell in Essbase, avalue of #Missing
isreturned to the worksheet. If any cell in arow contains avalue, that row is not
suppressed on aretrieval.

With Essbase, you can suppress missing and zero values from the display in the
worksheet. In addition, you can tell Essbase to suppress underscore charactersthat
arein some member names.

» To suppress rows that contain missing values from displaying in the worksheet:
1. Incell C3, double-click the secondary mouse button to drill up on Profit.

2. Pivot Measures (in cell C3) to Actua (in cell D1).
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3. Incell B4, drill down (double-click) on product 100.

Notice that, in the South, the product 100-30 row contains al missing val ues,
indicating that this product is not sold in the South. Y ou may need to scroll

down the worksheet to see this row.

Figure 45: Worksheet View Displaying Missing Data Values

A B [ ¢ [ o | E [ F J6 |
L1 Measures
L2 | Actual Budget
L3 | Qtrl Qtr2 Qtrl Qtr2
|4 |East 100-10 2461 25940 2580 3050
L5 | 100-20 212 303 220 300
L6 | 100-30 74 109 110 130
L7 | 100 2747 3352 2880 3480
L8 | 200 562 510 250 1070
L9 | Product 5380 5493 G500 75480
|10 |WWest 100-10 1047 1189 1720 1200
11| 100-20 £7 177 320 200
1112 | 100-30 52 -163 310 30
|13 | 100 1042 849 2350 2130
|14 | 200 2325 2423 2570 2720
|15 | Product 7137 7515 8560 290
|16 | South 100-10 745 835 1160 1280
|17 | 100-20 306 363 570 560
|18 | 100-30 #dissing #lissing | #Missing #lissing

Select Essbase > Options, and select the Display tab.

In the Suppress option group, select the #Missing Rows check box and

click OK.

Note: The Suppress #Missing Rows and Zero Rows options are not available
when any of the Formula Preservation options are selected in the Essbase Options

dialog box. For more information on Formula Preservation, see “Preserving

Formulas When Retrieving Data” on page 149.
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6. Select Essbase > Retrieve to update the worksheet.

Note: After you change a worksheet option in the Essbase Options dialog box, you
must perform a retrieval or drill operation to have the new setting take effect.

Essbase suppresses product 100-30 from the South member group.

Figure 46: Result of Suppressing Missing Data Values

A B [ €] b | EJTFEJ]G [H]T1]
| 4 [East 100-10 2461 2940 2550 3080
15 | 10020 212 303 2200 300
| 6 | 100-30 74 103, 110 130
| 7 | 100 2747 3352 2880 3480
| 8 | 200 E62 610 960 1070
EN Product| 5380 E499 6500 7540
|10 [west 100-10 1047 1183 1720 1800
K 10020 7 77 320 20
|12 | 100-30 £2 163 30 @0
|13 | 100 1042 849 2350 2130
|14 | 200 2325 2423 2570, 2720
|15 | Product| 7137 7515 8960 9290
|16 |South 100-10 745 835 1160 1280
|17 | 10020 306 33 570 6D
|18 | 100 1051 1198 1730 1940
|19 | 200 1465 1540 1640 1700
|20 | Product| 3077 3267 41800 4410
|21 |central 10010 843 928 1080/ 1180

7. Select File> Close to close the worksheet. You do not need to save
the worksheet.

Note: After you enable the Suppress #Missing Rows feature in the Essbase
Options dialog box, any missing values suppressed during a data retrieval are not
retrieved again by simply disabling the feature. If you disable the feature in the
Essbase Options dialog box, missing values are retrieved from only that point on.
For example, in the tutorial task described above, Essbhase could not go back and
return the missing values for product 100-30. To return these missing values to the
worksheet, you disable the Suppress #Missing Rows feature, drill up on a Product
member, and then drill down again.

Y ou can also suppress zeros and underscore characters as described in the task
above by clicking the appropriate options in the Suppress option group in the
Essbase Options dia og box (Display tab).

In addition to suppressing specific values and characters during retrieval, Essbase
enables you to define alabel for missing values (#Missing) or for data you do not
have access to (#NOAccess). If you define a replacement label for these val ues,
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Esshase displays the replacement labelsinstead of the default labels. For more
information on defining replacement labels for the #Missing and #NoA ccess
labels, see the Essbase Spreadsheet Add-in online help.

Formatting the Worksheet

Essbase provides you with various ways to customize the worksheet view. For
example, you may want to apply visual cues, or styles, to certain member names
or to data cellsin the worksheet, or you may want to display alternative names, or
aliases, for member names. This section steps you through the following
formatting procedures:

e “Formatting Text and Cells’ on page 75

e “Displaying Aliases for Member Names’ on page 85

e “Displaying Both Member Names and Aliases’ on page 87
e “Repeating Member Labels’ on page 88

This section of the tutorial starts with a new worksheet.

Formatting Text and Cells

In a spreadsheet report, you may have many hierarchical levels of database
information displayed. By defining and applying visual cues, or styles, to the
text and cellsin the worksheet, you can easily keep track of specific database
members, dimensions, and cell functions. Styles are a great way to help view
and distinguish datain Essbase Spreadsheet Add-in.

Note: Keep in mind that applying styles requires additional processing during a
retrieval request. For more information, see “Removing Styles” on page 84.
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This section of the tutorial describes the following:

“Applying Stylesto Parent Members’ on page 76

“Applying Styles to Dimension Members’ on page 79
“Applying Stylesto Data Cells’ on page 82

“Determining the Precedence of Overlapping Styles’ on page 83
“Removing Styles’ on page 84

Note: For a discussion of the relationships among Essbase database members, see
“Database Outlines” on page 25.

Applying Styles to Parent Members

Each dimension in a database may contain alarge number of hierarchical levels.
Asyou view data in the worksheet, you may not be familiar with all the
hierarchical levels of the database outline. To indicate which members have
underlying children, you can apply formatting stylesto parent members, including
those with attributes.

» To apply stylesto parent members:

76 &

To open anew worksheet, select File > New or click the QI icon.
Select Esshase > Retrieve.

Note: You should still be connected to the Sample Basic database. If you are not
connected, follow the steps in “Connecting to a Database” on page 47.

In cell A2, drill down (double-click) on Year.

Select Essbase > Options.
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5. Inthe Esshase Options dialog box, select the Style tab.
Note: The Style tab is available only when you are connected to a database.
Esshase displays the Style tab.

Figure 47: Essbase Options Dialog Box, Style Tab

Essbase Options E

Displayl Zoom I Mode  Style |GIObaI|

— Member
" — Sample
[ Chid Farent
[ Shared

— Dimenszion

cd
v Measures

v Product LI

— Sample
Year
¥ Cell Border
Background Color: I Mone j Format... |

— Drata Cell

— Sample

[mllLirked Objects
[ Integration Server Drill-Thraugh

[ Read Only LI
Farmat.. |

Connection Information:
’7 Localhost:S ample: B azic ‘

QK | Cancel | Help |

In the Members area, you can define styles for various types of database
members, such as parent, child, and shared members.

6. Inthe Membersgroup box, select the Parent check box.

Clicking this box defines afont and color style for parent member names.
Essbase defines adefault color of navy for all parent members. Y ou can select
afont format by clicking the Format button to the right of the Members box

and using the Font dialog box.
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7. Click the Format button.
Esshase displays the Font dialog box.
Figure 48: Font Dialog Box

Font

Font: Font style:
| Bold
M Albertus Extra Bold |« [Regular

T Albertuz Medium |talic
Anna Eold
T Antique Olive Bold Italic
% Avial
Avial Black
T Arial Narmow LI
— Effect: — Sample

[ Stikeout
™ Underline
Lolor:

I- Mawy vl Script:

8. IntheFont stylelist box, select Bold and then click OK.

Note: Essbase displays an example of the selected style in the Sample box.

9. Click OK again.

Even though you have defined styles, they are not enabled until you select the
Use Styles check box from the Essbase Options dialog box and refresh the
worksheet.

10. Select Esshase > Options, and select the Display tab.

11. Inthe Cells option group, select the Use Styles check box to enable your
styles, and then click OK.

12. Select Essbase > Retrieve to refresh the worksheet and apply the styles.
Esshase displays parent member names in bold, navy font.
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13. Incell A2, drill down (double-click) on Qtr1.

Esshase displays Jan, Feb, and Mar in aregular font, because these members
do not have underlying children.

Figure 49: Styles Applied to Parent Members

A [ B [ ¢ | 0 [ E ]
|1 Measures Product  Market  Scenario
| 2 [Jan 8024
| 3 |Feb 5346
| 4 [Mar 5333
15| Qut 24703
|6 | Qa2 2na7
|7 Qul 27912
18| ot 25500
| 9 | Year | 105522

Applying Styles to Dimension Members

In addition to applying styles to parent members (as you did in the previous
section), you can aso apply styles to members of a dimension in a database.
Applying styles to dimensions makes it easy to view the various dimension
members in Essbase Spreadsheet Add-in.

» To apply stylesto dimensions:
1. Select Essbase > Options and select the Style tab.
2. Inthe Dimensions group box, select Year.

3. Select the Cell Border check box to create a border around each cell that
contains a member from the selected dimension.
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4.

9.

From the Background Color list box, select Yellow.

Figure 50: Selecting a Background Color from the Style Tab

Essbase Options E
Display I Zoom I Mode  Style | Global I
— Member
Attribute: — Sample
- P
arent
[ Chid
LjShared LI Farmat. |
— Dimenszion
Dimension: - Sample
v
[ Measures Year
I Product LI
¥ Cell Border
Background Color: ||:| ellow - Format... |
—Data Cells =
Attribute: — Sample
Farmat.. |
Connection Information:
’7 Poplar. 5 ample:Basic ‘

QK I Cancel | Help |

Click the For mat button that is to the right of the Dimensions list. Essbase
displays the Font dialog box.

From the Font style list box, select Bold, and then click OK.
Note: Essbase displays an example of the selected style in the Sample box.
From the list of dimensions, select the Measures dimension and, from the

Background Color list box, select Fuschia.

From the list of dimensions, select Product, and clear the Cell Border check
box.

From the Background Color list box, select Aqua.

10. Scroll down thelist of dimensions, and select Market.
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11. Select the Cell Border check box, and click the For mat button that is to the
right of the Dimensions list.

When the Font dialog box is displayed, from the Font style list box select

Italic, and then click

OK.

12. Fromthelist of dimensions, select Scenario, and from the Backgr ound Color

list box, select Red.

13. Click the Format button, and from the Color list box, select White.
14. Click OK twiceto return to the worksheet.

Note: When you define styles, your choices are saved to the essbase. i ni file

on your local machine. You can define one set of styles per database.

15. Incell D1, drill down (double-click) on Market.
16. Press and hold the Alt key and drill down (double-click) on Scenario (in

cell EY).

17. Select Esshase > Retrieve to refresh the worksheet.

Essbase redisplays the worksheet and implements the newly defined styles.
For example, members of the Scenario dimension are displayed with ared

background.

Figure 51: Dimensions with Styles Applied
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A [ B C D | E F G|
|1 Product
2 | . udge Variance 8[|
| 3 |East Jan 732 -16.7308 1732
| 4 | Feh 1843 2230 -387 -17.3543 1843
| 5 | Mar 1805 2190 -385 -17.5799 1805
| B | Qtrt 5330 B500 1120) -17.2308 5330
17| Qtr2 B499 7550 1051 -13.9205 B499
| & | Qtr3 346 7550 1204 -15.947 346
ER Qtrd 5936 B790 -B54 -12.5773 5936
|10 Year 24161 28390 4229 -14.8961 24161
| 11 | West Jan 2339 2980 641 -21.5101 2339
112 Feh 2384 2990 596 -19.9331 2384
|13 | Mar 2404 2990 586 -19.5957 2404
| 14] Qtrt 7137 B9B0|  -1823] -20.346 7137
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Applying Styles to Data Cells

Y ou can apply stylesto data cells, such as read-only cells, read/write cells, linked
object cells, and Essbase I ntegration Server drill-through cellsto distinguish them
from other cellsin the worksheet. The Sample Basic database that you are using
for thistutorial does not contain data cells with any of these characteristics. In the
advanced tutorial presented in Chapter 3, you attach alinked reporting object to a
data cell and apply astyleto the cell.

Note: You cannot perform the actions in shaded boxes.

In general, you apply styles to data cells by following these steps:

1.
2.

Select Essbase > Options, and select the Style tab.

In the Data Cells option group, select the Linked Objects, I ntegration
Server Drill-Through, Read Only, or Read/Write check box.

Click For mat.

In the Font dialog box, specify thefont, font size, font style, color, and effects,
and click OK.

Note: Essbase displays an example of the selected style in the Sample box.

Data Cells

Sample———————————
[ElLinked Objects ample
I Integration Server Drill-Through Linked Ohjects

[ Read Only LI

Figure 52: Sample Style for Read/Write Data Cells

Repeat steps 2—4 to set styles for other data cells.

Select the Display tab and select the Use Styles check box to apply stylesto
the worksheet.

Click OK to close the Essbase Options dialog box.
Select Essbase > Retrieve to display the new stylesin the worksheet.
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Determining the Precedence of
Overlapping Styles

The only way you can apply a background color to dataisto define a style for
dimensions. If dimension styles are defined, and the Use Styles setting is turned
on, members of a dimension aways have the background color defined for their
dimension.

The text styles that you can apply to members, dimensions, and data cells have a
hierarchy that determines which characteristics are applied. Member styles are at
thetop of that hierarchy. Thus, member styles are dways applied (aslong as styles
areturned on). Note that in Figure 51, the Qtrl label in cell B6isin bold, navy
font, and has ayellow background. The navy font comesfrom the style defined for
parent members, and the yellow background comes from the style defined for

Y ear.

Essbase usesthefollowing order of precedence when applying multipletext styles:
e Linked object cells

e Integration Server Drill-Through cells
e Read-only cells

e Read/write cells

e Parent member cells

e Child member cédlls

e  Shared member cells

e Cellscontaining formulas

e Dynamic calculation member cells

e Attributecells

e Dimension cells

If you want to see a child member style, make sure that the parent member styleis
turned off. If you want to see a shared member style, make sure that both parent
and child member styles are turned off.
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Removing Styles

Styles can be very helpful tools for keeping track of datain Essbase Spreadsheet
Add-in. Applying styles, however, involves additional processing time during a
retrieval request. This additional processing has a slight impact on the speed of
Essbase retrievals.

If you do not want to apply stylesto the worksheet view, you can clear them. You
can a'so turn off styles so they are not displayed when you refresh the view (by
selecting Essbase > Retrieve, for example). So that the worksheet matches the
illustrations presented in the following tasks, do not remove stylesif you are
stepping through the tutorial.

Note: If you have styles applied to the worksheet and you execute the FlashBack
command, these styles are temporarily removed from the current view. The styles are
re-applied whenever you initiate a retrieval. You cannot perform the actions in shaded
boxes.

» Toremove al styles from aworksheet:

1. Select dl cellsin the worksheet.
2. From the Excel menu bar, select Edit > Clear > Formats.

» Todisable styles:

1. Select Esshase > Options and, select the Display tab.
2. Inthe Cells option group, clear the Use Styles check box, and click OK.

Note: If you turn styles off without clearing them from the worksheet, the styles remain
in the current worksheet view when you refresh the view. The styles remain to avoid
removing any styles that you may apply to individual cells using native worksheet
formatting options.
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Displaying Aliases for Member Names

Aliases are aternate names for database members. Y ou can create reports that use
the database member name, which is often a stock number or a product code, or an
alias name, which can be more descriptive. Aliases are defined by the Essbase
application designer. Each database can contain one or more alias tables.

For example, members of Product in the Sample Basic database are defined as
codes, such as 100 and 200. A descriptive alias for each member of Product, such
asColasand Root Beer, isdefinedinan aliastable. In some cases, alias names may
vary depending on the combination of other database members. For example, a
Product member may have adifferent aliasfor each market in whichit issold. For
more information, see the Essbase Spreadsheet Add-in online help or the Essbase
Database Administrator’s Guide.

» To display the alias of amember rather than its database name:

1. Incell C2, double-click the secondary mouse button to drill up on Actual.

2. Pressand hold the Alt key and drill down (double-click) on Product (in
cell D1).

Select Esshase > Options, and select the Display tab.

4. Inthe Aliases option group, select the Use Aliases check box to display
member aliases.
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5. Select Default from the Aliaslist box.

Figure 53: Enabling Aliases in the Essbase Options Display Tab

Essbase Options E

Display |Zoom I tode I Style I Globall

Indentation—————— ~ Feplacement

" Mone #higzing Label: I

' Subitems

& Totak #Mo Access Label: l—
— Suppre — Aliaze:

™ #Missing Fows V' Use Aliases

™ Zemo Rows ™ Use Both Member Names and Aliases

™ Underscore Characters far Row Dimensions
T Alias:

V' Use Styles IDefauIt j

V' Adiust Columng b

= Aute Sort Homs Query Designer

" Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic Time Serie
™ Latest Time Period IJan j

QK I Cancel Help

6. Click OK.
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Select Esshase > Retrieve to refresh the worksheet and display the alias
names.

Essbase changes the Product codes (100, 200, and so forth) to their predefined
aliases (Colas, Root Beer, Cream Soda, and so forth). In the Sample Basic
database, Product is the only dimension with predefined aliases.

Figure 54: Result of Displaying Aliases

A [ B [ ¢ [ D E F G
1

| 2 | Colas Root Beer Cream Soda  Fruit Sod: Diet Drinks
EX

| 4 |East Jan 924 158 184 466 181
| 5 | Feh B85 242 200 513 188
| 6 | Mar 935 162 207 501 189
|7 Qurt 2747 562 591 1480 555
| 8 | Q2 33582 610 922 1615 652
19| Qi3 3740 372 522 1712 G44
| 10 Qtef 2817 990 592 1537 567
| 11| Year 12656 2634 2627 5344 2408
| 12 |West Jan 378 762 785 454 BE3
| 13 | Feh 337 781 797 479 683
| 14 | Mar 327 792 811 474 679

Notice that Essbase is still displaying the styles that you created and applied
in the previous sections.

Displaying Both Member Names and Aliases

In addition to displaying aiases for database members, you can aso tell Essbase
to display both aliases and database member names in Essbase Spreadsheet
Add-in.

» To display the name and alias of a member:

1.

a r WD

Essbase Spreadsheet Add-in for Excel

In cell B8, double-click the secondary mouse button to drill up on Qtr2.
In cell C2, select Colas, and then select Essbase > Pivot.

In cell C3. select Year, and then select Essbase > Pivot.

Select Esshase > Options, and select the Display tab.

Inthe Aliases option group, select the check box for Use Both Member Names
and Aliases for Row Dimensions.

Be surethat Use Aliasesis already checked.
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6. Click OK to return to the worksheet, and select Essbase > Retrieve.

Esshase displays both member names and their aliases for row dimensions.
Because the only row dimension in this example that has preassigned aliases
is Product, only the Product members display their aliases. Region members
simply repeat the member name instead of displaying an alias.

Figure 55: Result of Displaying Both Member Names and Aliases

A [ B [ ¢ [ D ] E F

|1 Year

| 2 |

| 3 [T00 Colas East East 12656
| 4 | West West 3549
| 5 | South South 4773
| 6 | Central  Central 2490
| 7| Market  Market 30465
|8 [200 RootBeer  East East 2534
| 9 | West West 9727
| 10| South South G114
|11 Central  Central 9573
| 12 | Market  Market 27954
| 13 |300 Cream Soda Fast East 2627
| 14 | West West 10731
| 15 | South South 2350

Repeating Member Labels

By default, Esshase displays member labels only once for each nested row and
column group. If you are connected to alarge database when using Essbase
Spreadsheet Add-in, you may have to scroll down or across the worksheet to see
additional datarows and columns. In some cases, as you scroll down or across,
member labels may disappear from view. Essbase provides afeature for repeating
member |abels in each row or column cell that represents a data point so that you
can aways see amember label in the worksheet view.
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» To repeat member labels down and across the worksheet:
1. Select Essbase > Options, and select the Display tab.

2. IntheAliasesoption group, clear the Use Both M ember Namesand Aliases
for Row Dimensions check box.

3. Inthe Cellsoption group, select the Repeat Member L abels check box, and
then click OK.

Figure 56: Enabling the Repeat Member Labels Option

Essbase Options E

Display |Zoom I tode I Style I Globall

Indentation—————— ~ Feplacement

C Nore HiMissing Labet  [N/A

' Subitems

& Totsls #Mo Access Label: l—
— Suppre — Aliaze:

™ #Missing Fows V' Use Aliases

™ Zemo Rows ™ Use Both Member Names and Aliases

™ Underscore Characters far Row Dimensions
el Alias:

V' Use Styles IDefauIt j

¥

= Aute Sort Homs Query Designer

V¥ Bepeat Member Labels ’7|7 Use Sheet Options with Query Designer
— Dynamic Time Serie

" Latest Time Period IJan j

QK I Cancel Help

Essbase Spreadsheet Add-in for Excel M 89



A Basic Essbase Tutorial

90 N

In cell E1, drill down (double-click) on Year.

Essbase displaysamember label in every column and row cell. For the Sample
Basic database that you are using for this tutorial, repeating member labelsis
probably not necessary because the database is relatively small. This feature
is particularly helpful for keeping track of member labels when scrolling

through large worksheets.

Figure 57: Result of Repeating Member Labels
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Note: Even if you clear the Repeat Member Labels check box in the Essbase
Options dialog box, Essbase retains the repeated member labels in the worksheet
view. To remove the repeated labels, you need to do one of the following: (1) clear
the check box and open a new worksheet; (2) clear the check box and pivot the row
group to a column group and then pivot it back to a row group (or vice versa); or (3)
select Essbase > FlashBack and clear the check box.

Before returning to the tutorial, complete the following actions:
a. Select Esshase > Options, and select the Display tab.

b. Inthe Cellsoption group, clear the Repeat Member L abels check box,
and then click OK.

c. Select File> Closeto close the worksheet. You do not need to save the
worksheet.
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Creating Queries Using Essbase Query
Designer

So far, you have seen how easy it isto retrieve data and navigate through Essbase
Spreadsheet Add-in in an ad hoc fashion. Essbase also provides a query designer
so that you can define a database query for retrieving dimensions and database
membersinto the worksheet. Esshase Query Designer (EQD) isanew feature that
replaces Retrieval Wizard, used to define queries in previous versions of Essbase
Spreadsheet Add-in.

Before Hyperion Essbase actually retrieves data, Essbase Query Designer
provides a series of panels so you can regquest the data that you want to view in the
worksheet. It is particularly helpful when you know exactly which data you want
to retrieve from the server. In addition, you can save a query and use it again.

The Essbhase Query Designer window (Figure 58) consists of the following panels:

e Thenavigation panel provides accessto the variousfeaturesin Essbase Query
Designer. You can display all the dimensions used in a particular query and
access the various properties of each dimension member.

e Thehint panel provides abrief description of the feature that is selected from
the navigation panel.

e The properties panel provides access to the following functions:

— Layout: Design thelayout of the spreadsheet report. To change the default
layout, select adimension tile and drag it to one of the other dimension
boxes. To access the member select panel and to define a member for a
query, double-click adimension tile.

—  Member Sdlect: Select members that you want to display in the rows of
the spreadsheet report. To select a member, right-click the member, and
select Add to Selection Rules. You can also double-click amember to add
it to the selection rules.

— Member Filter: Filter the member selection by attribute, generation name,
level name, pattern string, or UDA.

— Data Filter: Retrieve rows of data. The retrieval is based on the ranking
of the rows within certain columns. Use this panel to access the data
restriction panel.

— DataRestriction: Filter databy comparing it to afixed datavalue, a set of
data values, or #Missing data values.
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— Data Sort: Sort rows in ascending or descending order. The sort is based
on column data values.

— Messages and Confirmation: Turn on and turn off certain messages from
Essbase Query Designer.

— Help: Access documentation about Essbase Query Designer.

Creating and Changing Queries

To access any of the Hyperion Essbase Query Designer panels, select the
appropriate feature listed in the navigation panel.

Asyou create a query or make changes to an existing query, the changes are
reflected in the navigation panel. To view a dimension or a member of an open
guery, click on the specific dimension or member in the query outlinethat is
displayed in the navigation panel. Selected members are displayed in the member
selection panel on the right.

Y ou can al'so revise an existing query in the member selection panel. For example,
you can delete amember or add a member to the query by selecting amember in
the navigation panel and making the appropriate changes in the properties panel.

Note: Files created using the obsolete Retrieval Wizard feature can be opened in
Essbase Query Designer. However, if a query contains more than two member filters
per selection rule or more than two data restrictions, the member filters may be out of
order. To ensure correct results, rearrange the member filters in the navigation panel, if
necessary.

For complete information on Essbase Query Designer options, see the Essbase
Spreadsheet Add-in online help.

CAUTION: Manipulation of worksheets in VBA such as naming worksheets
or moving worksheets may not work when EQD is running.
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Creating Queries

» To create a query using Essbase Query Designer:
1. Select Esshase > Query Designer.
Esshase displays the Essbase Query Designer welcome panel.
Figure 58: Essbase Query Designer Displaying Welcome Panel

r'} Hyperion Essbase Query Designer EHE
ED Spreadsheets - Excel

Hyperion Esshase Query Designer -
E@ Book! 808 teplaces the Retrieval Wizard to create
{gmt:: }g:eeﬂz O O repotts using a more advanced user
a0l eet,

interface. Use this feature to:
Hyperlon *  Create and modify spreadsheet

gueties.
*  Specify which dimensions display in LI

[Book1]Shesat3
B Messages & Confimations

Help

To start a new gquety: 1=

1. Fromthe navigation panel (the screen to the left of this
panel), select the name of the wotksheet; for example,
[Eookl]3heet] in Excel or <<Untitled.123>>4 in Lotus 1-2-3.

2. With the wotksheet selected, click the right mouse button,
and from the pop-up meny, select Mew > Query.
Hote: If you have not logged into a database, the Esshase
System Login dialog boxis displayed. Youneed to loginto a
database before proceeding.

Eefer to the hint panel (the panel above this screen) for help on
other panels.

Click the question mark icon in the navigation panel (the screen
to the left of this naneli to access a tutorial and online heln for T

Essbase Spreadsheet Add-in for Excel M 93



A Basic Essbase Tutorial

2. To create anew query, select [Book1]Sheetl, right-click, and select
New > Query.

Hyperion Esshase displays the layout panel of Hyperion Essbase Query
Designer.

Figure 59: Essbase Query Designer Displaying Layout Panel

FT Hyperion Essbase Query Designer EHE
Elij Spreadshests - Exel Tse this layout panel to design the lagout of the
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Market memmber select panel to define members for the
o Scenario ULy,
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ol Measures EILEIE
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Available Dimensions Page Dimensions:
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3. Define the worksheet layout by dragging the dimension tiles as follows:
a. Drag Market and Product to the Row location.
b. Drag Measures to the Page location.

c. Drag Scenario below Year (in the Column location).
Figure 60: Changing the Worksheet Layout
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=] Spreadsheets - Excel
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= [Book1]Sheet - Quenyl
U. Dimensions

Tse this layout panel to design the layout of the report.
1. Belect a dimension tile from a dimension box.
2. Dragthe dimension tile to a page, row, or column
I dimension box.
Page 3. Dowble-click a dimension tile to access the member select
ol Measures panel to define members for the query.
] Row ou have completed designing the layout of the query.
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4. To select the Measures dimension in the navigation panel, select the Measures
icon. Alternatively, double-click the Measures tile in the layout panel.

Essbase displays the member select panel, where you can select a member
from the Measures dimension.

Note: You can select only one member from the dimension in the Page location.
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5. Select Profit, right-click, and select Add to Selection Rules. Alternatively,
double-click Profit to add it to the selection rules.

Profit is displayed in the selection rules list.

Figure 61: Hyperion Essbase Query Designer Displaying the
Member Select Panel

r'} Hyperion Essbase Query Designer EHE
Elij Spreadshests - Exel Tse this member select panel to select a member for the
E-g] Bookl page dimension. You can select only one member per
=] l:[‘Book‘I]Sheet‘I - Quernyl page dimension,
o Dimensions by 1. Select amemberin the "Members" list box.
& : 2. With the member selected, click the right mouse
button, and from the pop-up men, select Addto
Selection Bules.
3. Select the member in the "Selection Rules" list box.
ou have completed defining the member for the page
dimension.
Members:
Available.Dimensions = Measures
Caffeinated [Baze:Product) - Prafit
Intro D ate [Baze: Product] Inventary
Ounces [Baze:Product) - Ratios
Pkg Type [Baze:Product]
Population [Base:Market]
Z2 Attribute Caloulations
----- 52 Data Filkering
=] Data Sorting
[Book1]5heet2

- [Book1]Sheet3
----- B Messages & Confimations
Help

Selection Rules:

----- Prafit

Note: In Essbase Query Designer, after you make your selections, you do not
need to confirm them; for example, you do not have to click OK. If you do not select
members from any given dimension, Essbase uses the top member of the
dimension.
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6. To select members of the Year dimension, complete the following actions:

a. Inthenavigation panel, click the Year icon. Alternatively, double-click
the Year tile in the layout panel.

Essbase displays the member select panel for the Year dimension.
b. Select Qtrl, right-click, and select Add to Selection Rules.

c. Add Qtr2, Qtr3, and Qtr4 to the selection rules in the same manner.
Because Year isin a Column location, you can select one or more
members.

Figure 62: Adding Members to the Selection Rules
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7. To select members of the Scenario dimension, complete the following actions:

a.

C.

In the navigation panel, select Scenario. Alternatively, double-click the
Scenario tilein the layout panel.

The members of the Scenario dimension are displayed in the member
select panel.

Select Actual, right-click, and select Add to Selection Rules.
Actual is added to the Selection Rules box.

In the same manner, add Budget to the Selection Rules box.

8. To select members of the Product dimension, complete the following actions:

a.

In the navigation panel, select Product. Alternatively, double-click the
Product tile in the layout panel.

The members of the Product dimension are displayed in the member
select panel.

Select product code 100, right-click, and select Add to Selection Rules.
Repeat the process for product codes 200, 300, and 400.

In the Selection Rules list box, select product code 100, right-click, and
then, from the popup menu, choose Select > Children.

Thisaction selectsall children of 100. Essbase displays All Children next
to 100 in the Selection Rules list box.
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e. Inthe Selection Ruleslist box, select product code 400, right-click, and

choose Select > Descendants.

Essbase displays All Descendants next to 400 in the Selection Rules list

box.

Figure 63: Selecting Members of Product
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Tse this member select panel to select a member for =
the row dimension.
1. Belect a member in the "IMMembers" list box.
2. With the member selected, click the right mouse
button, and from the pop-up mem, select Add
to Selection Rules.
3. Select the member in the "Selection Rules" list
hox.
4. With the member selected, click the right mouse
button, and from the pop-up meny, select
Member Filter. |
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f.  Toview thelist of al product codes that will be retrieved into the
worksheet, select any of the entries in the Selection Rules list box
(for example, 200), right-click, and select Preview.

Hyperion Essbase displays the Member Selection Preview dialog box.

Figure 64: Selected Members of Product Dimension

Member Selection Preview E
Selected Members:
100-10 -
100-20 _I
100-30
200
300
400-10
400-20
400-30
The selected rule returned 8 members.

g. Click Closeto close the Member Selection Preview dialog box.
9. To select members of the Market dimension, complete the following actions:

a. Inthenavigation panel, select Market. Alternatively, double-click the
Market tile in the layout panel.

Themembers of the Market dimension are displayed in the member select
panel.

b. Inthe Member list box, select East, right-click, and select
View by > Generation.
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c. To pick the second generation of the Market dimension, in the Member
list box, select Region, right-click, and select Add to Selection Rules.
Alternatively, double-click Region to add it to the selection rules.

Region is displayed in the Selection Rules list box.

d. Toview thelist of members that will be retrieved into the worksheet, in
the Selection Ruleslist box, select Region, right-click, and select Preview.

Essbase displays East, West, South, and Central inthe Member Selection
Preview dialog box.

Figure 65: Generation Name Selection

Member Selection Preview E
Selected Members:
East ;I
et
South
Central
The selected rule returned 4 members.

e. Click Closeto closethe Member Selection Preview dialog box.

Y ou have now defined abasic Essbase query. The outline of the query isdisplayed
in the navigation panel.
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10. Inthe navigation panel, select [Book1] Sheetl, Query1\, and then right-click
and select Save Query.

Essbase displays the Essbase Query Designer Save As Query dialog box.
Y ou can save your query to the server or to your own client machine. To save
to the server, you must have a security level of database designer or higher.
Contact the Esshase system administrator for more information.

11. Select Client.

Figure 66: Essbase Query Designer Save As Query Dialog Box

Hyperion Essbase Query Designer Save As Query E
. Application:
Lacation
Ok
™ Server Isample 'l
&' Clisnt D atabase: Cancel |
Guery name: I[aII dbs) 'l Help |

I Query Type:
0 File System... |

Query objects:
El
Connection informatior:
Server: Localhost
LI Application: 5ample
D atabase: Basic

|

12. Click the File System button.
Essbase displays the Save As dialog box.

Figure 67: Save As Dialog Box

Save As 21=]
Save in: Ia Temp j gl e EE
Wbe
File name: IBasic‘I Save I
Save as ype: IEQD[".eqd] j Cancel |
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13. Select alocation, inthe File nametext box, typeBasi c1 and then click Save.

Y ou will use the Basicl query again in Chapter 3.

Figure 68: Hyperion Essbase Query Designer Displaying
Query Information Panel

=i Spreadshests - Excel =] e ——
-] Bookl
= [Book1]Sheet] - Basicl

Tse this query information panel to find out information
about the query, such as the query name, the database
that the gquety is connected to, and so on.

e
=' [ =T =T = |
e e

Dimensions
El"' 5599 Mote: When you initially create a new guery, most of
S Measures the fields will be empty. When you open an existing
B Prafit quety, the fields will be filled with the appropriate
information.
o Product
----- Bg 100, &1 Children
..... EIE| 200
Query Mame: Bazicl [EQD)
Location: Localhost:sample:

Current Connection:  Localhost: 5 ample: B asic

Created Faor:
Modified: Mo
Locked: ‘Yes, Spamidi

B Available Dimensions

----- B Caffeinated [Base:Product]
Intro D ate [Baze: Product]
Ounces [Baze:Product]
Pkg Type [Base:Product] —
= Population [Base:Market]
----- Z2 Attribute Caloulations
%8 Data Filkering
T Data Sorting LI
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14. Inthe navigation panel, select [Book1] Sheetl, Basicl. then right-click, and

select Apply Query.
Theresult of the query is displayed in the worksheet.

Figure 69: Results of a Essbase Query Designer Query

A B @ D | E F o H 1]
1

L2 | Qtr1 Qtr2 Qtr3 Qtrd
13|
| 4 [East Cola 2461 2550 2940 3050 3298 3440 2430 2410
| 5 | Diet Cola 212 220 303 300 312 310 287 290
| 6 | Caffeine Free Cola 74 110 109 130 130 130 100 150
|7 | Root Beer 562 960 10 1070 372 830 590 1500
| 6 | Cream Soda 591 770 922 1010 522 60 592 530
| 9 | Grape 545 840 B76 560 710 920 18 500
| 10 Orange 290 350 327 380 377 420 394 440
[11] Strawberry 545 700 512 750 525 780 525 570
|12 [West  Cola 1047 1720 1189 1500 1339 2120 1018 1780
[ 13| Diet Cola 57 320 177 200 -154 250 136 320
| 14 | Caffeine Free Cola 62 310 -163 30 286 -130 123 70
115 | Root Beer 2325 2570 2423 2720 2540 2820 2439 2840
| 16 | Cream Soda 2363 2620 2739 2970 2937 3230 2692 2850
|17 | Grape 1143 920 1167 960 1271 1020 1219 920
EED Orange 1002 810 1120 590 1192 1000 940 530
| 19| Strawherry 73 -310 -783 -380 500 -440 779 -400
|20 (South  Cola 745 1160 835 1280 1031 1490 985 1510
Fi] Diet Cola 306 570 363 BB 261 570 247 550

Note: In the Display tab under Essbase > Options, if you select Use Styles and
Use Sheet Options with Query Designer, the styles you selected for dimension
members will be applied to the initial query results. If you do not select Use Sheet
Options with Query Designer, even if you have selected Use Styles, they will not
be applied to the initial query results. To apply styles, select Esshase > Retrieve.
When Essbase returns the data to the worksheet, you are free to further investigate
the data by performing Zoom, Keep Only, Remove Only, and Pivot operations.
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Deleting Queries

Y ou can delete a query only from the location where you saved that query. For
example, if you save aquery inthe/ essbase/ cl i ent/ sanpl e directory, you
can delete the query from within the sanpl e directory. Y ou cannot delete the
guery from within Hyperion Essbase Query Designer.

Viewing Messages and Confirmations

Hyperion Essbase Query Designer displays messages and confirmations about
certain actions, such as moves and deletes, in the messages and confirmations
panel.

» Toturn on or turn off messages and confirmations:
1. Select the Messages and Confirmations icon in the navigation panel.

2. Toturn on (enable) a message, select the check box that is displayed next to
that message.
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3. Toturn off (disable) a message, select the check box again (clear the check
box).

Figure 70: Messages and Confirmations Panel

r'} Hyperion Essbase Query Designer EHE

Tse this messages and confirmation panel to turn on and off

cettain messages from Hyperion Esshase Query Designer.

1. Belect the cotresponding check box next to a message to
enable that message.

2. Select the check box again to clear the check box and turn
off a message.

Tou have completed selecting the message notifications that

you want turned on ot off.

[ 1Dimension move deletes member selection rules
[w] Dimengion move deletes zorting and filtering rules
[ 1Confirm delete of member filker

[ 1Confirm delete of member selection rule

[ 1Confirm delete of data restriction

[ 1Confirm delete of data sorting rule

[ lAction deletes data sorting and filtering rules
[C15ave query only on spreadsheet application cloze

Scenario
B Actual
B Budget
Available Dimensions
Caffeinated [Baze:Product]
Intro D ate [Baze: Product]
Ounces [Baze:Product]
Pkg Type [Baze:Product]
Population [Base:Market]
B Attribute Caloulations

-5 Data Filtering, Top 30
%] O, Actual <= 500
OR Qtr, Actual < Q2, Actual
AND G, Actual is not #missing
=] Data Sorting

41 Descending, Qtrl, Actual
[Book1]5heet2
[Book1]Shesat3 -
nfirmatiors:

)
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Accessing Help

Access online help or the tutoria for Hyperion Essbase Query Designer by using
the help panel. To access the help panel, in the navigation panel, select Help. For
more information on a particular topic, click the Online Help button in the

properties panel. To access the online tutorial, click the Tutorial button in the
properties panel.

Figure 71: Essbase Query Designer Help Panel

r'} Hyperion Essbase Query Designer EHE
EI--- fiow = Tse this help panelto access OLAP overview, a tutorial
9 ofn Hyperion Esshase Query Designer, and online help.
Click a button to access the topic.

----- B 400, &1l Descendants
[—] Colurnn
E|---U. “Y'ear

- Budget Tutorial
I'_—'I--Ej Available Dimensions

-Wl7 Caffeinated (B ase:Product]
Intro D ate [Baze: Product]
unces [Base:Product] =
kg Type (Base:Product] O N I ne He I p
‘opulation (B aze:karket]

il Aithribute Calculations
-5 Data Filtering, Top 30
Q1. Actual <= 500
OR Qtr, Actual <= Qtr2, Actual
AND G, Actual is not #missing
[rata Sorting
4] Descending, Q1. Actual
----- B Messages & Confimations

=
1 | ]
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Connecting to Multiple Databases from Essbase Query
Designer

Y ou can connect to several databases and create separate queries on each database
from Essbase Query Designer.

108 W

To connect to multiple databases from Essbase Query Designer:

1.
2.
3.

6.

Logon to Essbase and connect to the server you want to access.
Select Essbase > Query Designer to open Essbase Query Designer.
Select [Book1] Sheetl, right-click, and select Connect.

Essbase displays the Essbase System L ogin dialog box.

Note: The book may be a number other than 1. For example, it may be [Book5], if
four worksheets are already open.

Type your password, and click OK. Select Sample Basic, and click OK.

Select [Book1] Sheet2 (or Sheet3), right-click, and select
Connect.

Essbase displays the Essbase System L ogin dialog box.
Typeyour password, and click OK . Select Samppart Company, and click OK .

Note: You are restricted to one connection per worksheet. The connection information
is displayed in the query information panel of the Hyperion Essbase Query Designer
only when you open an existing query or create a new query.

7.

To create a new query based on Sample Basic, select [Book1] Sheetl, right
click, and select New > Query.

To create a new query based on Samppart Company, select [Book1]Sheet2,
right-click, and select New > Query.

To open an existing query, right click, and select Open Query.

Y ou are now ready to proceed with the process of creating queries or opening
existing queries.
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Applying Worksheet Options to Essbase Query Designer
Results

Y ou can also apply any of the worksheet options you have previously set from the
Esshase Options dialog box to the results of a query created in Essbase Query
Designer.

» To enable Essbase Query Designer to use your previously set worksheet options:
1. Select Esshase > Options.
2. Inthe Essbase Options dialog box, select the Display tab.
3. Select the Use Sheet Options with Query Designer check box, and select OK.
4. Select Esshase > Retrieve to refresh the worksheet.

Esshase displays the results of the query you created in Essbase Query
Designer and implements your previously set worksheet options.

For example, note that aliases, instead of the numeric codes, are now
displayed for the Product dimension.

Figure 72: Results of Query with Options Applied

A ] B [ c [ b [ EJF G [ H [ 1 [ 4]
1

12 | Qtr2 Otr3
| 3 | Actual |[Budget |[Actual Actual |[Budget [Actual
| 4 |East Cola 2461 25500 2240 3050 3235 3440 2430 2010
| & | Grape 545 840 B7E 850 710 920 G618 800
| 6 | Cream Soda 551 7700 922 1010 s22 G600 592 530
L7 | Root Beer 562 950 B10 1070 572 g30 920 1500
| & | Strawherry 545 700 612 750 B25 780 825 670
| 9 | Orange 250 3500 3F 3|00 37 4200 34 440
| 10| Diet Cola 212 2200 303 oo 312 o 287 250
|11 Caffeine Free Cola 74 1100 109 1300 130 120, 100 150
| 12 |West Cream Soda 2363 2620 2739 2970 2937 3230 2692 2850
| 13| Root Beer 2325 2570 2423 V0 25400 28200 2439 2840
| 14 | Grape 1143 9200 167 950 1271 10200 1219 920
| 15 | Cola 1047 17200 1189 1900 1332 2120 1018 1780
| 16 | Orange 1002 810 1120 850 1192 1000 540 550
|17 | Caffeine Free Cola 52 310 -163 300 286 1300 123 70
| 18 | Diet Cola £7 3200 177 200 -154 2500 -136 320
| 19 | Strawherry 738 310 783 -3800 8000 -4400 7Y 400
| 20 | South Root Beer 1465 16400 1540 17000 1612 1710 1483 1330

5. Select File > Close to close the worksheet. You do not need to save the
worksheet.
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Selecting Members

A Essbase database may contain hundreds or even thousands of members, making
it difficult to remember each member name. Y ou can use the Essbase Member
Selection dialog box to find and select members and to define the layout of
members in the worksheet. In addition, you can use Boolean operators, such as
AND, OR, and NOT, or other search parameters to specify criteriaand conditions
that members must meet for the member selection. Member selection isan
important method of creating a spreadsheet report for the datayou want to retrieve.

Note: For complete information on the Essbase Member Selection dialog box, see the
Essbase Spreadsheet Add-in online help.

» To view specific members from the Product dimension:

1. To open anew worksheet, select File > New or click the QI icon.

Note: You should be connected to the Sample Basic database. If you are not
connected, follow the steps in “Connecting to a Database” on page 47.

2. Select Essbase > Retrieve.

3. Select Product and select Essbase > Pivot to display Product as arow, rather
than a column, dimension.

Figure 73: Initial Worksheet for Member Selection

n | B [ D E F |
M arket
[Product  Jrear 105522

O B |G [P =t
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4. Select Product again, and select Essbase > Member Selection.

Esshase displays the Esshase M ember Selection dialog box. In the Esshase
Member Selection dialog box, Esshase displaysthe Product dimensioninthe
Dimension list box and its children, Colas, Root Beer, Cream Soda, Fruit
Soda, and Diet Drinks, in the Members list box.

Figure 74: Essbase Member Selection Dialog Box

Essbase Member Selection

Dimenzion: |{siaiey i

Members

[~ Product (5]
M Calas (3
[ Roat Beer [4]
[ Cream Soda [3]
[ Fruit Soda [3)
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Lele |5 |

¥
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<
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Mote: Uze the right mouze button to apply
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Find... | Ezpand Tja Mescendants | ove ltem g | Eremoye (e |
[Elear | emtenlrfematian.. | e ltem Davwmn | Eremaye Al |
Wiew Method Output Optio:

& By Member Mame

' By Generation Mame

' By Level Mame

) By Dpriamic: Time S enes
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™ Irsert List Before Active Cel

Cancel
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Save...

Eresieg..

LB el
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5. Select Colas and click the Member Information button.

Esshase displays the Member Information dialog box. The dialog box
provides information about the selected member, such as dimension,
generation, level, storage setting, formula, UDAS, and member comments.

Figure 75: Member Information Dialog Box

Member Information E
Member Information for - Colas:
Dimension: Product
Generatior: 2

Lewvel: 1
Storage Setting:  Mormal

Formula: ;I
<] _>l_I
Uszer Defined o
Attributes [UDA]: —I
Kl 3
Member Comment: ;I
<] _>l_I

6. To closethe Member Information dialog box, click OK.

7. Inthe Esshase Member Selection dialog box, click Add to add Colas to the
Ruleslist box.

Note: Alternatively, you can double-click an item in the Members list box to add the
item.

112 Essbase Spreadsheet Add-in for Excel



A Basic Essbase Tutorial

8. Select Cream Soda, and click the Find button.
Esshase displays the Find Member dialog box.

In the Find M ember dialog box, you can do pattern-match searches for
membersin the selected dimension. Y ou can use Wildcard patterns—(trailing
asterisk, *) and (single-character match, ?). Hyperion Essbase locates the
members that match the text string (in aphabetical order) and keeps them
selected so that they can be selected as a group.

Note: You can use the trailing asterisk wildcard and single-character wildcard

in the text string. The * wildcard replaces a string of characters, whereas the ?
wildcard replaces a single character. J?n and 100* are examples of valid wildcard
strings; *- 10 and J* n are examples of invalid wildcard strings.

9. IntheFind Member dialog box, type D* in the text box.
Figure 76: Find Member Dialog Box

Find Member E

Enter ember Mame or Pattem in Field Below:
P

End | Fidides || Cese || Hep |

10. Click Find to locate all members that match D*.

Essbase locates and selects Diet Cream. Its parent, Cream Soda, is also
selected because it was highlighted before the search.

11. To closethe Find Member dialog box, click Close.

12. Clear Cream Soda, leaving only Diet Cream selected, and click Add. Essbase
displays Colas and the new selection, Diet Cream, in the Ruleslist box.
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13.

14.

15.

16.

17.

In the Essbase Member Selection dialog box, select Colasin the Rules list
box, and then right-click. From the pop-up menu, select All Children and
Member.

Essbase displays All Children and Member next to Colas in the Selection
Ruleslist box.

In the Selection Rules list box, select Colas, All Children and Member, and
then right-click again.

From the pop-up menu, select Subset.
Esshase displays the Subset Dialog box, where you can further define
conditions for the selected member.

Note: You can define a maximum of 50 conditions in the Subset Dialog box.

Inthe Subset Dialog box, inthefirst list box, select Caffeinated. In the second
list box, select Is. Inthe third list box select Caffeinated True.

Click the Add as AND Condition button.
Esshase displays Caffeinated = Caffeinated_Truein the Conditionslist box.

When you use Add as AND Condition, the subsetting condition in the
Conditionslist box is evaluated using AND logic. AND logic means that the
selection must meet the current condition and the following condition in the
Conditions list box.

Figure 77: Subset Dialog Box (Before Adding Conditions)

Subset Dialog E
Select member Colas and its children where: oK |
IEaffeinated j Iis j IEaffeinated_True j c |

ance |
Add as OR Condition | | """" i 55 NG Eondiion Help |
LConditions:
Caffeinated = Caffeinated True
Femove [tem |
Add add] |
Eemoye [ ] |
Remoe il |
Freview... |
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In thefirst list box, select Ounces. In the second list box, select the logical
operator “=". In the third list box, select Ounces_12.

Click the Add as AND Condition button.
Essbase displays Ounces = Ounces 12 in the Conditions box.

In thefirst list box, select Ounces. In the second list box, select the logical
operator “<=". In the third list box, select Ounces 32.

Click the Add as OR Condition button.
Essbase displays Ounces <= Ounces_32 in the Conditions box.

When you use the Add as OR Condition, the subsetting condition in the
Conditionslist box is evaluated using OR logic. OR logic means that the
selection must meet the current condition or the following condition in the
Conditions list box.

In thefirst list box, select Pkg Type. In the second list box, select Is. In the
third list box, select Bottle.

Click the Add as AND Condition button.
Essbase displays Pkg Type = Bottle in the Conditions list box.

In the Conditions box, select Ounces <= Ounces_32, and then click the
Add ( button.

Select Pkg Type = Bottle, and click the Add ) button.

The Add (and Add ) buttons add a left parenthesis and right parenthesis,
respectively, to selected items. Use parentheses for grouping multiple
subsetting conditions to determine the order of priority for analyzing the
conditions. Each item in the Conditions list box can have either the left

or right parenthesis, but not both. In this example, Esshase first evaluates
members that are equal to or less than 32 ounces and are packaged in a bottle.
Essbase then evaluates the results from this condition against members that
are 12 ounces.

Note: Use the Remove () button to remove an individual group of parentheses
from a selected item in the Conditions list box. Use the Remove All () button to
remove all parenthetical groupings from the Conditions list box.
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The Subset Dialog box is displayed as follows:

Figure 78: Subset Dialog Box (After Adding Conditions)

Subset Dialog E

Select member Colas and its children where:

ok |

IF'kg Type j Iis j IBottIe j Cancel |
AddasOR Condion | Addas AND Condition | T |
LConditions: —

Caffeinated = Caffeinated_True

ND Femove [tem |
Ounces = Ounces_12

[ Ounces <= Ounces_32
AND

el add] |
Fkg Type = Bottle |

Remave [ ] |

Remave &)l [ ] |

26. To open the Member Preview dialog box, click Preview.

Inthe Member Preview dialog box, you can view the member selection that
results from the conditions you defined.

Figure 79: Member Selection That Results from Subsetting Conditions

Member Preview E
Selected Members:
Cala
Diet Cala

Caffeine Free Cola

-]

The Selected rules retumed 3 members
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To close the Member Preview dialog box, click Close.

28. To close the Subset diaog box and return to the Esshase M ember Selection

29.

dialog box, click OK.

The conditions you set in the Subset dialog box are displayed in the Selection
Ruleslist box.

To changethe order in which Diet Cream is displayed in the worksheet, select
Diet Cream and click the Move Item Up button.

Each time you click the Move Item Up or Move Item Down button, the
selected item and its associated subset conditions move up or down one
position in the Selection Ruleslist box. Y ou can move only the top-level item
(the item you added from the Members list box), not the individual subset
conditions.

Figure 80: Selecting Members Completed
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30. To preview the members that will be retrieved in the worksheet, click

Preview.

Essbase displays the Member Preview dialog box.
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31. After previewing thelist, click Close.
Figure 81: Members to be Retrieved in Worksheet

Member Preview E

Selected Members:

Diet Cream
Cala

Diet Cala
Caffeine Free Cola ﬂl

-]

The Selected rules retumed 4 members

32. To close the Essbase M ember Selection dialog box and insert the new
members into the worksheset, click OK.

Figure 82: Result of Selecting Members

A [ B[ ¢ D E
|1 Market

Diet Cream Year 106522
Cola

Diet Cola
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Note: The FlashBack command cannot undo a Member Selection action.

33. Starting with Diet Cream, type Y ear next to each product.

Y ou need to do this step so that every product has amatching Y ear dimension
associated with it in the report.

Figure 83: Worksheet After Adding the Year Dimension to All States

A [ B[ ¢ D E
|1 Market

| 2 |Diet Cream Year 108522
| 3 |Cola Year
| 4 |Diet Cola Year

5 |Caffeine Free Cola Year
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34. To update the values in the worksheet, select Essbase > Retrieve.

Esshase retrieves data for the members that you selected and also applies the
styles you previoudly set.

Figure 84: Result After Retrieving with Member Selection

A [ B C D E
|1 Market
|2 |Diet Cream Year FNIEE]
| 3 |Cola Year 2577
| 4 |Diet Cola Year 4703
| & |Caffeine Free Cola Year 1983

Saving and Disconnecting

After performing basic retrieval, navigation, and formatting tasks, you can save
worksheets and disconnect from Essbase. This section instructs you in the
following procedures:

e “Saving aWorksheet” on page 119
e “Disconnecting from Essbase” on page 120

e “Logging Off” on page 121

Saving a Worksheet

At any point during the Essbase session, you can save the active worksheet with
the Excel commands, File> Saveor File> Save As. Thus, you can keep apersona
library of database views. Y ou can open the worksheet during a later session and
retrieve the latest data val ues to update the view.

Note: Saving a worksheet saves the settings from the Essbase Options dialog box
unless the worksheet is protected. Esshase cannot save option settings for a protected
worksheet.
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Disconnecting from Essbase

When you finish retrieving and navigating through data, disconnect from the
Essbase server to free up a port (or user count) on the server for other Essbase
Spreadsheet Add-in users.

» To disconnect from the server:
1. Select Essbase > Disconnect.

Esshase displays the Esshase Disconnect dialog box, where you can
disconnect any worksheet that is connected to a database.

Figure 85: Essbase Disconnect Dialog Box

Essbase Disconnect E

Disconnect

Sheet ServerApplication-> D atabase

[S heet1]Sheetl  Aspen:Sample->B asic

[Sheet2]Sheetl  Aspen:Sample->B asic Close |
Help |

4] | i

2. Fromthelist, select aworksheet name, and then click Disconnect.
3. Repeat step 2 until you have disconnected all active sheets.
4. Click Closeto close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by simply closing Excel. An abnormal
termination of an Excel session, such as a power loss or system failure, does not
disconnect your server connection.
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Logging Off
Essbase provides two administrative facilities that control user connections:

e Forced Logout, where an administrator disconnects users at any point intime.
This logoff usually occurs when maintenance operations are performed on
databases.

e Auto Logout, where Essbase automatically disconnects usersthat areinactive
for atime interval specified by an administrator.

For further information, contact the Essbase system administrator.

Moving on to Advanced Tasks

Now that you have compl eted the basic Essbasetutorial, you are ready to move on
to more complex tasks. In the next chapter, you will use the sample Excel filesto
see how to perform advanced tasks in Essbase Spreadsheet Add-in.
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An Advanced Essbase
Tutorial

Thetutorial you completed in Chapter 2 teachesbasic dataretrieval and navigation
concepts for Essbase Spreadsheet Add-in. This chapter builds on your basic skills
and expands your knowledge of Esshase and Essbase Spreadsheet Add-in.

This chapter provides the following sections on advanced tasks:
e “Preparing to Begin the Tutorial” on page 124

e “Performing Advanced Retrieval Tasks’ on page 130

e “Using Linked Reporting Objects’ on page 177

e “Connecting to Multiple Databases’ on page 193

e “Accessing Linked Partitions’ on page 194

e “Updating Data on the Server” on page 197

e “Calculating a Database’ on page 199

e “Creating Multiple Worksheets from Data’ on page 201

e “Working with Currency Conversions’ on page 207

In this advanced tutorial, you use several sasmpleMicrosoft Excel files that were
installed as part of the default Essbase installation. These files are stored in

the\ Essbase\ cl i ent\ sanpl e directory. Y ou also reconnect to the Sample
Basic database.
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Preparing to Begin the Tutorial

Before you begin the advanced tutorial, complete the steps in the next two
sections, “ Connecting to a Database” on page 124 and “ Setting Essbase Options”
on page 126. In addition, be sure to read “ Following Guidelines During the
Tutoria” on page 44 and “ Reviewing the Sample Basic Database” on page 46 for
important information about what you should expect as you perform the tutorial

steps.

Connecting to a Database

To access Esshase data for the advanced tutorial, first connect to the Sample Basic
database on the server. This tutorial assumes that you have the appropriate
privileges to connect to a server, an application, and a database.

1. Select Esshase > Connect.
Esshase displays the Essbase System L ogin dialog box.

Figure 86: Essbase System Login Dialog Box

Essbase System Login E

Server: ILDcthost j K I
Username: W Cancel |

Pazsword: l— Help |

[EhanaeFassword.. |
Application/D atabase:
[ pdate |
Tote.. |

Note: To complete the steps that follow, you need to know the name of the
Essbase server, your username, and your password. If you do not have this
information, contact the Essbase system administrator.

2. From the Server list box, select the server that you want to access. (If the
server name that you want is not shown in the list, type the name of the server
that you want to access.)
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3. Tomoveto the Usernametext box, press Tab and then, in the User name text
box, type your username.

4. To moveto the Password text box, press Tab, and then, in the Password text
box, type your password.

Note: You can change your password when you are connected to a server. See
“Changing a Password” on page 49.

5. To connect to the server, click OK.

Esshase displays alist of available application/database pairsin the list box.
An Essbase server enables simultaneous access to multiple applications. An
application can contain multiple databases. Only the databases to which you
have security access appear in the list.

For thistutorial, you use the Sample Basic database. If the Sample Basic
database wasinstalled as part of the Essbaseinstallation, it isshownin thelist.
If Sample Basic is not shown in the Application/Database list, ask the
Essbase system administrator to install it.

Figure 87: Available Application and Database Pairs

Essbase System Login E

Server: ILDcthost j 0K I
Usermame: W Cancel |

Password: I ******** Help |
LChange Password... |

Application/D atabase:

Demo Basic Update |

S ampeast East

Sample Internt! Mate... |

S ample Hchgrate
S amppart Company
Sourcel Basic
Targetl Basic

6. IntheApplication/Database list, double-click Sample Basic, or, from the
Application/Database list select Sample Basic and then click OK.
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If the applicationisnot already running, Essbase automatically startsit. There may
be abrief pause as the application loads; the time required to start an application
depends on the number of databases, the sizes of the databases, and the sizes of the
indexes of the databases that are contained within the applications.

Setting Essbase Options

Before you begin the tutorial, make sure that the worksheet options are set to the
initial settings shown in the Figure 88 through Figure 91.

126 &

Note: For information on each option in the Essbase Options dialog box, see the
Essbase Spreadsheet Add-in online help.

1.
2.
3.

Select Essbase > Options.

In the Essbase Options dialog box, select the Display tab.

Select the appropriate check boxes and option buttons so that your display

matches Figure 88.

Figure 88: Initial Settings for Display Options

Essbase Options

Display |Zoom I tode I Style I Globall

' Subitems
&

Indentation—————— ~ Feplacement
' Nane HMigzing Label: WA

#Mo Access Label: I

— Suppre — Aliaze:

™ #Missing Fows V' Use Aliases

™ Zemo Rows ™ Use Both Member Names and Aliases

™ Underscore Characters far Row Dimensions

el Alias:
—Cells

V' Use Styles IDefauIt j

™ Adjust Columng

= Aute Sort Homs Query Designer

" Bepeat Member Labels ’7|7 Use Sheet Options with Query Designer
— Dynamic Time Serie

" Latest Time Period IJan j

QK I Cancel Help
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4. Select the Zoom tab.

Select the appropriate check boxes and option buttons so that your display
matches Figure 89.

Figure 89: Initial Settings for Zoom Options

Essbase Options

O
(]
(]
(]
(]
(]
(]

6. Select the Mode tab.
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7. Select the appropriate check boxes and option buttons so that your display
matches Figure 90.

Figure 90: Initial Settings for Mode Options

Essbase Options

8. Skipthe Styletab.
9. Select the Global tab.
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10. Select the appropriate check boxes and option buttons so that your display
matches Figure 91.

Figure 91: Initial Settings for Global Options

Essbase Options E

Displayl Zoom I Mode I Style  Global |

—Mouse Actions———— [~ Display Messages
i ' Information
V¥ Enable Double-Clicking " Warnings
V¥ Enable Linked Object Browsing & Enars
' Mone
— Memory ™ Display Unknown Members
[V Enable Flashback
—Log File
Member Select———————— | F Boute Messages to Log File
™ Display Save Dialog V¥ Purge Log File Every Session

—Mode

™ Mavigate without Data Addins... |

QK I Cancel | Help |

11. Tosavethesettingsfor thissession and close the Essbase Optionsdialog box,
select OK.

Note: The settings in the Essbase Options dialog box may change as you access
the various sample Excel files as part of the tutorial. Leave the settings as they are
unless the tutorial advises you to change them. If you have different option settings,
the illustrations presented in this chapter may not match the worksheet view.
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Performing Advanced Retrieval Tasks

Thetutorial in Chapter 2 describes how to perform basic data retrieval and
navigation tasks in Esshase Spreadsheet Add-in. This section walks you through
performing the following advanced retrieval tasks:

e ‘“Filtering Data” on page 130

e “Sorting Data’ on page 138

e “Retrieving Datainto Asymmetric Reports’ on page 141

e “Working with Formatted Worksheets’ on page 143

e “Preserving Formulas When Retrieving Data’ on page 149
e “Retrieving a Range of Data” on page 153

e “Retrieving Data by Using a Function” on page 156

“Retrieving Dynamic Calculation Members’ on page 160

“Specifying the Latest Time Period for Dynamic Time Series” on page 163
e “Using Free-Form Reporting to Retrieve Data’ on page 167

Remember that you can perform common dataretrieval tasksin any of the
following ways.

e Selecting commands from the Essbase menu on the Excel menu bar
e Clicking the appropriate buttons on the Essbase toolbar

e Double-clicking the primary or the right-mouse button in the appropriate
cell (for Retrieve, Zoom In, and Zoom Out commands only, and the Linked
Objects command, if you have enabled that option).

Filtering Data

Despite the ease and speed with which you can navigate through large Hyperion
Essbase databases, it is not practical to use the capabilities of Excel to filter and
sort very large databases; however, the Essbase server includes powerful data
filtering and sorting capabilities. In Chapter 2, you learned to use Esshase Query
Designer to define adimensional layout and to select members to view. Esshase
Query Designer also provides a powerful, yet easy-to-use tool to define
conditional retrievals.
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To become familiar with the capabilities of Hyperion Essbase Query Designer,
work with the query, Basicl, that you saved in Chapter 2, and perform the
following steps:

Note: If you skipped the tutorial in Chapter 2, follow the steps in “Creating Queries
Using Essbase Query Designer” on page 91 to create and save the Basicl query.

1. Select Esshase > Query Designer.

Essbase displays the query information panel of Essbase Query Designer.
2. [Book1]Sheetl
3. Right-click and select Open Query.

Essbase displays the Open Query dialog box.
From the location that you specified in Chapter 2, select the Basicl file.
Click OK.

The member selection, displayed in the properties panel, remains unaltered
from the last Esshase Query Designer session.
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6. From the navigation panel, select Data Filtering.

Essbase displays the data filter settings in the datafilter panel. Thefilter
controls the number of data rows that are retrieved. The number is based on
the column criteria that you define. Y ou can define datafiltering criteriaon
data values that reside in one or more columns of the view.

Figure 92: Data Filter Panel

r'} Hyperion Essbase Query Designer EHE
E-E BDH . = Use this data filter panel to retrieve data based on the rank  +
= l:[‘Book‘I]Sheet‘I - Basicl.eqd 3 order that you have specifisd.

=gl Dimensions 1. Select the Top or Bottom check box, or bath.

E'"' EI‘:'age 2. Specify how many rows you want to retrieve.
= Measurgs 3. Select a dimension from the "Dimension being ranked"

e BE Profit drop-down list hox.

=1+ 4. Zelect the column from the "Column used for ranking"

drop-down list box.
5. Dowble-click in the "Data Restrictions" box to create
additional data filters.

Mote: Follow Step 5 only if you want to define additional LI

..... EIE| 300 — —
----- O 400, All Descendants Riank: T Rows [ Boten[T ] Rows

EI---.FEM\T:&[ Dimenszion being ranked:
..... B Qi IF'roduc:t j
..... EIE| []10ed _
_____ I:IEI an3 Column used for ranking:
..... By dud IQtr‘I,Actual j

I'_—'l---':'. Scenario

B etual D ata Restrictions:

----- [double click to create a new data restriction)

B Available Dimensions
Caffeinated [Baze:Product]

Intro D ate [Baze: Product]

Ounces [Baze:Product]

lg Type [Base:Product]

‘opulation (B aze:karket]

- Aithribute Calculations

----- 52 Data Filkering

[rata Sorting

41 Descending, Qtrl, Actual LI

7. Thedatafiltering panel contains the following items:

e A check box for ranking so many of top rows or so many bottom rows of
data. You can select the highest or lowest rows. Your selectionisbased on
previously selected row dimension members. When using the top or
bottom criterion, you specify the number of rows, such as“top 10.” The
default isthe top 25 rows.

e A Dimension being ranked list box to specify the dimension to which
ranking should be applied.
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e A Column used for ranking list box to specify the data column onwhich
data values are based.

e A DataRestrictionsbox to specify standard data comparison operations,
such asgreater than, lessthan, and equal to. You can apply the comparison
operator to data values in one or more data columns; you can even apply
criteriato compare values between two columns.

e Buttonsfor OR and AND operators. If you define more than one column
criterion, you can use these operators to link the criteria.

8. Click the Top check box, and enter avalue of 30 in the Rows text box.

When you apply the query, Essbase retrieves the top thirty rows of the
dimension.

9. From the Dimension list box, select Product. Product is the dimension to
which ranking should be applied.

10. From the Column list box, select Qtrl, Actual. Qtrl, Actual isthe column on
which data values are based.
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11. Inthe navigation panel, select the Data Filtering icon. Right-click and select
Apply Query.
Y our query results should look as shown below.

Figure 93: Data Filtering Query Results

-

East  (Cols 2461 2580

3440 2430 2410

1
| 2 |
| 3 |
| 4 | 3080
| 5 | Grape 645 840 860 920 618 800
| 6 | Cream Soda 591 7o 1010 660 592 530
| 7 Root Beer 562 960 1070 g30 980 1500
| 8 | Strawberry 545 700 750 780 525 670
EN Orange 280 350 380 420 394 440
| 10| Diet Cala 212 220 300 310 287 280
111 | Caffeine Free Cola 74 110 130 190 100 150
| 12 | West Cream Soda 2363 2620 2739 2970 3230 2652 2850
| 13 | Root Beer 2325 2570 2423 2720 2820 2439 2840
| 14 | Grape 1143 920 1167 960 1020 1219
| 15| Cola 1047 1720 1159 1900 2120 1018
| 16 | Orange 1002 g10 1120 g0 1000 940
| 17 | Caffeine Free Cola 62 310 -163 30 -130 -123
| 18 | Diet Cala 67 320 -177 200 250 -136
| 15| Strawberry -738 -310 -783 -3580 -440 -779
| 20 |South Root Beer 1465 1640 1540 1700 1612 1710 1495
| 21 | Cola 745 1160 835 1280 1031 14390 965
| 22 | Cream Soda 561 g10 528 7o 591 840 665
| 23 | Diet Cala 306 570 363 660 281 570 247
| 24 |Central Cream Soda 2414 2770 2579 2930 2648 2980 2450
| 25 | Root Beer 2369 3310 2457 3350 24581 3470 2271
| 26 | Grape 1050 1030 1155 1120 1220 1150 a70
| 27 | Orange 931 910 1075 1020 1073 1010 1070

28 Diet Cala 908 1130 1045 1320 1039 1340 ajiie)
[4/4[» [pi}Sheet1  Sheetz [ Sheetd 4]

Y ou can further filter your data output by specifying data comparison
operationsin the Data Restrictions box.

12. Inthe navigation panel, select the Data Filtering icon.

The datafilters that you specified are displayed in the properties panel.
13. In the Data Restrictions box, double-click.

The data restriction settings are displayed in the properties panel.

134 W Essbase Spreadsheet Add-in for Excel



14.

15.
16.
17.

18.

19.

20.
21.

22.

23.
24.
25.
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Select the Value option and type 500 in the Value box.
Observe that the is option in the Data list box changed to =.
Click the down arrow of the Data list box and select <=.
Select Qtrl, Actual in the Column list box.

In the navigation panel, select the Data Filtering icon. Right-click, and select
Apply Query.

Notice that the query results now reflect only Actual and Budget data that are
less than or equal to 500.

In the navigation panel, select the Data Filteringiconto display the datafilter
setting in the properties panel.

In the Data Restrictions box, select Qtrl, Actual <= 500, right-click and
select New Data Restriction.

In the Data box, click the down arrow and select <.

In the datavalueslist box, select Qtr2, Actual. Under Combined With Other
Restrictions, click the Or button.

In the navigation panel, click the Data Filtering icon to access the data filter
panel.

In the Data Restrictions box, double click to create a new data restriction.
In the Data box, click the down arrow and select | s Not.

Click the button for the #Missing Value option.

This option instructs Esshase to discard data that have #Missing values.
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26. Inthe Column list box, select Qtrl, Actual. Under Combined With Other
Restrictions, select the And button.

The data restrictions should appear as follows:

Figure 94: Data Filtering

r'} Hyperion Essbase Query Designer EHE
= Tse this data filter panel to retrieve data basedon =
the rank order that you have specified.
1. Belect the Top or Bottom check box, or both.
2. Bpecify how many rows you want to rettieve.
3. Select a dimension from the "Dimension being
ranked" drop-down list box.
4. Select the column from the "Column used for
----- BE 400, &1l Descendants ranking" drop-down list box.
=- Colurnn 5. Double-click in the "Data Restrictions" box to
=Bl Year create additional data filters.
..... B Qi Mote: Follow Step 5 only if you want to define LI
..... EIE| []10ed
..... [altk]
_____ % Qe Rark: W Top |30 _|:i'F|ows r Bott0m|25 _I::[ Flows
o -
= g Seenario Dimension being ranked:
B Actual
IF'roduc:t j
B Available Dimensions )
----- B Caffeinated (Basze:Product) Column used for ranking:
Intro D ate [Baze: Product] IQtr‘I L Actual j
Ounces [Baze:Product]
Pkg Type [Baze:Product] [rata Restrictions:
Fopulation (B aze:b arket) 1, Actual <= 500
Attribute Calculations OR Qtr, Actual < Q2, Actual
AND G, Actual is not #missing
[double click ta create a new data restriction)
[rata Sorting =
1 v
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27. Select the Data Filtering icon, right-click, and select Apply Query.

Esshase retrieves datafor all the quarters. Notice that the retrieved data for
Qtrl, Actual islessthan or equal to 500 or islessthan Qtr2, Actual. Theresults
should appear as follows:

Figure 95: Data Filtering Results

A B [ ¢ [ o | E F 6 | v [ v a

] =]
| 2|
| 4 |East Cola 2451 2550 3050 3440 2430 2410
1 5 | Grape 545 B40 B0 520 518 800
| 6 | Cream Soda 591 770 1010 BE0 592 530
| 7| Root Beer 562 950 1070 B30 990 1500
| 8 | Strawberry 545 700 750 780 525 70
1 9| Orange 290 350 350 420 394 440
|10 Diet Cola 212 220 300 310 257 290
111 Caffeine Free Cola 74 110 130 190 100 150
| 12 |West Cream Soda 2363 2620 2970 3230 2592 2850
113 | Root Beer 2325 2570 2720 2520 2439 2540
| 14| Grape 1143 520 950 1020 1219
|15 | Cola 1047 1720 1500 2120 1018
| 16 | Orange 1002 810 B0 1000 940
| 17 | Caffeine Free Cola 52 310 30 -130 -123
|18 | Diet Cola 67 320 - 200 - 250 -136
119 | Strawberry 738 -310 783 -380 -500 -440 779
| 20 | South Root Beer 1465 1640 1540 1700 1612 1710 1495
|21 Cola 745 1160 835 1280 1031 1480 955
| 22| Diet Cola 306 570 363 BE0 281 570 247
| 23 | Central Cream Soda 2414 2770 2579 2930 2645 2980 2450
| 24 | Root Beer 2369 3310 2457 3350 2481 3470 2271
|25 | Grape 1050 1030 1185 1120 1220 1150 570
| 26 | Orange 591 310 1075 1020 1073 1010 1070
| 27 | Diet Cola 908 1130 1045 1320 1059 1340 B39
| 28 | Cola B43 1080 928 1180 915 1170 793
|29 | Caffeine Free Cola 457 520 500 510 556 B0 567

30 Strawberry 77 50 57 50 130 140 205
4[4 [» [#]sSheet1 / sheetz £ sheets / 4]

Note: To delete all data restrictions, select the Data Filtering icon in the navigation
panel, right-click, and select Delete All Data Restrictions. Alternatively, select any data
restriction in the Data Restriction box, right-click, and select Delete All Data
Restrictions.

Note: To delete a particular data restriction, select the data restriction in the query

outline, right-click, and select Delete Data Restriction. Alternatively, select the data
restriction in the Data Restriction box, right-click, and select Delete Data Restriction.
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Sorting Data

138 |

Using the data sort panel, you can sort the output from the Basicl query in
ascending or descending order.

1. From the navigation panel, select the Data Sorting icon.

Thedatasorting settings are displayed in the properties panel. Y ou can specify
data sorting criteriathat affect the order in which the selected rows are

retrieved in the data sorting panel.

The data sorting panel contains the following items:

e A Dimension being sorted list box that lists the dimensions specified in
row format in the query.

e A Column used for sort list box that you use to select one or more
dimensions to be specified in column format in the query.

e AnOrdering list box that you useto apply an ascending or descending sort
order for the selected column. You can a so specify sorting to occur over
aspecific row dimension group. For example, you can sort by Product or
by Market.

Figure 96: Data Sorting Panel

4

O Market - l

----- B 400, &1l Descendants

EI Colurnn

EI---D. ear

I'_—'I--Ej Available Dimensions

Caffeinated (B aze:Produc
tro Date [Baze: Product]
unces [Base:Product]
lg Type [Base:Product]
‘opulation (B aze:karket]
Altribute Calculations

EZ
-5 Data Filtering, Top 30

i1, Actual < 500
OR Q. Actual < Qtr2, Actua

0t

ascending or descending order based on
column data values.
1. Belect a dimension from the
"Dimension being sorted" drop-
down list box
2. Click "Ordering" and select
Aarending nr Tearending from tha LI

Tse this data sott panel to sort rows in j

AND QO Actual iz not #miss

Dimenzion being sorted:

I Product

Ordering

=

Column used for sort

[double click to create a new sort rule]
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----- BE 400, &1l Descendants dimension.
[—] Colurnn 4. Double-click in "Column used for sort" to create
another sott nale.
ou have completed defining the sort nales. LI
Dimenzion being sorted:
IF'roduc:t j
Orderin Column used for sort
B Available Dimensions [Descendin > |Qtr1, Actual
Caffeinated [Base:Product) [double click to create a new sort rule]
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In the Column used for sort list box, double-click.

The selection defaultsto Qtrl, Actual. The sort order defaultsto Ascending in
the Ordering list box.

Click Ascending. A down arrow is displayed next to Ascending.
Click the down arrow. Descending is displayed below Ascending.
In the Ordering list box, select Descending.

Figure 97: Specifying Data Sorting Order

1. Belect a dimension from the "Dimension being
sotted" drop-down list box

Click "Ordering" and select Ascending or
Descending from the drop-down list box

3. From "Column used for sort," select the column

=

JTse this data sort panel to sort tows in ascending or *
= I descending order based on column data values.

Intro D ate [Baze: Product]
Ounces [Baze:Product]
Pkg Type [Baze:Product]
Population [Base:Market]
& Aftribute Calculations
[Drata Filtering, Top 30

%) O, Actual <= 500

OR Qtr, Actual < Q2, Actual
AND G, Actual is not #missing
[rata Sorting

1 Descending, Qtrl, Actual

|

~

o

In the next row of the Column used for sort list box, double click.

The selection defaults to Qtrl, Actual.

Click the down arrow and select Qtrl, Budget.

Observe that the order in the Ordering list box has defaulted to Ascending.

In the navigation panel, under Data Sorting, select Ascending, Qtrl, Budget.
Right-click and select Delete Sorting Rule.

The Ascending, Qtrl, Budget sorting rule is deleted from the query.
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9.

Apply Query.

In the navigation panel, select the Data Sorting icon. Right-click and select

Essbase returns the results sorted in descending order for each quarter, as

shown below:

Figure 98: Result of Filtering and Sorting Data

B [ ¢ [ o | E F c | H [ 1 ] 4

| 1|
| 2 |
| 4 |Cola 2461 2580 3080 3440 2410
| 5 |Grape 645 840 860 920 800
| 6 | Cream Soda 591 770 1010 60 530
| 7 | RootBeer 562 960 1070 830 1500
| B |Strawherry 545 700 780 780 670
| 9 |Orange 290 350 380 420 440
| 10 |Diet Cola 212 220 300 310 290
| 11 |Caffeine Free Cala 74 110 130 190 150
| 12| Cream Soda 2363 2620 2970 3230 2840
| 13| RootBeer 2328 2570 2720 2820 2840
| 14 |Grape 1143 920 960 1020
| 15 |Cola 1047 1720 1500 2120
| 16 |Qrange 1002 810 890 1000
| 17 | Caffeine Free Cala 52 310 30 -130
| 18 |Diet Cola &7 320 200 260
| 19 | Strawberry -73a -310 -3a0 -440
| 20| RootBeer 1465 1640 1700 1612 1710 1498
| 21 |Cola 745 1160 1280 1031 1490 965
| 22 |Diet Cola 306 570 60 281 570 247
| 23| Cream Soda 2414 2770 2930 2648 2980 2480

| 24| Root Beer 2369 3310 3340 2481 3470 2271

| 25 |Grape 1080 1030 1120 1220 1150 970

| 26 |Qrange 991 910 1020 1073 1010 1070

| 27 |Diet Cola 908 1130 1320 1082 1340 889

| 26 |Cola 843 1080 915 1170 793

| 25 Caffeine Free Cala 457 G20 556 G50 aE7

30 | Strawherry 77 90 130 140 205

14 4[> [#]\5heet1 / Sheetz £ Sheets /.

Note: The values that you are ranking and sorting must be the same. For example,
you cannot specify Product in the Dimension Being Ranked box and Market in the
Dimension Being Sorted box. If you specify different values, Hyperion Essbase
Query Designer automatically changes both values to the last specified value.

10. To closethe worksheet, select File > Close. You do not need to save the
worksheet.
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Retrieving Data into Asymmetric Reports

When you retrieve datainto a worksheet, the resulting report can be either
symmetric or asymmetric. Symmetric reports are characterized by repeating
identical groups of members. For example, Figure 98 shows a symmetric report
that contains Actual and Budget members nested below Y ear members (Qtrl,

Qtr2, Qtr3, and Qtr4).

An asymmetric report is characterized by groups of nested membersthat differ by
at least one member. There can be adifferencein the number of membersor in the
names of members.

Y ou can create asymmetric reports in one of the following ways:
e Enter member names into the worksheet in free-form retrieval mode.

e Useadrill action with the Within Selected Group option selected from the
Essbase Options dialog box (Zoom tab).

e Suppress rows that contain missing values, zero values, or underscore
characters during data retrievals.

If you retrieve data into an asymmetric report, Essbase must perform additional
internal processing to maintain the asymmetric layout. This processing may
increase the retrieval time on large reports. For more information regarding
optimizing reports, see the Essbase Database Administrator’s Guide.

As part of the default Essbase installation, Hyperion Essbase provides a sample
file, Asynm xI s, that illustrates how to create asymmetric reports.
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» Toview the samplefile, Asynm x| s:
1.
2.

Select File > Open.

From the\ Essbase\ cl i ent\ sanpl e directory, open the Asynm x| s file.

Depending on how software is installed on your PC, the file may not be
available or may belocated in adifferent directory. Contact the Essbase
system administrator for more information.

Figure 99: Asymmetric Report

—
=

Crearn Soda 8043

—_
p—y

7720

8300

A B [ C D E F [ G|
L1 |Sales
2]
L3 | Acts! | Budgst! | Bvdge?! | Sudgs?
L4 ] Ol Owr2 Otr3 Otr4
L5 [East Colas G292 G760 7300 5570
L6 | Foaot Beer 5726 5650 5600 5780
L7 | Fruit Soda 3735 4150 4350 3850
8
L9 [\West RootBeer 8278 7970 8320 7820

7570

In Asymm x| s, row and column dimension groups are asymmetric. Thus, the
nested member groups from the Product dimension differ in member content
within respective markets. For example, Colas and Fruit Sodaare included in
East but not in West. In addition, Actual datais displayed for Qtrl, whereas

Budget datais displayed for Qtr2, Qtr3, and Qtr4. Also notice that the sample
file displays styles for members of the Scenario and Y ear dimensions.

Leavethe Asynm xI s file open for the next tutorial task.
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Pivoting in Asymmetric Reports

When you pivot agroup of membersin an asymmetric report, Essbase keeps only
unique members from dimensions that are not involved in the pivot.

» To usethe open Asynm xI s filetoillustrate this point:
1. Using the right-mouse button, drag East to the cell below Qtrl.

Figure 100: Result of Pivoting in an Asymmetric Report

A [ B [c] b [JEJ] F Ja[ H J1]
L1 Sales
2]
L3 | Acts! Sudgs? Sudgs? Sudgs?
L4 ] Otrl Otr2 Otr3 Otr4
L5 | East [westlFast Wiest East West East Wiest
L6 [Colas G292 B350 G760 8800 7300 9100 5570 8430
|7 [FootBeer B7Z6 8278 BEE0 7970 5600 8320 5780 7820
L8 [FruitSoda 3735 8403 4150 5840 4350 6070 3850 5280
L9 [Cream Soda| 4868 8043 40300 7720 3850 8300 3170 7570
10

Essbase combines the Product members into all unique members. For
example, Root Beer, which isdisplayed twicein Figure 99, is displayed only
once in the current view. Colas, which is displayed in only one market in
Figure 99, now is displayed in East and West.

Essbase a so removes the blank line between Product row groups. A pivot
action always eliminates any rows or columnsin which al cells are empty.

2. Close Asymm xI s without saving the changes.

Working with Formatted Worksheets

In addition to providing flexible, ad hoc retrievals, Essbase supports retrieving
datainto formatted worksheets. A worksheet can contain the following formats:

e  Spaces between rows and columns
e Cell valuesthat contain text or datathat is not defined in the database outline
e Member names in noncontiguous locations at the top of aworksheet

e Excel formulas (see also “Preserving Formulas When Retrieving Data’ on
page 149)

e Visua cues (styles)
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After you format and save a worksheet, you may want to retrieve and navigate
through new data in the existing worksheet format. This section provides the
following information on working with formatted worksheets:

e “Observing the Rules for Working with Formatted Worksheets” on page 144
e “Retrieving Datainto Formatted Worksheets’ on page 145
e “Pivoting Data on Formatted Worksheets” on page 147

Observing the Rules for Working with
Formatted Worksheets

Observe the following rules when retrieving data into a formatted worksheet:

Rulel

Intheworksheet, no numeric cellscan belocated before thefirst Hyperion Essbase
datacell. For example, in Figure 101, the first Essbase datacell isB6. Neither any
cell inrows 1 through 5 nor cell A6 can contain numeric values. Also, these cells
cannot contain formulas that resolve to numeric values.

Rule?2

A cell that lies within arow or column of Essbase data cannot contain text or
numeric values. For example, in Figure 101, the cellsin columns B, C, D, and F
and rows 6 through 9 and 11 through 14 cannot contain any nondata text or
numbers, for such values may be overwritten (or emptied) by the retrieved data.
These cells can contain formulas, however, if Formula Preservation options are
used. For more information on Formula Preservation options, see “ Preserving
Formulas When Retrieving Data’ on page 149.

Tip: If you need to preserve text in a cell, define that text or value as an Excel formula,
and use the Formula Preservation options.

Rule3

The Pivot command is not available when the Retain on Retrieval check box is
selected in the Essbase Options dialog box (Mode tab).
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Rule 4

ThePivot command removesall cellsthat contain text other than database member
names.

Retrieving Data into Formatted Worksheets

As part of the default Essbase installation, Essbase provides a samplefile,
P&l . xI s, that illustrates how to retrieve data into a formatted worksheet. The
P&l . x| s samplefileillustrates how to retrieve datainto aworksheet that contains
formatted text, formulas, and protected cells.

» Toview the P&l . x| s worksheet:
1. Select File > Open.
2. Fromthe\ Essbase\ cl i ent\ sanpl e directory, openthe P&l . xI s file.

Depending on how software isinstalled on your machine, the file may not be
available or may belocated in adifferent directory. Contact the Essbase
system administrator for more information.

Figure 101: A Sample Formatted Worksheet

A [ B [ € | o [ E [ F ] G [ H
L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget
4
I—
6 |Misc 5 10 10 25 0.30
7 |Payroll 200 200 200 500 0.07
8 |Marketing 350 350 350 1050 12.47
9 Total Expenses 555 560 560 1675 19.89
10
11 |COGS 1170 1180 1200 3550 42.16
12 |Sales 2740 2520 2860 8420 100.00
13 Margin 1570 1640 1660 4570 57.84
14 Prafit 1015 1080 1100 3195 37.95
15
16 [Ratio Analysis
17 | Markup 57.3% 558.2% 58.0% 57.8%
18 |Marketing % 12.8% 12.4% 12.2% 12.8%

Select Essbase > Options and select the Display tab.
4. Inthe Céells option group, make sure that Adjust Columnsis checked.
5. Select the Mode tab.
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In the Formula Preservation group, select the Retain on Retrieval check
box to enable Formula Preservation mode.

Note: When Retain on Retrieval is enabled, there may be a slight delay in retrieval
time.

Click OK.

By default, an Essbase retrieval overwrites Excel formulawith data valuesin
the retrieval area of aworksheet. Theretrieval process also eliminates
formulasin cellsoutsidetheretrieval area. However, the Retain on Retrieval
option enables you to define retrieval s that do not overwrite formulasin any
area of the worksheet.

Select Essbase > Retrieve to update the worksheet with the latest data val ues.

Essbase determines that some text cellsin the worksheet do not correspond to
database member names. When Essbase is unable to resolve text in the
worksheet, the following message is displayed:

Figure 102: Essbase Unknown Member Message

Essbhase Message ]

The sheet contains ah unknown member: barket:.
Thiz item will be ignored when you retrieve data from the server.

There may be additional cells that contain unknown database members.
Do you want to display additional unknown members in this retrieval ?

In this example, the first unknown member detected is Market: (in cell Al).
Essbase does not recognizethe colon (;) that follows Market in the cell. If you
click Y es, Esshase displays the next unknown member; if you click No,
Essbase continues with the retrieval.

Note: If you work with formatted worksheets often, you may want to tell Essbase
not to display this message. For more information, see “Pivoting Data on Formatted
Worksheets” on page 147.
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9. Click No to close the dialog box and continue with the retrieval.

Essbase retrieves new data but retains the formatting and formulas in the
worksheet.

Figure 103: Result of Retrieving on a Formatted Worksheet

A [ B [ € | o [ E [ F ] G [ H
L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget
4
]
6 |Misc Eissing  BMissing #Missing .
7 |Payroll 210 210 210 530 0.07
8 |Marketing 300 310 320 930 11.05
9 Total Expenses 510 520 530 1560 18.53
10
11 |COGS 1170 1180 1200 3550 42.16
12 |Sales 2740 2520 2860 8420 100.00
13 Margin 1570 1640 1660 4570 57.84
14 Prafit 1060 1120 1130 3310 383
15
16 [Ratio Analysis
17 | Markup 57.3% 558.2% 58.0% 57.8%
18 |Marketing % 10.9% 11.0% 11.2% 11.0%

10. Close P&l . x| s without saving it.

Note: This chapter’s section on “Preserving Formulas When Retrieving Data” on
page 149 provides additional tutorial tasks that show you how to take advantage of all
the Formula Preservation options.

Pivoting Data on Formatted Worksheets

With the Pivot command, you can produce ad hoc reports in both formatted and
unformatted worksheets. However, aformatted worksheet may contain labels and
formulas that make the result of a pivot operation ambiguous. The pivot is
designed to compress and retain only the database el ements represented in the
worksheet. The worksheet also retains |abelsin areas that are not overwritten by
pivoted data.

Note: Essbase prevents pivot operations on worksheets that contain formulas when
Formula Preservation mode is active.

I nv. xI s, asamplefileinstalled as part of the Essbase installation process,
illustrates how to pivot datain aworksheet. It was saved with the Retain on
Retrieval option disabled so that you can pivot on its worksheets.
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» Toview thel nv. xI s worksheet:
1. Select File > Open.
2. Fromthe\ Essbase\ cl i ent\ sanpl e directory, openthel nv. xI s file.

Depending on how software is installed on your PC, the file may not be
available or may belocated in adifferent directory. Contact the Essbase
system administrator for more information.

Figure 104: Formatted Worksheet Before Pivoting

n [ B [ e [ o J E [ F | &=
1 [Market frveniany: Analvsrs
2 |Actual
3 Jan Feb Mar Gt
4
5 |[Sales 100 8314 g327 8407 25048
6 200 8716 8960 8951 26627
7 300 7874 046 8077 23997
8 400 G634 G736 G778 20148
9 Produst 31638 32069 32213 95820
10
11 Opening [nventony 100 29448 28124 28929 29448
12 " Adjusted for Audit 200 33000 32100 31125 33000
13 300 28865 28964 29095 28865
14 400 26092 26246 26409 26092
15 Produst 117408 116434 1156558 117408
16
17 [Stock to Sales 3.72 3.63 3.59
18 ===== ===== =====

Select Essbase > Options and select the Global tab.

In the Display Messages group, clear the Display Unknown M ember s check
box to avoid seeing the Essbase messages when working with formatted
worksheets.
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5. Using the right-mouse button, drag Sales (in cell A5) to the cell nested below

Jan (C4).

Essbase pivots the Sales member group so that it is nested below the monthly
members. However, during the pivot, Essbase retains only database elements.
For example, al datafor Stock to Sales and Adjusted for Audit is deleted

during the pivot.

Figure 105: Result of Pivoting on a Formatted Worksheet

6. Closel nv. xI s without saving it.

f B C o | E F ] ] |
1 fmventary Analvsis M arket
2 Astual
3 Jan Feb Mar
4 Sales  [Cpening Inventory  [Rales Opening [nventorySales Cipening Inventory
5
6 100 314 20448 2327 20124 8407 28820
¥ 200 8716 33000 o460 32100 8951 3125
8 300 Tav4 28865 8046 28064 8077 20095
9 400 G634 26092 G736 26246 G778 26408
10 Product 3538 117408 32069 116434 32213 115658
11
12 " Adjusted for Audit
13
14
15
16
17 [Stock to Sales
18 —===o] —===o] —===o]

Preserving Formulas When Retrieving Data

In“Retrieving Datainto Formatted Worksheets” on page 145, you used the Retain
on Retrieval option to preserve formatting and formulasin an existing worksheet.
Collectively, the Formula Preservation options enables you to retain formulas

during data retrievals, keep and remove only

operations, and drill operations. In

addition, Essbase can replicate formulas for additional membersretrieved into the
worksheet as part of adrilling operation. This section steps you through using all
of the Formula Preservation optionsin areport that you create.
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Y ou must enabl e some options before you can enabl e other options. Keep in mind
the following guidelines and restrictions when using the Formula Preservation
options:

On the Mode tab of the Essbase Options dialog box, you must have the
Advanced Interpretation option selected to enable Retain on Retrieval. The
Formula Preservation options do not work with free-form retrieval mode.

You must enable Retain on Retrieval to enable Retain on Keep and Remove
Only and Retain on Zooms.

You must enable Retain on Zooms to enable Formula Fill.

When you select the Retain on Retrieval check box, the Suppress #Missing
Rows and Zero Rows options on the Display tab become disabled.
Conversely, if you have either of the Display options selected, the Formula
Preservation options are automatically disabled.

When you select the Retain on Zooms check box, the Remove Unsel ected
Groups option on the Zoom tab is disabled. When you enable the Remove
Unrelated Groups option, Retain on Zooms is automatically disabled.

When Retain on Retrieval is enabled, there may be adight delay in retrieval
time.

Asagenera rule, insert ablank row as the last row in the formularange to
ensurethat the cell rangein theformulaexpands properly when you drill down
on members with Retain on Zooms enabled. For more information, see the
Esshase Spreadsheet Add-in online help.

Formula arrays are not supported in Esshase Spreadsheet Add-in when the
preserve formula option is on. If you have formula arrays in the worksheet,
Esshase does not preserve these types of formulas.

To preserve formulas when retrieving or retaining data:

1
2
3.
4

To open anew worksheet, select File > New or click the QI button.
Select Essbase > Retrieve.
In cell A2, drill down (double-click) on Year.

Press and hold the Alt key and, in cell E1, drill down (double-click) on
Scenario.
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Select cell G3 and enter the following formulain the cell: =B3/ B7* 100

Figure 106: Entering an Excel Formula into a Cell

A [ B [ € [ D ] E [ F ] G [ H ]
L1 Measures Product Market
L2 | Actual Budget “ariance ‘ariance % Scenario
I3 |Gt 24703 30580 5877 1921844343 24705[=B3/B77100 I
|4 [Gtr2 27107 328700 5763 -17.53270458 27107
L5 [Gtr3 27912) 33980  -BOBG | -17.8575B327 27912
|6 |Gitrd 25800 31950  -B150) -19.24882629 25800
L7 | Year 105522 129380 -23858 -18.44025352 105522
8
9 |
|10
Press Enter.

Excel calculatesthe formulathat you entered in cell G3 and now reflects Qtrl

as a percentage of Year.

Figure 107: Result of Excel Formula with Essbase Data

A [ B [ € [ D ] E [ F ] G [ H ]
L1 Measures Product Market
L2 | Actual Budget “ariance ‘ariance % Scenario
I3 |Gt 24703 30580 5877 1921844343 24705( 23410284111
|4 [Gtr2 27107 328700 5763 -17.53270458 27107
L5 [Gtr3 27912) 33980  -BOBG | -17.8575B327 27912
|6 |Gitrd 25800 31950  -B150) -19.24882629 25800
L7 | Year 105522 129380 -23858 -18.44025352 105522
8
9 |
10

Select Essbase > Options and select the M ode tab.

In the Formula Preservation area, select the check boxes for Retain on
Retrieval and Retain on Keep and Remove Only. Click OK.

In cells D2, E2, and F2, respectively, select Variance, %Variance, and
Scenario.
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10.

11.
12.

13.

14.
15.
16.

152 |

Select Essbase > Remove Only.

Esshase removes the selected columns but retains the Excel formulathat you
entered, keeping it with the retained dataset.

Figure 108: Result of Removing Columns with Retain on Keep or
Remove Only Enabled

A [ B [ € ] D [ E T F T 6 ]
Measures Product Market

Actual Budget
24703 30580
27107 32870
27912 33980
25800 31950
105522 129380

23.410268411

Qtr1
Qtr2
Qtr3
Ctrd
Year

Select Essbhase > Options and select the M ode tab.

Inthe FormulaPreservation area, click the box for Retain on Zooms and click
OK.

In cell A3, drill down (double-click) on Qtrl.

Essbase drills down on Qtrl and moves the formula down with the Qtrl
member.

Figure 109: Result of Drilling Down with Retain on Zooms Enabled

A [ B [c ] o [ E [ F [ 6 |
Measures Product Market
Budget
9940

Actual

Jan 8024

Feb

Mar
Qtr1
Qtr2
Qtr3
Ctrd

8346
8333
24703
27107
27912
25800

10350
10280
30580
325870
33580
31550

23.410268411

=y
=

Year| 105522 129380

-
pry

Select Essbase > FlashBack.
Select Essbhase > Options and select the M ode tab.

In the Formula Preservation area, select the For mula Fill check box.
Click OK.
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17. Incell A3, drill down (double-click) on Qtrl.

Essbase drills down on Qtr1 and replicates the formula for each member of
Qtrl (Jan, Feb, and Mar). To view the replicated formulas, click in cells D3,
D4, D5, and D6 and look at the new syntax in the Excel formula bar.

Figure 110: Result of Drilling Down with Formula Fill Enabled

A [ B [ € ] D [ E [ F ]
Measures Product Market
Actual Budget
Jan 8024 9940 2960121002
Feb 8346 10350 29.9011178
Mar 8333 10290 32.29544961
Qtrl 24703 30580 23.41028411
Qtr2 27107 32870
Qtr3 27912 33980
Qtrd 25800 31950
Year| 105522 129380

=y
=

-
pry

18. Before moving on with the tutorial, compl ete each of the following actions:
a. Select Essbase > Options and select the M ode tab.
b. Clear al of the Formula Preservation options.

c. Select File> Close to close the worksheet. You do not need to save
the worksheet.

Retrieving a Range of Data

Inatypical Excel worksheet, you can select arange of cells by dragging the mouse
across the worksheet. Y ou can also select arange of cells and tell Essbase to
restrict the dataretrieval to the selected range in the worksheet. Retrieving arange
of datais particularly useful in the following situations:

e A worksheet contains multiple reports.

e A worksheet contains extraneous information that is not supported in a
formatted report retrieval.

e You need to retrieve only a small subset of values from the server, thus
dramatically decreasing retrieval time for large datasets.

e You need to retrieve data to an area of the worksheet other than the first
column.

As part of the default Essbase installation, Essbase provides a samplefile,
Profit.xl s, that illustrates how to retrieve arange of data.
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» ToviewtheProfit.xls file
1. Select File > Open.
2. Fromthe\ Essbase\ cl i ent\ sanpl e directory, opentheProfit. xl s file.

Depending on how software is installed on your PC, the file may not be
available or may belocated in adifferent directory. Contact the Essbase
system administrator for more information.

Profit. x| s hasalready selected arange of cells (B2 through F9) for you.

Figure 111: Selected Range of Cells for Retrieval

iy O By

Central  Actual Profit %2
Citrl Citr2 Citr3 Citr4 Year
100-10 220 220 220 220 220
100-20 220 220 220 220 220
|16 | 100-30 220 220 220 220 220

3. Select Esshase > Retrieve to update the selected range.

Figure 112: Result of Retrieving First Range of Data

iy O By

Central  Actual Profit %2
Citrl Citr2 Citr3 Citr4 Year
100-10 220 220 220 220 220
100-20 220 220 220 220 220
|16 | 100-30 220 220 220 220 220

Esshase updates only the data in the selected range of cells.

154 W Essbase Spreadsheet Add-in for Excel



An Advanced Essbase Tutorial

4. Select cells B12 through G16.
Figure 113: Selecting Cells for Retrieval
A [ B [© D E F G | H |
1
L2 | 1aa Central
L3 | Actual Budget
L4 ] Sales Profit 3 Sales Praofit 34
5 | Qtrt 8074 273 8200 345
[ 6 | Qur2 8701 284 8870 36.1
(7 | Qur3 8834 288 9060 363
(8 | Qtrd 8133 276 7800 38.1
ER Year 33308 281 33930 367
110 |
|11
112 |
113 |
114 |
115 |
|16 |
5. Select Esshase > Retrieve once again to update the selected range
Essbase updates the data in the selected range.
Figure 114: Result of Retrieving Second Range of Data
A [ B [© D E F G | H |
1
L2 | 1aa Central
L3 | Actual Budget
L4 ] Sales Profit 3 Sales Praofit 34
5 | Qtrt 8074 273 8200 345
[ 6 | Qur2 8701 284 8870 36.1
(7 | Qur3 8834 288 9060 363
(8 | Qtrd 8133 276 7800 38.1
ER Year 33308 281 33930 367
110 |
|11
112 |
113 |
114 |
115 |
|16 |
6. CloseProfit.xls without saving it.
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Retrieving Data by Using a Function

The Essbase cell retrieve function, EssCell, retrieves a single database value into
aworksheet cell. Enter an EssCell function directly into aworksheet or select an
EssCell function from the Excel menu bar.

Note: You must be connected to a database to use EssCell.

EssCell retrieves data when you perform an Essbase retrieva or when you

recal culate aworksheet through Excel. As part of the default Essbase installation,
Hyperion Essbase provides a samplefile, Summar y. xI s. Thisfile has EssCell
functions already set in cells B16 and B17.

» Toview the Summary. xI s file:

1. Select File > Open.

2. Fromthe\ Essbase\ cl i ent\ sanpl e directory, open the Summary. x| s
file.

Depending on how software isinstaled on your PC, the file may not be
available or may belocated in adifferent directory. Contact the Esshase
system administrator for more information.

Figure 115: Worksheet Containing EssCell Functions

A [ B [ ¢ | b [ E [ F | G |
L1 |200
| 2 |Texas
3]
L4 ] Budget
L5 | Oitrl Otrz Otr3 Oitrd “rear
|6 |Sales 1460 1560 1630 1320 5470
L7 |COGS 56D 540 B30 500 2280
L8 | Margin a00 970 1000 G20 3640
L9 |Marketing 160 160 170 120 610
|10 |Payrall 60 60 60 110 240
11 |Misc #issing  #Missing #Missing #Missing #Missing
|12 | Tatal Expenses 220 220 230 230 Bl
13 | Prafit BE0 750 770 540 2740
4]
15 ]
|16 | “rear Salesl #NEA _l
|17 |  ‘“vearMargin i #MNA

CellsB16 and B17 in Sunmar y. x| s contain the EssCell function. If you
select either of these cells, you can view the syntax for the EssCell function
in the Excel formula bar at the top of the worksheet.
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The EssCell function is defined in acell asfollows:

=EssCel | (nbrList)

mbrList is one of the following:

e A null value. If the parameters of the function are empty, Essbase returns
the data value from the top of each dimension.

e A comma-delimited list of member names. Member names must be
enclosed in double quotes, with only one member per dimension allowed.
If you list no members from a particular dimension, the function returns
the data value from the top member of the unspecified dimension.
Furthermore, you can include aliases in the member list, subject to the
same rules as member names.

e An Excd cell reference. The reference must point to acell that contains
avalid member name. Member names, such as 200 and 300-10, need to
be formatted as text cells, rather than numeric cells.

For example, the syntax for the EssCell function in cell B16 in the
Summary. x| s fileisthe following:

=EssCel | ("Sal es", Al, A2, B4, F5)

When you open the worksheet, the values in these cells are #N/A. To update
the values with the data in your database, you must perform aretrieval from
Essbase.
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3. Select Essbase > Retrieve.Esshase calculates the EssCell functionsin cells
B16 and B17.

Figure 116: Retrieval on a Worksheet Containing the EssCell Function

A [ B [ ¢ | b [ E [ F | G |
1 |200 1
| 2 |Texas
3]
L4 ] Budget
L5 | Oitrl Otrz Otr3 Oitrd “rear
|6 |Sales 1460 1560 1630 1320 5470
L7 |COGS 56D 540 B30 500 2280
L8 | Margin a00 970 1000 G20 3640
L9 |Marketing 160 160 170 120 610
|10 |Payrall 60 60 60 110 240
11 |Misc #issing  #Missing #Missing #Missing #Missing
|12 | Tatal Expenses 220 220 230 230 Bl
13 | Prafit BE0 750 770 540 2740
4]
15 ]
|16 | rear Zales 5870
|17 |  ‘vearMargin 3 £1.81

Now update the EssCdll functions to retrieve data for a different state.
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4. Change the contents of cell A2 from Texasto Florida.

The valuesin cells B16 and B17 are updated as soon as you update the cell.
The update occurs because Excel has recal culated the worksheet (if you have
configured Excel to calculate changes automatically). The remaining data
cells do not change. To completely update the worksheet, you must retrieve
datafrom the server.

Figure 117: Updating the EssCell Function

A [ B [ ¢ | b [ E [ F | G |
1 (200
2 |Florida I
3]
L4 ] Budget
L5 | Oitrl Otrz Otr3 Oitrd “rear
L6 [Sales 1460 1560 1630 1320 5970
L7 [COGS 560 540 630 500 2280
L8 [ Margin Ja0 370 1000 gz20 36490
L9 [Marketing 160 160 170 120 610
|10 [Fayroll 1] 1] 1] 110 240
11 |Misc #issing  #Missing #Missing #Missing #Missing
|12 | Tatal Expenses 220 220 230 230 Bl
13 | Profit Ga0 750 770 540 2740
4]
15 ]
|16 | rear Zales 5030
|17 |  ‘vearMargin 3 E0.04

Tip: If the worksheet contains many EssCell functions, change Excel to manual
calculation mode. This change prevents the cell retrieve from calculating until you
retrieve data or calculate the worksheet manually. For more information, see the
Microsoft Excel documentation.

5. Select Esshase > Retrieve to update the report.

Essbase returns an error message if EssCell is unsuccessful. The following
table lists messages that Essbase displaysin the EssCell cell and explainsthe
conditions that cause the messages:

Message Reason

#N/A The worksheet is not connected to a database.

#VALUE! A member namein thelist or referenceisinvalid.

#NAME? A text name in the function does not contain double
guotation marks.
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6. CloseSummary. x| s without saving it.

The samplefile that you used for thistutorial task already had EssCell functions
defined. To enter your own EssCell function into a worksheet, you do the following:

1. From the Excel menu bar, select Insert > Function.
2. From the Function Category list, select Essbase Add-in.
The Excel Function Wizard steps you through defining the EssCell function.

Note: For more information on EssCell functions, see the Essbase Spreadsheet Add-in
online help.

Retrieving Dynamic Calculation Members

160 W

Dynamic calculation members are database members that are excluded from the
batch calculation process, thus shortening the regular database calculation time.
The Essbase application designer tags dynamic cal culation membersin the
database outline so that Essbase knows not to cal cul ate those members until adata
retrieval requests them. This processis referred to as dynamic calculation.
Dynamically calculating database members benefits the Essbase server in the
following ways:

e Reduced disk usage
e Reduced database restructuring time
e Reduced time to back up the database

Database values that Essbase cal culates dynamically take slightly longer to
retrieve in Esshase Spreadsheet Add-in because Essbase must perform
calculations before retrieving data into the worksheet. For more information on
dynamic calculation, see the Essbase Database Administrator’s Guide.

Tip: Enable the Navigate Without Data feature while you arrange the spreadsheet
report so that Essbase does not dynamically calculate the database when you are
creating the report. For more information on the Navigate Without Data feature, see
“Navigating Through the Worksheet Without Retrieving Data” on page 67.

Because there may be a performance impact on retrieving data for dynamic
calculation members, define visua cues, or styles, for these members so that you
can identify them in Essbase Spreadsheet Add-in.
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To illustrate how to use Dynamic Calculation members, use the Asynm x| s file.

To view the Asymm x| s file:

1.

2
3.
4

© © N o

Select File > Open.

From the\ Essbase\ cl i ent\ sanpl e directory, open the Asynm x| s file.
Drill up on Actual by double-clicking the right-mouse button in cell C3.

In cell C3, drill down on Scenario to display all members of Scenario.

Essbase displays only the Scenario members for Qtr1.

Figure 118: Displaying Scenario Members

A B [ ¢ [T b | E ] F [ & |
L1 Sales
2]
L3 | |,4mw' _l Budget | Vanance | Yanance & | Soanaia
L4 ] Ol Ot Otrl Otrl Otrl
L5 |East Calas 6292 5870 422 7.188087104 6292
L6 | Fioot Beer 5726 5460 266 4.871794872 5726
L7 | Fruit Soda 3735 3860 -145| -3.737113402 3735
8
L9 |west RoaotBeer 8278 7700 578 7.506493506 8278
10 Cream Soda | 6043 BEA0 11683 16.73434768 8043

Select Essbase > Options and select the Style tab.

Note: You must be connected to the Sample Basic database to display the Style
tab. For more information on connecting to a database, see “Connecting to a
Database” on page 124.

In the Members group, scroll down until you see Dynamic Calculations.
Select the Dynamic Calculations check box and click the Format button.
Inthe Font stylelist, select Bold Italic.

Inthe Color list, select Gray.

. Click OK and then select the Display tab.
11.

In the Cells option group, click Use Styles. Click OK.
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12. Select Esshase > Retrieve.

Esshase displaysthe dataand appliesall the visual cues, or styles, that you set,
including the newly set styles for dynamic cal culation members and the styles
you set in Chapter 2. You can tell that the columns for Variance and
Variance% are dynamically calculated because Hyperion Essbase displays
these membersin gray, bold, italicized font. (Variance and Variance% also
have ared background because that style was previously set for all members
of the Scenario dimension.)

Figure 119: Result of Retrieving Dynamic Calculation Members

A B [ c ] D H F I
L1
|2
3 Actal|Budget] ¥anance | Variance % | ]
| 4 Ol Qtrl Ol Otrl Otrl
| 5 |East [Colas £292  BA70 422/ 7189087104 292
| 6 | Root Beer 5726 54E0 266 4871734872 5726
| 7| Fruit Soda 3735 3880 -145)  -3737113402 37385
]
| 8 |west Root Beer g27a 7700 578 7506493506 g278
| 10 Cream Soda 8043 6390 1183 16.73439768 043

Note: Occasionally, other styles you have set may override a style for dynamic
calculation members. For example, if a parent member is also a dynamic
calculation member, and if you have styles set for both parent and dynamic
calculations, the style for the parent member overrides the style for the dynamic
calculation member. In this case, you need to remove the style for parent members
in order to see the style for dynamic calculation members. For more information on
the precedence of styles, see “Determining the Precedence of Overlapping Styles”
on page 83.

13. Close the Asymm x| s filewithout saving it.
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Specifying the Latest Time Period for
Dynamic Time Series

Dynamic Time Series members are predefined database members that are used in
dynamic, to-date reporting, such asyear-to-date or month-to-date values. Dynamic
Time Seriesmembers do not appear asindividual membersin the database outline;
instead, they correspond to a generation name that uses a key term for time, such
as year, month, or day.

For example, in the Sampl e Basic database, a generation name called Quarter was
created for generation 2inthe Y ear dimension. Generation 2 includes the members
for Qtrl, Qtr2, Qtr3, and Qtr4. When the generation name Quarter was created,

Esshase created a Dynamic Time Series member called Q-T-D, or quarter-to-date.

To take advantage of Dynamic Time Series in Essbase Spreadsheet Add-in,
choose the latest time period for which you want datain ato-date calculation. The
calculated value of the Dynamic Time Series member is derived when you define
the latest time period to be reported. In the Sample Basic database, for example,
the level 0 members of the Y ear dimension are the months of the year: Jan, Feb,
Mar, and so on. If the current month is August, and you want to know the sales data
for the quarter up to the current month, a quarter-to-date calculation gives you the
sales data for the months of July and August.

» Toillustrate the concept of Dynamic Time Series:

To open anew worksheet, select File > New or click the QI button.
Select Essbase > Options and select the Zoom tab.

In the Zoom In option group, select Next Level.

Clear the Within Selected Group check box and click OK.

Select Essbase > Retrieve.

In cell B1, drill down (double-click) on Measures.

Incell B2, click Year.

N o o M~ w NP
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8. TypeQ T-Dincell B2 and press Enter to enter a predefined Dynamic Time

Series member (Q-T-D):

Figure 120: Entering a Dynamic Time Series Member into a Worksheet

| A [ B | C D E
Product Market

1
2 Q.T.0 105522
E Year 117405
4 Year 5526162527
5 Year 105522
B
7

Note: For alist of other possible Dynamic Time Series members, see the Essbase
Spreadsheet Add-in online help.

9. Select Essbase > Options and select the Display tab.
10. Inthe Dynamic Time Series area, select the Latest Time Period check box.
11. From thelist box, select May. Click OK.

Figure 121: Specifying Latest Time Period in a Dynamic Time Series

Essbase Options E

Display |Zoom I tode I Style I Globall

Indentation—————— ~ Feplacement
" Mone #higzing Label: I
' Subitems
& Totak #Mo Access Label: l—
— Suppre — Aliaze:
™ #Missing Fows V' Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions
= Alias:
™ Use Styles IDefauIt j
V' Adiust Columng
= Aute Sort Homs Query Designer
" Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic Time Serie

[+ Latest Time Period IMH

QK I Cancel | Help |

Note: If you do not specify a latest time period, Essbase uses the first level 0
member (Jan) as the default.
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12. Select Esshase > Retrieve.

Note: The Retrieve & Lock, Zoom In, and Zoom Out commands are not supported
with Dynamic Time Series members.

Essbase displays data for the Q-T-D member. The data valuesin the
worksheet are the aggregated values for April and May, because May is the
month you specified as the latest month in the quarter-to-date Dynamic Time
Series.

Figure 122: Result of Specifying Latest Time Period in a
Dynamic Time Series

[ A B ] C e E
Product Market

1

2 Q1D 17573
E Year 117405
4 Year 5526162527
5] Year 105522

13. To close the worksheet, select File > Close. You do not need to save the
worksheet.

Note: You can also create a report like the one shown above by simply typing the name
of the Dynamic Time Series member followed by the name of latest time period in
parentheses: for example, Q-T-D (May). If you are using free-form retrieval mode, you
must enter the Dynamic Time Series member and the latest time period in separate,
adjacent cells. You can also select a Dynamic Time Series member and a latest time
period through Hyperion Essbase Query Designer or through Member Selection.

Note: For more information on Dynamic Time Series, see the Essbase Spreadsheet
Add-in online help.

Using Substitution Variables

The Essbase application designer uses substitution variables to define global
variablesto represent values that are specific to Esshase. For example, Latest can
be a substitution variable representing the latest time period in a Dynamic Time
Series. Using Esshbase Application Manager, the application designer sets
substitution variables and their corresponding values for a specific application.
Essbase stores these variables and their val ues on the Essbase server. Y ou can take
advantage of the predefined substitution variables in Essbase Spreadsheet Add-in
during Dynamic Time Series reporting.
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For exampl e, say the application designer sets a substitution variable on the server
for the current month. The variableis called CurMnth and has a value of August.
If you use the substitution variable in the worksheet, aretrieval returns values for
August, because August is set as the current month on the server. If, at alater date,
the application designer changes the value of the CurMnth substitution variable to
October, aretrieval returns data for October.

The Sample Basic database you are using for this tutorial does not contain
predefined substitution variables. If the application designer had set a substitution
variablein the database you are using, you could enter a substitution variable
directly into aworksheet. For example, you could open ablank worksheet and type
member names as follows:

Figure 123: Entering a Substitution Variable in a Worksheet

A [ B | C [ D | E
Product Measures Market Scenario
&Curtnth

ol o]~

Note: Notice the substitution variable (CurMnth) in cell A2. When you enter a
substitution variable directly into a cell, you must precede it with an ampersand (&).

In this example, aretrieval produces the following results:

Figure 124: Result of Retrieval on a Substitution Variable

Al B[ ¢ [ p] E [ F |
Product Measures Market Scenario
Aug 9545

Esshase queries the server for the value of the substitution variable CurMnth,
whichis August. Datais returned only for August.

Note: If you save a worksheet containing a substitution variable as a template, make
sure that you save the worksheet before you retrieve data. For example, if you save the
worksheet shown in Figure 124 as a template, each time you retrieve the template,
August rather than the substitution variable CurMnth is displayed.
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Using Free-Form Reporting to Retrieve Data

So far, you have learned how to retrieve Essbase data into a worksheet through ad
hoc retrieval, Hyperion Essbase Query Designer queries, and Member Selection
operations. In addition to these retrieval methods, Essbase supports free-form
reporting. Free-form reporting enables you to tell Esshase specifically what you
want to retrieve by simply typing datainto the worksheet. Free-form reporting is
especially useful when you are familiar with the dimensions and membersin the
database outline.

Esshase provides two different retrieval modes for free-form reporting:
e Advanced Interpretation

o Free-Form

In both retrieval modes, enter member names directly into the worksheet. The
following sections describe the similarities and differences between the two
modes.

Using Advanced Interpretation Mode

The Essbase server contains an advanced spreadsheet interpretation engine that
scans aworksheet and interprets its content when fulfilling retrieval requests.
When you construct a report by entering names directly into aworksheet in
Advanced Interpretation retrieval mode, Essbase interpretsthe member namesand
creates adefault view that is based on the location of the labels.

Keep in mind the following guidelines when you are working in Advanced
Interpretation mode:

e Precede al member names that consist of numbers with a single quotation
mark. For example, for Product dimension member 100, type '100 in the
worksheet.

e If youdefineareport that does not contain all of the database dimensions, you
may need to enter a dummy value, such as 0, in the first data cell. Esshase
overwrites this value with the contents of the database cell upon retrieval. Be
sure to use a numeric value as the dummy value.
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» To construct afree-form report in Advanced I nterpretation retrieval mode:

1. To open anew worksheet, select File > New or click the QI button.
Select Esshase > Options and select the M ode tab.

3. IntheRetrieval option group, select Advanced I nter pretation (the default
setting) and click OK.

4. Enter member names and data as in the following illustration.

Note: If amember name consists of a number, such as 100, you must precede the
member name with a single quotation mark (for example, '100). This rule also
applies to member names with spaces between words.

Figure 125: Creating a New Free-Form Report

A [ B [ ¢ [ b [ E [ F ]
Sales East Budget

Qtr1 Qtr2
100
200
300
400

5. Select Essbase > Retrieve or double-click in adatacell.

Esshase retrieves data for the members you entered into the free-form report
and implements the Use Aliases option that you set in the Essbase Options
dialog box in the beginning of this chapter.

Figure 126: Retrieving Data into a Free-Form Report

A [ B T ¢ T o [ E [ F |
L1 [Sales East  Budget
2]
3 | Gtrl G2
L4 [Colas 5870 6760
| 5 |Root Beer Sde0 AmA0
|6 [Cream Soda 3630 4030
|7 |Fruit Soda 3880 4180
8

Now define afree-form report that does not contain al of the dimensionsfrom the
database. In Advanced Interpretation mode, you may need to enter adummy data
value, such asO, into thefirst Essbase datacell to tell Essbase where the data starts
in the worksheet. Be sure to use a numeric value as the dummy value.
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For example:

1.
2.
3.

Essbase Spreadsheet Add-in for Excel

Select Esshase > FlashBack.
Delete cellsAl, B1, and C1.

Incell B4, type0in cell B4 to provide Essbase with adatacell reference point.

Figure 127: Defining a Free-Form Report Without All Dimensions

A B[ c [ Do [ E [ F ]

it
100 I D_l
200
300
400

Qtr2

Select Essbase > Retrieve.

Essbase adds the dimensions that were omitted from the free-form report to

the worksheet and retrieves data.

Figure 128: Retrieval in a Free-Form Report Without all Dimensions

A_ [ B [ € [ o [ E [ F |

Measures Market  Scenario

Qtr1
Colas
Root Beer
Cream Soda
Fruit Soda

7048
6721
5929
5005

Qtr2
7E72
7030
E7E9
5436

Select File > Close to close the worksheet. You do not need to save the

worksheet.
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Using Free-Form Mode

Similar to Advanced Interpretation mode, Free-Form mode enables you to

enter member names into any location in aworksheet and then interprets the
contents of the worksheet when fulfilling the retrieval request. In addition, with
Free-Form mode, you can use Essbase report script commandsto retrieve datainto
aworksheet.

Report script commands are most useful for defining member references that can
bring back the most current member information dynamically. For example, if you
need to create a report that shows every product, including the products added
since thelast retrieval, standard retrieval mode reflects changes only when you
zoom in on the product. If you use the report script command <I DESCENDANTS,
Essbase retrieves all descendants of a specified member, including the specified
member. For more information on the syntax of report script commands and on
guidelines for developing reports, see the Technical Referencein thedocs
directory and the Essbase Database Administrator’s Guide.

Keep in mind the following guidelines when working in Free-Form retrieval
mode;

e You must precede all member names that consist of numbers with asingle
guotation mark. For example, for the Product dimension member 100, you
need to type '100 in the worksheet.

e You cannot cancel aretrieve in Free-Form mode.
e You cannot apply Essbase styles in Free-Form mode.
e Essbase removes blank rows and columns on any retrieval action.

e Do not use Report Writer formatting commands, such as{ BRACKETS},
{DECIMAL}, and { EUROPEAN} in Free-Form mode, because they are
incompatible with Excel’s formatting features.

e Whenyou arein Free-Form mode, an Auto Sort Rows option isenabled in the
Display tab of the Essbase Options dialog box. If you select this feature,
Esshaseretrieves datain symmetric rows. Therowsare sorted according to the
order specified in the database outline.

e Notall FormulaPreservation and Modes options (Essbase Optionsdial og box,
Mode tab) are available in Free-Form mode.
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To use Dynamic Time Series in Free-Form mode, do not put the Dynamic
Time Series member and the latest time period (for example, Q-T-D (Feb)) in
the same cell. You need to type the Dynamic Time Series member, Q-T-D in
one cell, and the latest time period within parentheses, (Feb), in a separate,
adjacent cell.

» To construct a free-form report in Free-Form retrieval mode:

o 0k w DN

Essbase Spreadsheet Add-in for Excel

To open anew worksheet, select File > New or click the QI button.
Select Essbase > Options and select the M ode tab.

In the Retrieval option group, select Free Form.

Select the Display tab.

In the Cells option group, select Auto Sort Rows. Click OK.

Enter the member names into the worksheet as shown in Figure 129:

Figure 129: Typing Member Names In a Free-Form Report

A [ B T ¢ T o [ E [ F |
Product COGs
Jan
East
Budget
Actual

Select Essbase > Retrieve.

Essbhase retrieves data for the members and creates a default view according
to the location of the labels. Note that three members were pivoted from row
groups to column groups.

Figure 130: Result of Retrieving in Free-Form Retrieval Mode

A [ B[ c [ p [ E [ F |
Product COGS  Jan East
I 2590!

3007

Budget
Actual

Select File > Close to close the worksheet. You do not need to save the
worksheet.
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Now create a report by entering member names and a report script command:

To open anew worksheet, select File > New or click the QI button.

Enter the member names into the blank worksheet as shown in Figure 131.

Figure 131: Typing Member Names in a Free-Form Report

A [ B [CI[D[E[] F |
Actual |Sales East
Jan Feb IMar_l

In cell A3, type <I DESCENDANTS Product. Press Enter.

Figure 132: Typing a Report Script Command in a Free-Form Report

A [ B [ ¢ [ D
Actual Sales East
Jan Feb Mar
<IDESCENDANTS 1

oo o

Select Essbase > Retrieve.

Esshase retrieves data into the worksheet for all descendants of Product and

for the members you entered in the worksheet.

Figure 133: Result of a Retrieve with a Report Script Command

A [ B [ € | o [JEJ F ]

L1 Actual  Sales  East

L2 | Jan Feh tlar

L3 [Cola 1512 1754 1805
|4 [Diet Cola I 2DD_| 206 214
| 9 |Caffeine Free Cala 93 10 107
L6 | Colas 21048 2061 2126
|7 |Qld Fashioned 647 &lais) 672
| 8 |Diet Root Beer 310 310 312
L9 [Sasparilla #issing #lissing #issing
|10 |Birch Beer 896 985 923
11| Root Beer 1853 15966 1807
|12 |Dark Cream 959 12 1026

Note: When Essbase completes the retrieval, the report script command is

overwritten by the data it returns. You can use FlashBack to restore the previous

view in Free-Form mode.
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5. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Using Attributes in Free-Form Reporting

Esshase enables you to retrieve data selectively by specifying attributes that are
associated with a base dimension. For example, in the Sample Basic database, the
Product base dimension is associated with attributes such as packaging and size.
Y ou can enter an attribute name into the worksheet to retrieve data that is
associated with that attribute.

» To use attributes in afree-form report:
1. To open anew worksheet, select File > New or click the QI button.

2. Enter member names as shown in the Figure 134.

Caffeinated is an attribute dimension associated with the Product base
dimension. Bottleisalevel 0 member of the Pkg_Type attribute dimension.
The Pkg_Type dimension is associated with the Product base dimension. A
level 0 member isthe lowest level member in adimension.

Figure 134: Using Attributes in Free-Form Reports

A [ B [ ¢ [ b [ E |
| 1 |Caffeinated Bottle Prafit Qtrl East
2

3. Click in any empty cell and select Esshase > Retrieve or double-click in an
empty data cell.

Essbase retrieves information on profits for the first quarter of the year for all
members of the Product base dimension that are associated with both the level
0 attribute members of the Caffeinated attribute dimension (Caffeinated_True
and Caffeinated False) and the level 0 member Bottle of the Pkg_Type
attribute dimension. The results should appear as shown below:

Figure 135: Result of Using Attributes in Free-Form Reports

A | B [ ¢ D J[E]JF]
Caffeinated Bottle | Profit  Qtr1 East
Scenatio 2604
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4. Youcandrill downto dataon thelevel 0 attribute members of the Caffeinated
attribute dimension. The results should appear as shown below:

Figure 136: Drilling Down on Attributes in Free-Form Reports

A [ B [T c Db JETJF]
Bottle Profit  Qtr1 |East
Caffeinated_True Scenario 142
Caffeinated_False Scenario 2462

5. Todrill down further for dataon profitsfor thefirst quarter for all members of
the East base dimension, double-click on cell E1. Theresults should appear as
shown below:

Figure 137: Result of Drilling Down on East

A [ B e[ o [EJ F ]
1 Bottle |Prafit| Scenaria
Mew ork Caffeinated_True [Year -2050
Caffeinated_False |Year G754
Caffeinated ‘ear| 4704
Massachusetts Caffeinated_True | Year 30
Caffeinated_False |Year 1577
Caffeinated ‘ear| 1607
Florida Caffeinated_True |Year 1727
Caffeinated_False |Year 5934
Caffeinated ‘fear| 2661
Connecticut Caffeinated_True |Year 1134

EEEEEEEEE

[}

| 12 | Caffeinated_False Year 742
| 13 | Caffeinated  “ear 1878
| 14 |Mew Hampshire Caffeinated_True Year -84
| 15 | Caffeinated_False Year 842
| 16 | Caffeinated  “ear 743
| 17| East Caffeinated_True Year 757
| 18 | Caffeinated_False Year 10349
19 Caffeinated ‘ear 11606

Entering Generation and Level Names

In addition to entering database member names into a free-form report, you can
enter generation or level names directly into a worksheet to retrieve specific
members. The Essbase application designer defines generation and level namesfor
database dimensionsin the database outline. Y ou have two optionsfor discovering
what generation and level names are defined in the database:

e View generation and level namesin the Essbase Member Selection dial og box
or through Essbase Query Designer.

e Contact the Essbase application designer to see what generation and level
names are defined in the database outline.
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» To enter generation and level names directly into afree-form report:

1
2
3.
4

To open anew worksheet, select File > New or click the QI button.
Select Esshase > Options and select the M ode tab.
In the Retrieval option group, select Advanced I nterpretation. Click OK.

Enter member names as shown in Figure 138:

Figure 138: Entering Member Names in a Free-Form Report

A [ BJ] c[] o [ E [ F ]
Sales | Budget West Year

Enter a generation name as shown in Figure 139:

Family is a generation name in the Product dimension. The name is aready
defined in the Sample Basic database.

Figure 139: Entering a Generation Name in a Free-Form Report

A [ B [ ¢ [ b [ E [ F |
Sales | Budget West Year

Farnily

Select Essbase > Retrieve.

Esshase retrieves data for the member and generation namesthat you entered.
The Family generation name expands to its individual members.

Figure 140: Result of Free-Form Retrieval with Generation Name

Essbase Spreadsheet Add-in for Excel

A [ B [ ¢ | o [ E T F ]

L1 Sales Budget  West ‘fear

L2 [Colas 34830

| 3 |Root Beer 3810

L4 [Cream Soda 30430

|9 |Fruit Soda 24730

|6 |Diet Drinks 35690

7

W 175



An Advanced Essbase Tutorial

7. Change Year to alevel name (LevO0,Year) as shown in the following

illustration.

Figure 141: Entering a Level Name in a Free-Form Report

A

B | C [ D

F_|

Colas

Root Beer
Cream Soda
Fruit Soda
Diet Drinks

Sales Budget  West
34830
31810
30480
24730
35620

[ E |
[Lewd Year]

Note: Be sure notto insert a space between the comma after 0 and the word Year.
Generation and level names that are entered directly into a worksheet must be

Essbase retrieves data for the level 0 members of the Y ear dimension, which
are theindividual months (Jan, Feb, Mar, and so forth).

Figure 142: Result of Free-Form Retrieval with Level Name

A | B [ C [ E [ F ]
L1 Sales Wyest
L2 [Jan Calas 2860
L3 | Foat Beer 2540
L4 | Cream Soda 2220
L9 | Fruit Soda 1340
L6 | Diet Drinks 2810
¥ |Feb Calas 2520
L8 | Foat Beer 2560
L9 | Cream Soda 2310
|10 | Fruit Soda 1340
11| Diet Drinks 2500
|12 |Mar Calas 2520

9. Select File> Close to close the worksheet. You do not need to save the

worksheet.
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Using Linked Reporting Objects

A linked reporting object is an external file, cell note, or World Wide Web
resource that you link to acell in a Essbase database. Thefile, note, or Web
resource (indicated by aURL, or Uniform Resource Locator) can then beretrieved
by the Esshase Spreadsheet Add-in users who have access to the database.

Note: If your organization has licensed and implemented Essbase Partitioning option,
you can also access linked partitions from cells in Essbase Spreadsheet Add-in. For
more information on linked partitions, see “Accessing Linked Partitions” on page 194.

This section describes the following procedures:

e “Linking aFileto aData Cell” on page 177

e “Linking aCell Noteto aData Cell” on page 181

e “Linking aURL to aData Cell” on page 182

e “Accessing and Editing Linked Reporting Objects’” on page 185

Note: For additional information on using linked reporting objects, see the Essbase
Spreadsheet Add-in online help.

Linking a File to a Data Cell

With the linked reporting objects feature, you can link an external file to adata
cell in Esshase Spreadsheet Add-in. Essbase stores the file on the Esshase server.
Userswho have access to the database can then retrieve the file and view the data
contained in the cell.

Thefollowing example usesthe Asynm x| s sampleworksheet with datafrom the
Sample Basic database. It links a samplefile, Budasnp. t xt , to acell containing
the Budget figure. Budasnp. t xt details the budgetary assumptions for the
current year.

Follow these stepsto link afile to adata cell:
1. Select File > Open.
2. Fromthe\ essbase\ cl i ent\ sanpl e directory, open the Asymm xI s file.

3. Makesurethat you are connected to the Sample Basic database. If you are not
connected, see “ Connecting to a Database” on page 124.
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4. Select cell D5.

Note: You can link objects only to data cells, not to cells containing member
names.

Figure 143: Selecting a Data Cell for Linking an External File

A B [ c [ b J E [ F JG] H ]
L1 |Sales
L2 |
L3 | Acts! | Budgst! | Bvdge?! | Sudgs?
L4 ] Ol 02 Otr3 Otr4
[ 5 |East Colas geo2[_e7e0] 7300 557D
| 6 | Root Beer 5726 5650 BEDO| G780
| 7 | Fruit Soda 5735 4180 4380 3850
8
[ 9 |West RootBeer Be7s| 7970 83200 7820
110 | Cream Soda | 8043 7720 8300/ 7570
11

5. Select Essbase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.

Figure 144: Linking a File

Linked Objects Browser -- Aspen:5ample:Basic
ember Combination: IQtr2,8aIes,EoIas,East,Budget
Linked Objects:
Object Type |Dbiect Drescription File Mame Created By Last Modified
Attach... | Edit.. | Eiew.-"Launc:hl [elete | Help | Lloze |

6. IntheLinked Objects Browser dialog box, click the Attach button.
Essbase displays the Attach Linked Object dialog box.
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7. Under the Attachment Type option group, select File.
Figure 145: Linking a File to a Data Cell

ember Combination: IQ tr2,5 ales Colas E ast Budget

Attachment Type
 Cell note

(:'flle Cancel |
" URL Help |
File M ame:

I Browse. .. |

File Description:

= ¥

8. Click the Browse button (next to the File Name text box).
Essbase displays the Browse Files dialog box.

9. Gotothe\ Essbase\ cli ent\sanpl e directory and select the
Budasnp. t xt file.

10. Click Open.

11. Under File Description, enter a brief description for the file asindicated in
Figure 146.

Figure 146: Selecting and Describing a File to Link

ember Combination: IQ tr2,5 ales Colas E ast Budget

Aftachment Type
' Cell note
Cancel |
Help |
File M ame:
IE:\ESSBASE\ELIENT\SAMPLE\Budasmp.txt Browse. .. |

File Description:

Budgetary azsumption report

= ¥

Note: Entering text in the File Description text box is optional.
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12. Click OK to close the dialog box and link thefile to the cell.

Esshase copies the file to the server and establishes alink to the current data
cell.

13. Click Closeto close the Linked Objects Browser dialog box.

14. Do not close the Asymm x| s file. You useit in the next tutorial task.

To recognize cells that have linked reporting objects attached to them, you may
want to apply avisual cue, or style, to the cells.

To apply styles:

© N o 0 w DN

Select Esshase > Options and select the Style tab.

Inthe Data Cells area, select Linked Objects.

Click Format.

In the Font stylelist box, select Italic.

Inthe Color list box, select Purple. Click OK.

Select the Display tab.

In the Cells option group, select the Use Styles box. Click OK.

Select Esshase > Retrieve to refresh the worksheet and apply the styles.

Cell D5 (the cell you just attached the linked file to) is now displayed in
purple, italic font. Essbase al so refreshes the worksheet with the other options
set in the Essbase Options dialog box.

Figure 147: Result of Applying a Style to a Linked Reporting Object Cell
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Leavethe Asynm x| s file open for the next tutorial task.
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Linking a Cell Note to a Data Cell

In addition to linking external filesto adata cell in Essbase Spreadsheet Add-in,
you can aso link individual cell notes that contain information on particular data
cells. Cell notes can have no more than 599 characters. If you need to link
information to a data cell that islonger than 599 characters, you need to create
and save an external file and then link the file to the data cell.

» Tolink acell note to adatacell:

1. IntheAsymm xI s file, select cell C5.

Note: You can link objects only to data cells, not to cells containing member
names.

2. Select Esshase > Linked Objects.
Esshase displays the Linked Objects Browser dialog box.
3. IntheLinked Objects Browser dialog box, click Attach.
Esshase displays the Attach Linked Object dialog box.
4. Under the Attachment Type option group, select Cell Note.
In the Cell Note box, type the note as indicated in the following illustration:

Figure 148: Creating a Cell Note to Link

Member Combination: IQ tr1,5ales Colas E ast Actual

— Alta
e

" File

" URL Help

LCell Mote:

Thiz number needs to be updated by the E astern Sales Manager. ;I

Tupe ok,

Cancel

Fli

|

6. To closethe dialog box and link the cell note, click OK.

Essbase copies the note to the server and establishes alink to the current data
cell.
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7. Toclosethe Linked Objects Browser dialog box, click Close.
8. Select Esshase > Retrieve to refresh the worksheet and apply the style you

defined for linked objects.

Now Esshase displays two data cells (C5 and D5) in purple, italic font to

represent a cell that contains a linked reporting object.

Figure 149: Result of Creating a Linked Cell Note
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9. Leavethe Asymm xI s file open for the next tutorial task.

Linking a URL to a Data Cell

A URL isan address string that identifies resources on the World Wide Web, such
as documents, images, and downloadable files. With the linked reporting objects
feature, you can link a URL to adata cell so that users who have access to the
database can link directly to the specified URL. When you access the cell from
Essbase Spreadsheet Add-in, your default Web browser opens and displays the

specified URL.

Note: For more information on URL syntax, see the Essbase Spreadsheet Add-in

online help.

182 |
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If you have aWeb browser and Internet access, follow these stepsto link adatacell
to the Hyperion Web site:

1. IntheAsymm xlI s file, select cell E5.

Note: You can link objects only to data cells, not to cells containing member
names.

Figure 150: Selecting a Data Cell for Linking to a URL

| A B ¢ [ o [ e | ¢ | & |
1
2
3 At Budget Budget Budget
4 Qtrl Qtr2 Qtr3 Qtrd
5 |East [Colas [EEE BT 7300 [0
6 Root Beer 5726 5ERD 5600 5780
7 Fruit Soda 3735 4150 4350 3850
8
9 est  |RootBeer | 827a 7970 8320 7820
10 Cream Soda 8043 7e0 8300 7570
11

2. Select Esshase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.
3. IntheLinked Objects Browser dialog box, click Attach.
Essbase displays the Attach Linked Object dialog box.
4. Under the Attachment Type option group, select URL.

Figure 151: Linking a URL to a Data Cell

Attach Linked Object E
ember Combination: IQtr3,8aIes,EoIas,East,Budget
Attachment Type
' Cell note
F Cancel |
i Help |
Location:
URL Description:
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5. Enter aURL in the L ocation text box and a brief description in the URL
Description text box, asindicated in Figure 152.

Figure 152: Entering and Describing a URL to Link

Attach Linked Object E
ember Combination: IQtr3,8aIes,EoIas,East,Budget
Attachment Type
' Cell note
= File Cancel |
Help |

Location:

Ihttp:.-".-"www.hyperion.com

URL Description:
Hyperion Solutions' home page ;I

|

Note: Entering text in the URL Description text box is optional. The text field for
entering the URL location is limited to 512 characters. The text field for entering the
URL description is limited to 80 characters.

6. To closethe dialog box and link the URL to the cell, click OK.

Essbase copies the URL string to the server and establishes alink to the
current data cell.

Note: The syntax for the URL is not checked at creation time; Essbase checks the
syntax when the user accesses the URL from the worksheet. The default Web
browser checks for the existence (or validity) of the URL.

7. Toclosethe Linked Objects Browser dialog box, click Close.

8. Select Esshase > Retrieveto refresh the worksheet and apply the stylethat you
defined for linked objects.

9. Leavethe Asymm x| s file open for the next tutorial task.

Now that you havelearned to create linked reporting objects, you areready to learn
how to access them from Essbase Spreadsheet Add-in.
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Accessing and Editing Linked Reporting Objects

Y ou have two options for accessing and editing a linked reporting object that is
attached to adata cell:

e Select thecell (asidentified by the style applied to it) and select
Esshase > Linked Objects.

e Enable double-clicking for linked object browsing.

Note: If you enable double-clicking for linked object browsing, double-clicking behavior
changes for retrieving data and performing drill actions. For more information on these
changes, see the Essbase Spreadsheet Add-in online help.

For thistutorial, you access the linked reporting objects that you created in the
previous sections by using the Essbase menu item instead of the double-clicking
action.

Accessing a Linked File

Sometimes you want to check an external file that is linked to a data cell.

» To access the external file that you previously linked to a data cell:
1. IntheAsynmm xI s file, select cell D5.
2. Select Esshase > Linked Objects.
3. IntheLinked Objects Browser dialog box, select the Budasnp. t xt file.

Figure 153: Accessing a Linked External File

Linked Objects Browser -- Aspen:5ample:Basic

ember Combination: IQ tr2,5 ales Colas E ast Budget

Linked Objects:
Object Type Object Description File Mame Created By Last Modified

Budgetary assumption report  Budasmp.tst  Sups Mon Oct 27 14

« 2

Attach... Edit.. Wiew/Launch Delete Help | Lloze |
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4. Toview thelinked file, click View/Launch.

The Budasnp. t xt fileisopened from the source application.

Figure 154: Viewing the Contents of a Linked External File

B Budasmp.tzt - Notepad =1 E3
File Edit Search Help
The Beverage Company ;I

1998 Budget Assumptions
The following factors were used to estimate our 1998 Corporate Budget:

1) Sales increases will be 5% in Large Markets, due to market maturity
2) Sales increases will be 18% in Small Markets, due to our focused advertising
3) Expenses will be reduced by 7% across the entire company

We are faced with the challenge of continuing to grow our business, in spite
of increasing competition. We will have to seek out and implement as many cost
saving measures as possible. =

K| 2

Note: Edit the contents of a file in the source application. After the edits are made
and the file saved, you can re-attach the edited file by clicking the Edit button in the
Linked Objects Browser dialog box. Essbase displays the Re-attach Linked Object
dialog box, which you can use to re-attach, or relink, the edited file to the data cell.
For more information, see the Essbase Spreadsheet Add-in online help.

Close the Budasnp. t xt file and click Closeto close the Linked Objects
Browser dialog box.

6. Leavethe Asymm x| s file open for the next task.
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Accessing a Linked Cell Note
Sometimes you have to edit a cell note that was previously created.

» To access and edit the cell note that you previously created:
1. IntheAsymm xI s file, select cell C5.
2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displaysthe cell note that islinked
to the selected data cell.

3. IntheLinked Objects Browser dialog box, select the cell note.

Figure 155: Accessing a Linked Cell Note

Linked Objects Browser -- Poplar:5ample:Basic

Member Combination: IQ tr1,5ales Colas E ast Actual

Linked Objects:

Object Type Object Description Linked Object and Object Created By (L.

Cell Maote This number needs to be

« 2

Attach... Edit.. Wiew/Launch Delete Help | Lloze |
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4. To edit the contents of the cell note, click Edit.

Esshase displays the Edit Cell Note dialog box with the selected cell note
displayed.

Figure 156: Editing the Contents of a Linked Cell Note

Edit Cell Note

Member Combination: |utr1 Sales,100,E ast Actual

LCell Mote:

Note: If you simply want to view the contents of the cell note, click the
View/Launch button instead of the Edit button in the Linked Objects Browser dialog
box.

Edit the contents of the cell note asindicated in the following illustration:

Figure 157: Result of Editing Cell Note Contents

Edit Cell Hote E

Member Combination: |utr1 Sales,100,E ast Actual

LCell Mote:

Thiz number was updated on 8/26/97. ;I QK I
Cancel |
Help |

|

Click OK to closethe Edit Cell Note dialog box and save the edits you made
to the note.

Esshase saves the edits to the cell note on the server.
To close the Linked Objects Browser dialog box, click Close.

Leavethe Asymm x| s file open for the next tutorial task.

Essbase Spreadsheet Add-in for Excel



An Advanced Essbase Tutorial

Accessing a Linked URL

If you followed the stepsin “Linking a URL to aData Cell” on page 182, you can
access and edit the URL that you created.

» To accessthe URL:
1. IntheAsymm xlI s file, select cell E5.
2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displaysthe URL that is linked to
the selected data cell.

3. IntheLinked Objects Browser dialog box, select the URL.

Figure 158: Accessing a Linked URL

Linked Objects Browser -- Poplar:5ample:Basic

ember Combination: IQtr3,8aIes,EoIas,East,Budget
Linked Objects:
Object Type Object Description Linked Object and Object Created By (L.

Hyperion Solutions' home hittp: ¢ =fion. Com

« 2

Attach... Edit.. Wiew/Launch Delete Help | Lloze |
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4. Toview thelinked URL, click View/Launch.

Esshase checks the syntax of the URL. If there are syntax errors, Esshase
displays an error message. If the URL syntax is correct, the default Web
browser launches and connectsto the specified site. Inthis case, the syntax for
the URL is correct, so the default Web browser launches and connects to the
Hyperion Web site.

Figure 159: Viewing a Linked URL

|J Address I@ hittp: £ A hyperion, com,

190

-

O @
000
O o

Hyperion®

) Fartnars
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About Us

Welcome to Hyperion
e e yp A

Announce ...
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going on with new customer acquisition?"..."What's going on with our sales
cycle?"."What's going on with our Web site sales and service?".. . Tough

Worldwide Hyperion ! ]
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Thousands of custormers and millions of users - everyday and around the world -
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guestions like these and others.
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your rost important business goals. Application
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Fublizh Open XML for

5. Close the Web browser.
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» To edit the URL:
1. IntheLinked Objects Browser dialog box, select the URL.
2. Toedit thelinked URL, click Edit.
Essbase displays the Edit URL dialog box with the selected URL displayed.

Figure 160: Preparing to Edit the Contents of a Linked URL

Member Combination: IIJ tr3.5ales.Colas. E ast. Budget

Location:

I hittp: £ A, hpperion, com

URL Description:

Hyperion Solutions' home page -
Cancel
v

3. Edit the URL location and description as show in the following illustration:

Figure 161: Editing the Contents of a Linked URL

Edit URL [X]

Member Combination: |utr3,sales,Colas,East,Budget

Location:

Ihttp: £ v hpperion. com/solutions. ofm

URL Description:
Hyperion Solutions' home page -
z

4. ToclosetheEdit URL dialog box and savethe editsthat you made, click OK.

Essbhase saves the edits to the URL on the server.
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5. Toview the new URL, click View/Launch.

The Web browser launches and connects to the new URL.

Figure 162: Viewing an Edited URL
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6. Closethe Web browser.
7. Toclosethe Linked Objects Browser dialog box, click Close.

8. Closethe Asynm xI s file without saving it.
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Connecting to Multiple Databases

Essbase supports simultaneous access to multiple databases. The databases can be
in different applications and can be stored on different servers. In Excel, you can
open multiple worksheets, each of which can be connected to adifferent database.
Anindividual worksheet can access only one database at atime. Use the Connect
command from the Essbase menu to switch the connection between databases.

Note: Depending on the status of production applications at your site, you may not
have access to additional applications or databases. Check with the Essbase system
administrator if you need access to other applications.

For this tutorial, you do not need to connect to another database.

To access multiple databases, use the following procedure:
1.
2.

Select Essbase > Connect.

In the Essbase System L ogin dialog box, select the server you want to access
from the Server list box (or typein the name of the server).

Press Tab to move to the User name text box and type your username.

Press Tab to move to the Passwor d text box and type your password.

Click OK to connect to the server.

When the server connection is complete, alist of available application and
database pairsis displayed in the Application/Database list.

Double-click the Application/Database pair that you want to connect to
in the Application/Database list. Alternatively, you can select the
Application/Database pair and click OK.

If the application is not already running, Essbase automatically startsit.
There may be a brief pause as the application loads; the time required to start
an application depends on number of databases, the sizes of the databases,
and the sizes of the indexes of the databases contained within the application.

Open anew worksheet and repeat the stepsto connect to additional databases.
Y ou can open one database at a time per worksheet.

For information on connecting to multiple databases from Essbase Query
Designer, refer to Chapter 2.
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Viewing Active Database Connections

If you frequently connect to multiple databases, you may need to check the active
database for each worksheet. There are two ways to view the database connection
status:

e The Styletab of the Essbase Options dialog box contains a Connection
Information text box. Thisbox displays connection information for the active
worksheet.

e The Essbase Disconnect dialog box lists al active worksheets and their
connection information. This dialog box also enables you to disconnect one or
more worksheets from their respective databases.

Accessing Linked Partitions

194 W

Linked partitions are part of the Essbase Partitioning product. They provide the
ability to link Essbase databases that contain different dimensions without losing
accessto all dimensions of both databases. If your organi zation has purchased and
implemented the partitioning product, you can take advantage of its powerful
capabilities. The Essbhase Database Administrator’s Guide describes how to
design and implement alinked partition. The Essbase application designer usually
sets up partitioning.

Note: The Partitioning product also enables the Essbase application designer to set up
transparent or remote partitions. For more information on partitioning, see the Essbase
Database Administrator’s Guide.

Y ou can set visua cues, or styles, for cells tagged as linked objects. These cells
are access points to the linked partition within the linked database. Y ou have two
options for accessing a linked partition from a data cell in Essbase Spreadsheet
Add-in:

e Select the cell and select Essbase > Linked Objects.
e Enable double-clicking for linked object browsing.

If you enable double-clicking for linked object browsing, double-clicking
behavior changes for retrieving data and performing drill actions. For more
information on these changes, see the Essbase Spreadsheet Add-in online
help.
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When you select Essbase > Linked Objects from alinked partition cell, Hyperion
Esshase completes the following actions:

e Essbasedisplaysthe Linked Objects Browser dialog box, which containsalist
of possible partitions to access. From this dial og box, select the partition to
connect to.

Note: The Linked Objects Browser dialog box may also contain a list of linked
reporting objects, such as cell notes and external files. For more information, see
“Using Linked Reporting Objects” on page 177.

e After you select a partition, Essbase creates a new worksheet that contains
corresponding members and dimensions for the cell in the linked partition.

Note: Essbase does not preserve formulas across partitions.

e Essbase retrieves data values from the linked partition.

Essbase Spreadsheet Add-in for Excel M 195



An Advanced Essbase Tutorial

196 W

Y ou can now perform operations such as drill down and drill up to get more
information on the new worksheet.

Note: The Sample Basic database that you are using for this tutorial does not contain
a linked partition.

If the Essbase application designer has alinked partition set up, use the following
procedure to access the linked partition in Essbase Spreadsheet Add-in:

1. Locate alinked object cell, asindicated by the style applied to the cell.

2. Select Esshase > Linked Objectsto open the Linked Objects Browser dialog
box.

Note: Alternatively, select the Enable Linked Object Browsing check box in
the Essbase Options dialog box to enable double-clicking to view linked
objects.

3. Select the partition that you want to connect to and click View/L aunch.

Figure 163: Linked Objects Browser Dialog Box, Linked Partition

Linked Objects Browser -- Aspen:5ample:Basic

ember Combination: IQ tr2,5 ales Colas E ast Budget
Linked Objects:

Object Type Object Description File Mame Created By Last Modified
Linked Partition

« 2

Attach... | Edit.. |£iew.-"Launc:h| [elete | Help | Lloze |

Esshase creates a new worksheet that contains the dimensions and members for
the cell in the linked partition.

Note: You need to have the proper privileges to access a linked patrtition. If your user
account and password match the account information for the linked partition, Essbase
establishes a connection with the linked partition. Otherwise, Essbase displays the
Essbase System Login dialog box for you to enter the user account and password
information manually.
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Updating Data on the Server

Data values are changed frequently in applications that involve planning,
budgeting, and forecasting. After you retrieve datainto the worksheet, you can use
Essbase Spreadsheet Add-in to change values, enter formulas, and format data.
Esshase is also designed to permit multiuser, concurrent database access and
update. Depending on your security privileges, you may be able to modify all data
values or a certain subset of values. To recognize cells to which you have
read/write access, apply avisual cue, or style, to the cells. For more information,
see“Applying Stylesto Data Cells’ on page 82. To update datafrom aworkshest,
you must lock the database area that contains the values that you want to change.
Locking prohibits other users from changing the data that you want to update.
Other users can retrieve locked data but cannot lock or change the data. Y ou have
exclusive update rights to that area.

Note: You cannot update attribute-related data on the server because attribute data is
always calculated dynamically and, hence, is not saved.

Y ou can lock data values in three ways:

e TheRetrieve & Lock command retrieves data into the worksheet while
locking the corresponding data area on the server. When you perform a
subsequent retrieval, Essbase automatically unlocks the previous data values.

Note: The Retrieve & Lock command is not supported with Dynamic Time Series
members.

e TheLock command locksinformation that you have already retrieved. When
you perform a subsequent retrieval, Essbase automatically unlocks the
previous data values.

e The Update M ode check box in the Mode tab of the Essbase Options dialog
box automatically locks the corresponding database area for each retrieval.

To update the server with data values from the worksheet, use the Send command
on the Essbase menu. After updating the server, the Send command automatically
unlocks data (unless you are in Update Mode). Y ou must disable Update Mode to
stop locking blocks automatically.
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Y ou can unlock data blocks in two ways:
e The Unlock command unlocks all blocks that you have locked.

e The server automatically unlocks data blocks that have been locked for the
maximum time allowed as defined by the Essbase system administrator.
Automatic unlock ensures that blocks are not locked for extended periods of
time.

P&l . x| s, asample Excel fileinstalled as part of the default Essbase installation,
illustrates how to update data on the server.
» Toview the P& . x| s worksheet:
1. Select File > Open.
2. Fromthe\ Essbase\ cl i ent\ sanpl e directory, openthe P&l . xI s file.
3. Select Esshase > Retrieve & Lock.
Esshase retrieves data and locks the appropriate area of the database.

Figure 164: P&L Worksheet After Retrieve & Lock

A [ B [ € | o [ E [ F ] G [ H
L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget
4
]
6 |Misc Eissing  BMissing #Missing
7 |Payroll 210 210 210 530 0.07
8 |Marketing 300 310 320 930 11.05
9 Total Expenses 510 520 530 1560 18.53
10
11 |COGS 1170 1180 1200 3550 42.16
12 |Sales 2740 2520 2860 8420 100.00
13 Margin 1570 1640 1660 4570 57.84
14 Prafit 1060 1120 1130 3310 383
15
16 [Ratio Analysis
17 | Markup 57.3% 558.2% 58.0% 57.8%
18 |Marketing % 10.9% 11.0% 11.2% 11.0%

4. Changethevaue for Salesin Jan (cell B12) to 4000 and press Enter.
Essbase changes the affected data values.
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5. Select Esshase > Send to update the server with the new values.

Essbase updates the server and unlocks the data blocks.

Figure 165: P&L Worksheet After Sending New Values to the Server

A [ B [ € | o [ E [ F ] G [ H
L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget
4
I—
6 |Misc 5 10 10 25 0.30
7 |Payroll 200 200 200 500 0.07
8 |Marketing 350 350 350 1050 12.47
9 Total Expenses 555 560 560 1675 19.89
10
11 |COGS 1170 1180 1200 3550 42.16
12 |Sales 2740 2520 2860 8420 100.00
13 Margin 1570 1640 1660 4570 57.84
14 Prafit 1015 1080 1100 3195 37.95
15
16 [Ratio Analysis
17 | Markup 57.3% 558.2% 58.0% 57.8%
18 |Marketing % 12.8% 12.4% 12.2% 12.8%

6. ClosePé&l . xI s without saving it.

Note: Essbase provides a worksheet update logging facility that tracks and logs all
data updates sent from Essbase Spreadsheet Add-in to the server. The Essbhase
system administrator enables this facility for extra protection against data loss. For
more information, see the Essbase Database Administrator's Guide or contact the
Essbase system administrator.

Calculating a Database

Sending updated datato the server does not automatically recal culate the database.
If you have the appropriate security privileges to perform database calculations,
you can calculate the database from Essbase Spreadsheet Add-in with the
Calculation command. For thistutorial, you will not actually calculate the Sample
Basic database. For more information on Essbase calculations, see the Essbase
Database Administrator’s Guide.

CAUTION: Do not perform any calculation operations for this tutorial.
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When you select Esshase > Cal culation, Essbase displays the Essbase Calculation
dialog box.

Figure 166: Essbase Calculation Dialog Box
Essbhase Calculation E
Connection Information
(Aspen:SampleoBasic
-
CalcRel
Calcthat ﬂl

Calcine
Calclanc

CalcDes
CalclDes il
Stop Calc |

Select Calc Script:

— Database State

Mo data values have been changed
since the last calculation.

The Essbase Calculation dialog box contains the following items:
e The Connection Information text box displays the active database connection.

e TheSelect Calc Script list box containsthe server-based cal culation scriptsto
which you have access.

e The Database State text box indicates the current calculation state of the
database. The following states are possible:

— Cdlculating—indicates that a calculation is currently running on the
database.

— Datavalues have been modified since the last cal culation—indicates that
data values have changed since the database was |ast calculated. The last
calculation may have been an entire calculation of the database or a
calculation of any subset of the database.
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— No data values have been changed since the last calculation—indicates
that the data in the database has not changed since it was last calculated.
The last calculation may have been an entire calculation of the database
or acalculation of any subset of the database.

CAUTION: If the last calculation was performed on a subset of the data,
the entire database may not have been calculated since values last
changed. To ensure that the results of calculations are up-to-date, you
may want to run a calculation of the entire database. For more
information, contact the Essbase system administrator.

Creating Multiple Worksheets from Data

One frequent requirement of budgeting and planning applicationsis to send
worksheets to various functional areas of an organization. After the worksheets
have been distributed, the recipients can review the contents, make modifications,
and send updates back to the distributor. Using the Essbase Cascade feature, you
can create multiple worksheet files based on asingle database view. You can
specify at what level of detail you want to replicate the worksheets to tailor the
information to each recipient’s needs.

The Sample Basic database contains data for beverage products sold in different
states across the U.S. For example, assume that you want all product managers to
review and respond to a proposed budget and to return their changesto the finance
department. We must create aworksheet for each combination of budget and P& L
datato distribute to the product managers for their respective products.

» To create this set of worksheets:

1. Select File > Open.

2. Fromthe\ Essbase\ cl i ent\ sanpl e directory, opentheP&l . x| s file. This
file contains the data that you need to replicate for each worksheet.

3. Select Essbase > Retrieve.

Notice that the retrieval uses the Use Aliases option, which is already set for
thisfilein the Essbase Options dialog box. In this example, product 200
changes to Root Beer, which isits preassigned alias.
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Select Central (in cell B1) and Root Beer (in cell B2) as the membersto be
represented in the resulting worksheets.

Select Essbase > Cascade.
Essbase displays the Essbase Cascade Options dialog box.
Click the Cascade | nfor mation tab.

The Cascadel nfor mation page containsthelist of membersthat you sel ected
and the options for specifying the level at which the selected members are
retrieved into the cascaded worksheets.

Note: For more information on each option, see the Essbase Spreadsheet Add-in
online help.

Select Central in the M ember list box, and select Same level in the Choose
Level for Selected Member option group.

Select Root Beer in the Member list box, and select Next level (the default
setting).

Figure 167: Cascade Information Tab

Essbase Cascade Options E

Cascade Information | Destination Dptionsl Format Dptionsl

- Cascade Or:

tember: Choose Level far
Selected Member:

& Mewt Level
Al Levels

© Battom Level
' Sibling Level
7 Same Level

7 Same Generation

Central Same level
iHoot Beer

et [yl

 Formulas

QK I Cancel | Help |

The replicated, or cascaded, spreadsheet reports now provide data for
membersat the samelevel asCentral (East, West, and South) and for members
at thelevel below Root Beer (Old Fashioned, Diet Root Beer, Sarsaparilla, and
Birch Beer).
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9. Click the Destination Options tab.

10. Inthe Destination Directory text box, enter C: \ t enp as the name of the
directory where you want the cascaded worksheets to be stored.

Y ou can also click Browse to select adestination directory from the Browse
dialog box.

11. Inthe Destination Types option group, select Separate Wor kbooks (the
default setting) to create separate Excel files for each cascaded worksheet.

Y ou can aso tell Esshase to create only one workbook with separate
worksheets for each cascaded report, or you can send the cascaded reports to
the printer.

12. Inthe File Information option group, click Overwrite Existing Files (the
default setting). This option tells Essbase to overwrite any cascaded
worksheets with the same file name.

Y ou can also select Open Created Filesto open each cascaded filein Excel as
itis created.

CAUTION: Depending on the number of replicated worksheets that you
want to create, the Cascade command can create more worksheets than
can be stored in the memory of your computer. Therefore, the Open
Created Files option should not be used when you are replicating large
numbers of worksheets.
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13. In the Naming Information option group, enter BUD in the Prefix text box.
Figure 168: Destination Options Tab

Essbase Cascade Options E

Cazcade Information Destination Options | Format Dptionsl

r— Destination Directory: ———— 1~ Destination Types

hbemp & Separate Workbooks
" OneWorkbook, Separate Sheets

Elo=l | " Printer Printer... |

—File Infarmation————————  —~ Maming Infarmation
[~ Open Created Files Prefis: ELD
¥ Ovenwrite Existing Files S

Wwiorkbook: I

QK I Cancel | Help |

When you assign a prefix or suffix in the Naming Information option group,
the worksheet files that are generated as a result of executing the Cascade
command are named with the prefix or suffix that you specify. The default
is to generate worksheet names that are numbered 1 through n, where n
isthe total number of worksheets created. The syntax for the file namesis
PrefixnSuffix.xls. If you do not specify a prefix or suffix, Essbase creates the
worksheets 1. x| s, 2. xI s, and so on. If you are creating a single workbook,
the same naming convention is used for the worksheet tab names within the
workbook.

CAUTION: Do not specify a prefix and suffix combination that leaves no
characters free for Essbase to create unique file names. If file names are
duplicated, Essbase overwrites the duplicate file name with the last
cascaded worksheet.
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14. Click the Format Optionstab.

15. To copy theformatting of the source worksheet into each cascaded worksheet,
select the Copy Formatting check box.

Note: Copy formatting copies only the visual cues set using Essbase and the cell
formatting that you set using the worksheet. It does not copy formulas, column
formatting, worksheet formatting, or graphs.

Inthe Header and Footer text boxes, specify aheader or footer nameto be used
for all of the cascaded worksheets.

16. Inthe Sheet Formatting group, select the Suppress Missing Rows check box
so that rows containing only #Missing values are not replicated.

17. Inthe Table of Contents group, select the I nclude Table of Contents check
box to create atext filethat lists all replicated worksheets, their creation dates,
and their member content.

By default, Essbase namesthe Table of Contentsfilewith theextension. | st .

Figure 169: Format Options Tab

Essbase Cascade Options E
Cascade Informationl Destination Options ~ Format Options |

— Sheet to Sheet Replication
V' Copy Formatting

Header: I

Footer: |

— Sheet Formatting
¥ Suppress Missing Rows

— Table of C

QK I Cancel Help
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18. Click OK to create the cascaded worksheets.

Esshase rapidly createsthe cascaded worksheets (nine total worksheetsin this
example). As each worksheet is created, it isautomatically saved, closed, and
logged in the Table of Contents. Each individual fileis saved in the directory
that you specified, named Bud1. x| s through Bud9. x| s. When the Cascade
is completed, Essbase returns you to the original worksheet view (that is, the
sourcefile).

19. Using atext editing application, open the Table of Contents file from the
destination directory that you specified earlier. Thisfileis named BUDO. LST
and contains alist of all cascaded worksheets.

Figure 170: Table of Contents File for Cascaded Worksheets

/***********************************************************/

/* File name: c:\temp\BUDD.1lst */

/* Creation date: Mon MNov 10 11:48:34 1997 */
/***********************************************************/

c:htemphBUDL.x1s /* Bast, ¢ld Fashioned #*/
c:h\temph\BUDZ .x1s /* Bast, Diet Root Beer */
c:htemphBUD3.xls /* East, Sasparilla */
c:htemphBUD4 . x1s /* FEast, Birch Beer */
c:htemphBUDS . x1s /% Test, ©ld Fashioned #*/
c:htemp\BUDG.x1s /* TWest, Diet Root Beer */
c:ihtemphBUDT.x1ls /* West, Sasparilla */
c:h\temp\BUDG .x1s /* South, ©ld Fashioned */
c:htemphBUDY .x1s /* South, Diet Root Beer */
c:h\temp\BUDLO.x1s /% gouth, Zasparilla */

20. Select File > Close to close the worksheet.
Y ou do not need to save the worksheet.

Note: You can create multiple worksheet files based on the attributes of a product.
Type in the attribute names in the top row of the worksheet. Select the attribute names
and select Essbase > Cascade. Proceed as described in the above example.
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Working with Currency Conversions

Organizations with officesin different countries generally do businessin the
currency of the host country (known as the local currency). Such organizations
must convert data entered in local currenciesto acommon currency for
consolidation and analysis.

The Essbase Currency Conversion product can be purchased separately for
Essbase. If your organization has purchased this product and has implemented a
currency conversion application, you can take advantage of the powerful
capabilities of Hyperion Essbase Currency Conversion. The Essbase Database
Administrator’ s Guide describes how to design and implement a currency
conversion application.

The following sections provide a brief tutorial for working with currency
conversions:

e “Retrieving Currency Conversion Data’ on page 207
e “Connecting to the Sample Currency Databases’ on page 208
e “Performing Ad Hoc Currency Reporting” on page 211

Retrieving Currency Conversion Data

This section focuses on basic currency conversion concepts, including the
easy-to-use Currency Report command.

A currency conversion application consists of two databases:
e A main database that contains datain local and converted values

e A currency rates database that contains exchange rates

Apply exchange rates from the currency rates database to local values from

the main database to derive converted values. The Essbase server product
installation includes a sample currency conversion application (installation
options) that consists of two sample databases: a main database called Interntl and
acurrency rates database called X chgrate.

The Sample Interntl database consists of five dimensions: Y ear, Measures,
Product, Market, and Scenario. All but the Market and Scenario dimensions are
identical to the Sample Basic database. The Market dimension includes Toronto,
Vancouver, Montreal, France, Germany, Spain, and the UK. The Scenario
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dimension handles different currency types (such as Actual and Budget) in both
local and converted currencies. In this database, all local currencies are converted
to the common currency of U.S. dollars.

The Sample X chgrate database, which is a subset of the main database, contains
four dimensions:

e The CurTime dimension accommodates different exchange rates by month.

e The CurName dimension contains names of currencies from their respective
markets.

e The CurCategory dimension contains the names of the various currency
categoriesthat may be applied to the categories of Measures. For example, one
rateis applied to Profit and Loss items and another rateis applied to Balance
Sheet items.

e The CurType dimension enables a currency database to contain rates for
different scenarios, such as Actua and Budget.

Connecting to the Sample Currency Databases

To complete the following exercises, the Sample Interntl and Sample Xchgrate
databases must be installed on the server. Contact the Essbase system
administrator if these application and database pairs are unavailable.

» To retrieve data from the Sample Interntl database:
1. Select Essbase > Connect.
2. Select the Sample Interntl database and click OK to complete the connection.

The Essbase installation al so includes sample Excel files that illustrate
currency conversion concepts.
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The worksheet contains actual (Act) and budget (Bud) data entered in local
currencies for New York and Germany.

Figure 171: Retrieving Local Data

Total Expenses  #Missing #Missing #Missing  #Missing

Margin %% #Missing  #Missing #Missing  #Missing
Profit %2 #Missing  #Missing #Missing  #Missing

A [ B [ c© ] D [  E [ F ]
L1 Jan 100-10
2
3 | Az Fend
4 | New York Germany New York | Germany
L5 |Sales 678 210 640 190
LB |COGS 27 84 260 80
L? | Margin #Missing  #Missing #Missing  #Missing
8
|9 |Marketing 94 27 80 20
|10 |Fayrall 51 Kl 40 20
11 |Misc i 0 #dissing  #Missing
2]
3]
4]
15 ]
(16 |
7]

—
[=-}

4. Fromthe\ Essbase\ cli ent\ sanpl e directory, open Convert . x| s.
Select Essbase > Retrieve.

The worksheet contains values for Actual and Budget as they appear after
conversion.

Figure 172: Retrieving Converted Data Values

A [ B [ € ] D [ E [T F [T & |
1 llJan 100-10
2
3 Actusl Actuat & Bed XChe P
4 Mew York Germany Mew York | Germany  New York | Germany
5 |Sales 678 130 678 210 640 133
B |COGS 271 52 271 84 260 56
7 Margin 407 78 407 126 380 77
8
9 |Marketing 94 17 94 27 a0 14
10 |Payrall 51 19 51 31 40 14
11 |Misc 0 0 0 0 #Missing #Missing
12 | Total Expenses 145 36 145 58 120 28
13
14 Margin %% 60.03 60.00 60.03 60.00 59.38 57.89
15 Profit %2 38.64 32.38 38.64 32.38 40.63 36.84
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Notice that the worksheet contains data that is converted to U.S. dollars.
Values for New York remain the same, but Germany values are converted.
Esshase converts the values by using the exchange rates from the Sample
Xchgrate database.

6. Fromthe\ Essbase\ cl i ent\ sanpl e directory, open Rat es. x| s. Connect
to the Sample Xchgrate database.

7. Select Essbase > Retrieve.

Figure 173: Retrieving Exchange Rates from a Currency Database

A B [c[Db [ETJFJ[GI[HTIJT[J]

L1 Jan Feb  Mar  Apr May  Jun Jul

L2 [US$ | Actxchg P&L 1 1 1 1 1 1 1
3 | B3 1 1 1 1 1 1 1
4| Bud xchg |PEL 1 1 1 1 1 1 1
5 | B3 1 1 1 1 1 1 1
|6 [CN$  Actxchg P&L 1563 153 153 153 1563 153 153
L7 | B3 165 185 185 185 185 1H5 155
8 | Bud xchg |PEL 1.5 1.5 1.5 1.5 1.5 1.5 1.5

9

B/S 15 15 15 15 15 15 15

Mark |Actxchg PEL 062 062 062 062 062 062 062
B/S 063 063 063 063 063 063 063

Bud xchg |PAL 0.7 0.7 0.7 0.7 0.7 0.7 0.7

—
=

—_
p—y

-
M

The worksheet contains al possible combinations of exchange rate scenarios,
categories, and types by month. Because this example convertsto U.S. dollars
(US$), the sample file contains a base rate of 1 for USS$. Therefore, the local and
converted figuresremain the samefor New Y ork. Essbase convertsthefiguresfor
Germany, however, by using data values in the currency database, as follows:

e Essbase divides data values from Actual by valuesin the Act xchg currency
type.

e Essbase divides data values from Actual @ Bud xchg by valuesin the Bud
xchg currency type.

e Essbase divides data values from Budget by values in the Bud xchg currency
type.

e Esshase basesdl figuresin Convert. x| s on the CurCategory of P&L and
the CurTime of Jan.

Note: A conversion can be defined as a multiplication or division operation on
exchange rates. The definition is determined by the application designer.
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Performing Ad Hoc Currency Reporting

A main database, such as Sample Interntl, usually contains values that are
converted and stored in the database. Y ou may want to perform currency
conversions dynamically, as well. Essbase provides this capability with the
Currency Report command. Thiscommand enablesyou tointeractively changethe

currency rates and types applied to the retrieval.

» To perform an ad hoc conversion on datain the Convert . xI s file:

1. Fromthe\ Essbase\ cl i ent\ sanpl e directory, open Convert. x| s.
The worksheet contains data that is already converted to U.S. dollars.

2. Select Esshase > Connect and connect to the Sample Interntl database.
Select Essbase > Retrieve.

Select Essbase > Currency Report.

Essbase displays the Essbase Currency Report dialog box.

Figure 174: Essbase Currency Report Dialog Box

Eszsbase Currency Report

" Current Setting:

|

Curl ame
CH$

‘rear

LClear |
Cancel |

CurType

-

CurCategory

I [none]

j I[none] j Help |

The Essbase Currency Report dialog box enables you to interactively
modify the exchange rates applied to the retrieval. The box contains options
for currency settings, names, categories, and years. For more information on
these options, see the Esshase Spreadsheet Add-in online help.

Note: The dimension names CurName, CurType, and CurCategory are default
names for a currency database. The application designer can use different names
for any of these dimensions.

5. Select the currency settings that you want to apply.

For example, select CN$ from the Cur Name list box and Bud xchg from the
CurType list box.
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6. Click Apply to apply the settings.

7. Select Esshase > Retrieveto refresh the datain the worksheet with the results
of the ad hoc conversion.

Figure 175: Performing an Ad Hoc Currency Conversion

A [ B [ € ] D [ E [T F [ & |
1 IJan Cola
12|
| 3 | Actusl Actuat & Bed XChe P
| 4 | Mew York Germany Mew York | Germany  New York | Germany
| B Sales 452 61 452 69 427 62
| B |COGS 181 24 181 27 173 26
| 7 | Margin 271 36 271 a1 253 36
8
| 9 |Marketing 63 8 63 9 53 7
| 10 | Fayrall 34 9 34 10 27 7
| 11 [Misc i i i 0 #dizsing #Missing
| 12 | Tatal Expenses 97 17 97 14 i 13
13
| 14 | Margin % 60.03 60.00 60.03 60.00 59.38 57.89
| 16 | Profit 32 38.64 32.38 38.64 32.38 40.63 36.84
16

Essbase converts the New Y ork and Germany figures to Canadian dollars
(CN$).

8. ClicktheClear buttoninthe Essbase Currency Report dialog box to disable
currency reporting and return to standard retrieval mode.

Note: Performing a currency report retrieval does not change values in the
database. It simply performs a temporary conversion as part of the retrieval.
Converted data values may not always balance, because the ad hoc conversion is
performed on values that were previously calculated or previously consolidated in
another currency.

If values must balance and verify, they must be converted to the target currency in
the database, calculated, and retrieved. This procedure differs from the ad hoc
currency conversion retrievals described in this section; see the Essbase system
administrator for more information.
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A

Essbhase Integration Servicesis a product that works with Essbase and Essbase
Spreadsheet Add-in for Microsoft Excel and Lotus 1-2-3. Essbase I ntegration
Servicesisasuite of tools and data integration services that serves as a bridge
between relational data sources and the Essbase server. Drill-through is one of
these tools. Drill-through enables you to view and customize spreadsheet reports
that display dataretrieved from relational databases. Y our organization must
license Essbase Integration Services for you to use the drill-through tool.

This chapter provides the following information:
e A brief overview of the drill-through feature

e A description of the sample database, Microsoft Excel file, and drill-through
report used for the tutorial

e A tutorid that guides you through tasks for using drill-through
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What Is Drill-Through?

Despite the benefits of the multidimensional database for storing analytic data,
somedataelementsrequired for analysisare better suited to the relational structure
of arelational database. The scope of dataresiding in an Essbase database is
typically at asummary level, where datais summarized and calculated for
planning and analysis. Detailed, transactional datausually is not examined during
the planning and analysis of a business.

For example, say you are using Esshase to analyze retail salesfor thefirst quarter
in the Eastern region. Detailed data, such as alist of customers who purchased a
particular product in a particular size, is not used during the normal course of
analyzing business performance. However, as you analyze sales results, you may
want to view more detailed information. Drill-through is atool that enables you to
drill from the summarized and cal culated data stored in the Essbase server of your
organization into detailed data stored in arelational database.

The database administrator predefines a data mapping for you from Essbase to the
relational source. For example, the Esshase members East, West, South, and
Central might map to afield called Region in arelational database. Asyou
navigate through data in the spreadsheet, Essbase knows how the current data
maps to the relational source. For example, suppose you select cell G4 in the
following sheet:

Figure 176: Example of Drill-Through Sheet

A ' B[ ¢ [ b E [ F L6 [ HI I [ 4] K E

|1 Profit | Froduct
| 2 | Scenaria Actual Budget
| 3 | Jan Feh Mar | Ol Jan Feh Mar | Ol Jan Feh
|4 | Mews ' ork 512 601 843 1856 812 I 601 _l 843 1656 B20 710
| 5 | Massachusetts 519 495 815 1432 519 495 1 815 14832 570 550
| 6 | Flarida 336 361 373 10700 336 361 373 1,070 400 450
| 7 Connecticut 321 308 290 920 0 31 308 290 920 380 380
| 8 | MNew Hampshire 44 74 g4 202 44 74 g4 202 110 130
| 9 | East 1,732 1843 1805 5380 1732 1843 1805 5380 2080 27230
|10 ‘est 2,339 2394 2404 | TI57 2339 2394 2404 737 2980 2,990
| 11|  South 997 1046 1034 | 3077 | 997 10465 1034 3077 1,330 1440
|12 | Central 2,556 3p0e3 3090 9109 2956 3063 3,080 9109 35350 3F90
| 13 | Market g,024 8346 8333 24703 8024 8346 8333 24703 5940 10,350
14

WA [» (M Market drill 3 Market Detail § Measures drilll Measures drill2 KN
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The dimensional attributes of the cell are as follows: Actual, Profit, New Y ork,
Feb, and Product. The combination of one or more of these attributes becomesthe
basis of adrill-through query that returns data from the relational source.

From Essbase Spreadsheet Add-in, you can access a predefined drill-through
report that isbased on the dimension or member intersections of Essbase datacells
in the sheet. Using an Esshase I ntegration Servicestool called Essbase Integration
Services Console, an administrator at your organization sets up drill-through
reports for you to access; that is, each drill-through report is already defined in
terms of what to retrieve from the relational source.

In Essbase Spreadsheet Add-in, you can access drill-through reports from the
Linked Objects Browser dialog box. When you select a drill-through cell in the
sheet and select Essbase > Linked Objects, the Linked Objects Browser dial og box
displays an entry for drill-through that you can select and launch.

Figure 177: Linked Objects Browser Dialog Box with Drill-Through Entry

i Linked Objects Browser -- Localhost:5ample:0LAP_TBC

Iember Combination:

Linked Objects:

« 2

Attach... | Edit. |£i.ew.-"Launc:h| [elete | Help | Lloze |

Y ou can define a style for cells tagged as drill-through to identify which cellsin
the spreadsheet are associated with drill-through reports. For more information,
see “Accessing Drill-Through from the Spreadsheet” on page 226.
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What Is the Drill-Through Wizard?

An administrator at your organization can predefine drill-through reports for you
to view or customize. The person who develops a report determines whether the

report can be customized by drill-through users. If areport can be customized, use
the Drill-Through Wizard to customizeit. The Drill-Through Wizard isagraphical
user interface that steps you through the following customization tasks:

e Selecting columns to retrieve from the relational data source
Decide which columns from the predefined report you need to see.
e Selecting the display order for columns
Change the default display order of columns across the sheet.
e Selecting asort order for data

Select an ascending or descending sort order for a particular column; for
example, sort alist of store managersin alphabetical order.

e Selecting datafilters

Define afilter on acolumn so that only data meeting certain criteriais
retrieved.

Before You Start

216 W

Before starting thetutorial, you should have aworking familiarity with the Essbase
product through the use of the Essbase Spreadsheet Add-in interface. Review in
this guide Chapter 2, “ A Basic Essbase Tutorial” and Chapter 3, “An Advanced
Esshase Tutorial” as prerequisite reading.

A sample Essbase database is the basis for the examplesin this tutorial. The
database administrator creates this sample Esshase database using the sample
metaoutline supplied with Essbase I ntegration Services. For moreinformation, see
the Essbase Integration Services OLAP Metaoutline User’s Guide. A sample
Microsoft Excel file, Essdt . xI s, contains a sheet with the appropriate member
intersections for the sampl e drill-through report. For more information on the
sample database, Microsoft Excel file, and drill-through report, see “ About the
Samples Used in This Tutorial” on page 224.
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If you plan to follow the examplesin alive working session, check with the person
at your organization who installs the Essbase Integration Services product family
for information on the sample database you need for drill-through, and to which
Essbase server you should connect.

Note: The Essdt . x| s file also contains sample results of the drill-through reports
when you run them without customizing the reports. The results are provided in
separate sheets in the workbook so that you can see the sample report results without
working through the tutorial For more information about the sample reports, see “About
the Samples Used in This Tutorial” on page 224.

Before starting the tutorial, make sure you meet the following requirements:
e Youmust install the following components on your client PC:

— A 32-bit version of Excel (for example, Excel 97 or Excel 2000)

—  Essbase Spreadsheet Add-in for Excel

—  Drill-through

The drill-through module isinstalled automatically when you install
Essbase Spreadsheet Add-in. Thismoduleistransparent until you invoke
it from the Linked Objects Browser. For moreinformation oninstallation,
contact the Essbase system administrator.

e The Essbase system administrator must install the Essbase server.

e You must have access to Esshase I ntegration Services and to the Esshase
server. For moreinformation, contact the Essbase system administrator or the
person who administers Essbase Integration Services at your organization.

e You must have access to the underlying relational database (typically using a
user nameand password that are different from those you usefor Essbase). For
moreinformation, contact the Essbase system administrator or the person who
administers Esshase Integration Services at your organization.

e Make sure that the sample Excel file, Essdt . x| s, isavailablein the
\ Essbase\ cl i ent\ sanpl e directory.
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In order to use the sample drill-through report, Essdt . x| s, you need to
login to amachine that has both the Essbase server and Essbase Integration
Servicesinstalled. You must run member and dataload and calcul ate the data
for the sample Esshase | ntegrati on Services database that you will accessfrom
Essbase Spreadsheet Add-in.

The sample database that contains the drill-through report must be set up and
running. The sample drill-through reports used in thistutorial (called “ Market
Detail,” “Measures Detail,” and “Product Detail”) are available with the
sample database. Contact the person at your organization who installs Essbase
Integration Services to find out the name of the sample database needed for
drill-through.

Note: For more information on Essbase Integration Services installations, see the
Essbase Integration Services Installation Guide. For more information on Essbase
installations, see the Essbase Installation Guide.

Keep in mind the following guidelines during the tutorial :

Each tutorial task builds upon the previous one, and tasks must be followed in
succession.

Tasksthat should not be performed as part of the tutoria aredisplayed in gray
boxes. These tasks are included for your reference. You can find more
information on these tasks in the Drill-Through online help.

The examples used in this tutorial are based on the sample database that is
included with the Essbase I ntegration Servicesinstallation. Contact the person
at your organization who installs Esshase | ntegration Servicesfor information
about accessing the sample database.

Set the optionsin the Essbase Options dial og box as described in thefollowing
section, “ Setting Essbase Options’ on page 219. If the option settings are
different, theillustrations presented in this chapter may not match the
spreadsheet view.

If you make amistake during thetutorial, select Esshase > FlashBack to return
to the previous spreadsheet view.
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Setting Essbase Options

Before you begin the tutorial, make sure that the spreadsheet options are set to
theinitial settings, asillustrated in Figure 178 through Figure 182. If your option
settings are different, the illustrations presented in this chapter may not match the
spreadsheet view.

Note: For information about each option in the Essbase Options dialog box, click Help
to see the Essbase Spreadsheet Add-in online help.

» To set Essbase options:
1. From the spreadsheet menu, select Essbase > Options.
2. Inthe Essbase Options dialog box, select the Display tab.

3. Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 178: Initial Settings for Display Options

Essbase Options E

Display |Zoom I tode I Style I Globall

Indentation—————— ~ Feplacement
" Mone #higzing Label: I
' Subitems
& Totak #Mo Access Label: l—
— Suppre — Aliaze:
™ #Missing Fows V' Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions
= Alias:
™ Use Styles IDefauIt j
V' Adiust Columng
= Aute Sort Homs Query Designer
" Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic Time Serie

[+ Latest Time Period IMH

QK I Cancel Help
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4. Select the Zoom tab.

Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 179: Initial Settings for Zoom Options

Essbase Options

O
(]
(]
(]
(]
(]
(]

6. Select the Mode tab.
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7. Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 180: Initial Settings for Mode Options

Essbase Options

8. Select the Style tab.
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9. Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 181.: Initial Settings for Style Options

Essbase Options E

Displayl Zoom I Mode  Style |GIObaI|

— Member
Attribute: — Sample
[ Chid
Shared -
= _I Farmat.. |
— Dimenszion
Dimension: - Sample
[ Measures
I Product LI
™| Gl Barder
Background Color: I Mone j Earmat... |
— Drata Cell
Attribute: — Sample
I Integration Server Drill-Through
[ Read Only LI Farmat... |
Connection Information:
’7 Aszpen:Sample:Basic ‘

10. Select the Global tab.
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11. Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 182: Initial Settings for Global Options

Essbase Options

12. Click OK to save the settings for this session and close the Essbase Options
dialog box.
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About the Samples Used in This Tutorial

The sampl e database used for this tutoria contains the following dimensions:
Scenario, Product, Market, Measures, and Y ear. The sample Excel file shownin
Figure 183 provides a particular view from this database:

Figure 183: View from Sample Database

A ' B[ ¢ [ b E [ F L6 [ HI I [ 4] K E

|1 Profit | Froduct
| 2 | Scenaria Actual Budget
| 3 | Jan Feh Mar | Ol Jan Feh Mar | Ol Jan Feh
|4 | Mews ' ork 512 601 843 1856 812 B011 543 1pB56 | 620 710
| 5 | Massachusetts 519 495 815 1432 519 495 1 815 14832 570 550
| 6 | Flarida 336 361 373 10700 336 361 373 1,070 400 450
| 7 Connecticut 321 308 290 920 0 31 308 290 920 380 380
| 8 | MNew Hampshire 44 74 g4 202 44 74 g4 202 110 130
| 9 | East 1,732 1843 1805 5380 1732 1843 1805 5380 2080 27230
|10 ‘est 2,339 2394 2404 | TI57 2339 2394 2404 737 2980 2,990
| 11|  South 997 1046 1034 | 3077 | 997 10465 1034 3077 1,330 1440
|12 | Central 2,556 3p0e3 3090 9109 2956 3063 3,080 9109 35350 3F90
| 13 | Market g,024 8346 8333 24703 8024 8346 8333 24703 5940 10,350

14 -
WA [» (M Market drill 3 Market Detail § Measures drilll Measures drill2 KN 4

For this spreadsheet view, detail-level dataexistsin arelational data source—data
that is not available from Esshase. For example, the relational source contains
columns of datafor market detail, measures detail, and product detail. Thistutorial
walks you through a sampl e drill-through session, where you will drill down from
the data shown in Figure 183 into the detail data from the relational source.

This tutorial uses two sample drill-through reports, “Measures Detail” and
“Market Detail.” Aswith al drill-through reports, these reports have been
predefined to retrieve specific columns from the relational source. Y ou will
use the Drill-Through Wizard to customize the report, “Measures Detail .”

Note: The sample file also contains two more sample reports called “Product Detail”
and “Two reports” that you can use for drill-through practice. In “Two reports,” select the
drill-through cell B3 to select from two drill-through reports, “Product Detail” and Market
Detail, select cell B6 to view “Market Detail,” and cell G3 to view “Product Detail.”
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In addition to the sample drill-through reports, Essdt . xI s provides sample
results of the drill-through reports. The following list describes the drill-through
results that are provided:

e TheMarket Detail drill tab displaystheresultsfor Market Detail whenyou run
adrill-through report on cell G4 without customizing the report.

e TheMeasures Detail drill1 tab displays the results for Measures Detail when
you run a drill-through report on cell C4 without customizing the report.

e TheMeasures Detail drill2 tab displays the results for Measures Detail when
you run a drill-through report on cell G6 without customizing the report.

e The Product Detail drill tab displays the results for Product Detail when you
run a drill-through report on cell D5.

Using Drill-Through
Drill-through consists of the following tasks:
e Accessing Drill-Through from Essbase Spreadsheet Add-in
e Selecting Drill-Through Reports to View or Customize
e Selecting and Ordering Columns
e Sorting Data
e Filtering Data

The following sections describe each of these tasks and step you through alive
working drill-through session.
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Accessing Drill-Through from the Spreadsheet

From Essbase Spreadsheet Add-in, you can access detail-level drill-through
reports that are based on the member intersections of Essbase data cellsin the
sheet. Each drill-through report has been predefined by an administrator at your
organization; that is, each drill-through report is already set up to retrieve specific
columns from the relational source, to sort datain these columnsin specific ways,
and so forth. Using the Drill-Through Wizard, you can customize these predefined
drill-through reports to retrieve only the data you want, displayed in a specific

way.

To access the predefined drill-through report, double-click a drill-through cell in
the spreadsheet (or select arange of cells and select Esshase > Linked Objects).
Y ou can set styles for cells tagged as drill-through to help identify which cellsin
the sheet are associated with drill-through reports. When you double-click a
drill-through cell, Esshase displaysthe Linked Objects Browser dialog box, which
displays an drill-through report entry. A single cell can have multiple reports
associated withit. The Linked Objects Browser dialog box also displaysentriesfor
linked partitions and other linked object types, such as cell notes, URLS, and
application files. After you view or customize the drill-through report, Essbase
Integration Services retrieves data from the relational source and displays the
resultsin anew spreadsheet.

Before starting the drill-through tutorial, perform the following tasks:

1. Openasample Excel file that contains the appropriate member intersections
from the sampl e database for the drill-through report. Thisfile, Essdt . x| s,
is provided as part of the default Essbase installation.

2. Setastylefor data cellsthat are associated with drill-through reports.
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» To access the sample file and sample database:
1. Start Excel.

2. Select File > Open and open the Essdt . xI s file from the
Essbase\ cl i ent\ sanpl e directory.

The sample file should look like the following screen. Note that the Market
Detail tab isselected in thisexample. Thedefault tab that is sel ected when you
first open the file may be different.

Figure 184: Sample Excel File for Drill-Through

A ' B[ ¢ [ b E [ F L6 [ HI I [ 4] K E

|1 Profit | Froduct
| 2 | Scenaria Actual Budget
| 3 | Jan Feh Mar | Ol Jan Feh Mar | Ol Jan Feh
|4 | Mews ' ork 512 601 843 1856 812 B011 543 1pB56 | 620
| 5 | Massachusetts 519 495 815 1432 519 495 1 815 14832 570
| 6 | Flarida 336 361 373 10700 336 361 373 1,070 400
| 7 Connecticut 321 308 290 920 0 31 308 290 920 380
| 8 | MNew Hampshire 44 74 g4 202 44 74 g4 202 110
| 9 | East 1,732 1843 1805 5380 1732 1843 1805 5380 2080 27230
|10 ‘est 2,339 2394 2404 | TI57 2339 2394 2404 737 2980 2,990
| 11|  South 997 1046 1034 | 3077 | 997 10465 1034 3077 1,330 1440
|12 | Central 2,556 3p0e3 3090 9109 2956 3063 3,080 9109 35350 3F90
| 13 | Market g,024 8346 8333 24703 8024 8346 8333 24703 5940 10,350

14 -
WA [» (M Market drill 3 Market Detail § Measures drilll Measures drill2 KN 4

Thesamplefile shows datafor specific members of an Essbase database. This
sample file contains the following three predefined drill-through reports,
indicated by the tabs of the spreadsheet: “Market Detail,” “Measures Detail,”
and “Product Detail.” Using drill-through, you can access these reports and
customize them so that Essbase I ntegration Services retrieves only the data
you need and displaysit in the desired format.

3. Select the Market Detail tab on the spreadshest.
4. Select Esshase > Connect and connect to the appropriate sample database.

Note: A specific sample database for drill-through is not automatically provided
with Essbase Integration Services. For information on the sample database,
contact the person at your organization who installs Essbase Integration Services
to set up a database for you.
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5. Select Esshase > Options and select the Style tab.

6. IntheData Cellsoption group, select thelntegration Server Drill-Through
check box and click Format.

Essbase displays the Font dialog box.
Select Bold Italic from the Font stylelist box.

8. Select Blue from the Color drop-down list, and click OK to return to the
Essbase Options dialog box.

Figure 185: Font Dialog Box Selection

Font 21=]
FEont: Font style: Size:
[MS Sans Serit S old It 10 [ ok ]
15 &l Regular af g .
M5 Italc B IlIl—I Corcel |
T News Gothic Bold 12
H News Gothic Condens Bold [talic 14
% Mimrod it 18
Orys 24
B Perpetua LI LI LI
— Effect: — Sample
[ Stikeout
™ Underline AL
Lolor:
I- Blue vl Script:
IWestern VI

Note: In the Essbase Options dialog box, Essbase displays an example of the
selected style in the Sample box.
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Thefollowing screen shows how the Essbase Options Style tab lookswith the
style for drill-through cells defined:

Figure 186: Sample Style for Drill-Through Data Cells

Essbase Options

Displayl Zoom I Mode  Style |GIObaI|

— Member
— Sample
v
v Child Parent
[ Shared LI
Farmat... |
— Dimenszion
— Sample
=
[ Measures
I Product LI
™| Gl Barder
Background Color: I Mone j Earmat... |
— Drata Cell
— Sample
I Linked Objects = Sl
Il ritegration 1 Drill-Through fntegration Sen
[ Read Only LI
Farmat... |

Connection Information:
’7 lzgal 7:EIS:Main

Essbase Spreadsheet Add-in for Excel
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9. Inthe Esshase Options dialog box, select the Display tab, and then select
the Use Styles check box.

Figure 187: Setting the Use Styles Option

Essbase Options

[ ]
Display |Zoom I Mode I Style I Globall
— Indentation — Replacement
" Nane HMissing Labsl: |0
& Subjterns
 Totaks #Mo Access Label: l—
— Suppre — Aliaze:
™ #Missing Fows V' Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Raw Dimensions
Alias:
o IDefauIt j
V' Adiust Columng
= Aute Sort Fows Query Designer
V¥ Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer
— Dynamic Time Serie
™ Latest Time Period IJan j
QK I Cancel | Help |

10. Click OK to close the Essbase Options dialog box.
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11. Select Esshase > Retrieve to display the new style in the spreadshest.

In Figure 188, the sample drill-through report is associated with the data cells
for Actual, Profit, and Product at the month and Eastern state levels, so that
these data cells are displayed in blue, bold, italic font.

Figure 188: Sample Excel File with Drill-Through Style Applied

A B | ¢ | b [ E | F [ &6 [ H [ 1 1 1 |§

|1 Profit | Product
| 2 | Scenaria Actual
| 3 | Jan Feh tlar Oitrl Jan Feh tlar Oitrl Jan
|4 | Mews ' ork X A4 a37 A47 1656 X A4 £071 547 1656
| 5 | Massachusetts EYES 98 A7 1532 EYES 98 A7 1532
| 6 | Flarida JIE JET Z77 1070 JIE JET Z77 1070
| 7 Connecticut 277 Ji7 EL 920 277 Ji7 EL 920
| 8 | MNew Hampshire L&l ~ #4 202 L&l ~ #4 202
| 9 | East 1,732 1843 1805 5380 1732 1843 1805 5330 2,080
|10 ‘est 2,339 2394 2404 FO37 0 2339 2384 2404 37 2980
| 11|  South 997 1046 0 1034 3077 997 | 1046 1034 3077 17330
|12 | Central 2,556 3poe3 | 30900 9109 2856 3063 3080 9109 3550
| 13 | Market g,024 8346 8,333 24703 8024 8346 8333 24705 9940
14

WA [» (M Market drill 3 Market Detail § Measures drilll Measures drill2 KN

To access the sample drill-through report from Esshase Spreadsheet Add-in:
1. Select any drill-through cell; for example, cell G4.

Figure 189: Selecting a Drill-Through Cell

A B T ¢ [T o [ e [T F [6 [ & T 1 [ J 5
|1 Profit | Product Il
| 2 | Scenaria Actual
| 3 | Jan Feh tlar Oitrl Jan Feh tlar Oitrl Jan
14| Mewy W ark &7Z &7 &7 1556 &7Z &7 &7 1556
| 5 | Massachusetts £77 978 &7 1532 £77 kL &7 1532
| 6 | Florida A FET FAF 1070 A FET FAF 1070
| 7 | Cannecticut 227 749 287 920 227 749 287 920
| & | Mew Hampshire L - &5 202 L - &5 202
| 9 | East 1,732 1843 1805 5380 1732 1843 1805 5380 2080
|10 ‘West 2,339 2394 | 2404 | 7457 2339 2384 2404 757 25980
| 11|  South 997 1046 | 1034 3077 997 1048 1034 3077 1330
| 12|  Central 2,956 3063 3080 9109 296 3063 3090 95109 3550
| 13| Market §,024 8346 | 8333 24703 8024 85346 85333 24703 95940
14
WA [» (M Market drill 3 Market Detail § Measures drilll Measures drill2 KN

Essbase Spreadsheet Add-in for Excel

Note: You can also select a continuous range of cells in the sheet to display all
drill-through reports associated with cells you select. In this example, we have only
one drill-through report attached to the range of cells.
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2. Select Esshase > Linked Objectsto openthe Linked ObjectsBrowser dialog
box.

Alternatively, select the Enable Linked Object Browsing check box in the
Esshase Optionsdialog box (Global tab), which enables you to double-click
alinked object cell to open the Linked Objects Browser dialog box. This
option works only with single-cell selection. If you select arange of cells, use
the Essbase > Linked Objects menu command.

Figure 190: Linked Objects Browser Dialog Box with Drill-Through
Entry Selected

i Linked Objects Browser -- Localhost:5ample:0LAP_TBC

Iember Combination:

Linked Objects:

Object Type Object Description Linked Object and Object Created By (L.

Drill-Through sshase Integration Server  E s Intearation Server

« 2

Attach... | Edit. |£i.ew.-"Launc:h| [elete | Help | Lloze |

3. Select the drill-through report entry and click View/L aunch.
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4. Inthe Select Drill-Through Report dialog box, select Market detail and click
Execute.

The results of the drill-through report are displayed in a spreadsheet. The
results of the Market Detail report showsthat theregional director for the East
region is John West and that the population for New Y ork is between
18,000,001-21,000,000.

Figure 191: Results of Market Detail Drill-Through Report

A B [ ¢ | 5] I E [T F |
REGION IDIRECTOR |STATE  POPULATION_ALIAS
East John West |Mew York 18,000,001--21,000,000

= ca ol

Note: If there is only one report available for the cells you select in the
spreadsheet, and if that report is not designed to be customized, drill-through
generates the report and immediately displays the results in the spreadsheet. The
person at your organization who develops drill-through reports specifies whether
you can customize a report and whether you need to log in to drill-through and the
relational data source.

5. Follow thestepsin the next section, “ Selecting Drill-Through Reportsto View
or Customize” on page 233 to select a report to customize.

Selecting Drill-Through Reports to View or Customize

After you launch drill-through from the Linked Objects Browser dialog box,
Essbase | ntegration Services displays the Select Drill-Through Report dialog box
under the following conditions:

e Morethan one drill-through report exists for the cell or cell range that you
select in the spreadsheet, or

e Only one report exists, but you have the option of customizing it using the
Drill-Through Wizard.
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The Select Drill-Through Report dialog box displaysthe list of drill-through
reports available for the cells you select in the spreadsheet. Depending on how a
report is defined in Essbase Integration Services Console, you may have access
only to view, not customize, the report.

2. Click Execute.

current sheet.

The sample report used for this tutorial isthe Measures Detail report. You will
use the Drill-Through Wizard to customize this sample report. To execute a
predefined drill-through report without customizing it, perform these tasks:

1. Select thereport that you want to view from the Available Reportslist box.

Essbase Integration Services retrieves the data from the relational source and
displays the resultsin a new spreadsheet. The new sheet is added before the

» To customize the sample drill-through report:

1. InEssdt. x| s, select the M easures Detail tab.

Figure 192: Initial Drill-Through Report for Measures Detail

A B C D | E [ F [ 6 | i =
1 =
| 2 | Mews ok Mazsachy
| 3 | Cola | Diet Caola | Caffeine Free Cola | Calas | Cala | Diet Cala
EN Sales Year 5940 0 0 8540 B518 0
| 5 | Cost of Goods Sold | Year 3573 0 u] 3573 783 0
| 6| targin Year 5367 O 0 5367 | 573510
| 7 | Tatal Expenszes Year 1869 0 u] 1,869 B30 0
| & | Profit Year 3495 0 0 3498 5105 0
g
10
I41 |1< [» Tl Market drill £ Market Detai Measures drill 3 Measures Detail ;| 4]

2. Select Esshase > Connect and connect to the appropriate sample database.

Note: A specific sample database for drill-through is not automatically provided
with Essbase Integration Services. For information on the sample database,
contact the person at your organization who installs Essbase Integration Services
to set up a database for you.
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Select Essbase > Options and select the Styletab to define stylesfor this sheet.

4. IntheData Cellsoption group, select the I ntegration Server Drill-Through
check box and click Format.

Essbase displays the Font dialog box.

Note: The style for drill-through cells may already be set as blue, bold, italic font
because you set the style in the previous exercise. If this is the case, then go to
step 7.

5. Select Bold Italic from the Font stylelist box.

6. Select Bluefrom the Color drop-down list, and click OK to return to the
Esshase Options dialog box.

Figure 193: Font Dialog Box Selection

Font 21=]
FEont: Font style: Size:
[MS Sans Seii 10 [ ok ]
if Fegular N
talic —I m—l Cancel |
T News Gothic Bold 12
H News Gothic Condens Bold [talic 14
% Mimrod it 18
Orys 24
B Perpetua LI LI LI
— Effect: — Sample
[ Stikeout
™ Underline AL
Lolor:
I- Blue vl Script:
IWestern VI

Note: In the Essbase Options dialog box, Essbase displays an example of the
selected style in the Sample box.
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Figure 194: Sample Style for Drill-Through Data Cells

Essbasze Options E

Displayl Zoom I Mode Style |GIObaI|

— Member
— Sample
v
v Child Parent
[ Shared LI
Format... |
— Dimension:
— Sample
=
I Measures
[ Product ;I
™| Cell Barder:
Background Colar: I Mone j Earmat:.. |
— Drata Cell
— Sample
I Linked Objects = Sl
Imllirteqration Server Drill-Through fntegration Serv
[ Read Only ;I
Format... |

Connection Infarmation:
’7 lzgal 7:E15:Main

QK I Cancel | Help |
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7. Inthe Essbase Options dialog box, select the Display tab and select the Use
Styles check box.

Figure 195: Setting the Use Styles Option

Essbase Options [ %]
Display |Zoom I Mode I Style I Globall
Indentation———— ~ Feplacement
" Nane HMissing Labsl: |0
& Subjtems
 Totaks #Mo Access Label: l—
— Suppre — Aliaze:
™ #Missing Fows V' Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions
Alias:
IDefauIt j
V' Adiust Columng

= Aute Sort Fows Query Designer
¥ Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic Time Serie
™ Latest Time Period IJan j

QK I Cancel | Help |

8. Click OK to close the Essbase Options dialog box.
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9. Select Esshase > Retrieve to display the new style in the spreadsheet.
In this example, the sample drill-through report is associated with every
member intersection at the state level in the East region, so that all datacells
associated with an Eastern state and children of Colaare now displayed in
blue, bold, italic font.
Figure 196: Sample File with Drill-Through Style Applied
A | B C ] E | F G H |
1
Z Mews ok Mazsachusetts
| 3 | Cala Diet Cala | Caffeine Free Cala | Calas | Cola Diet Cala
4| Sales Year | 8940 & 7 8940 |  £578 4
| 5 | Cost of Goods Sold | Year 2477 7 7 3573 FEF 7
| 6 | Margin “rear BIE7 7 7 5,367 E
| 7 | Tatal Expenszes “rear Faeg 7 7 1,869 L%/ A
| 8 | Profi Year | 1498 & 7 3498 | &85 4
g
|10

» To access the sample drill-through report from the Essbase Spreadsheet Add-in:

1. Select any drill-through cdll; for example, cell G6.
Figure 197: Selecting the Drill-Through Cell for the Measures Detail Report
A el ¢ | 0 | E TPl 6 | H |

1
Z Mews ok Mazsachusetts
| 3 | Cala Diet Cala | Caffeine Free Cala | Calas | Cola Diet Cala
| 4 | Sales Year a840 7 7 8,940 E578 &7
| 5 | Cost of Goods Sald | vear 2577 & 7 3573 A3 7
| 6| targin rear L3857 & 7 5,367 L]
| 7 | Tatal Expenszes rear 1857 7 7 1,869 53 7
| 8 | Profit Year 2498 7 7 3,498 si0s 7

g
[10]
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Note: If Essbase Integration Services is not running, drill-through does not launch
properly. For more information, contact the Essbase system administrator.

Note: If you are prompted with the Drill-Through Login dialog box to connect to
Essbase Integration Services and the relational data source, enter the appropriate
connection information. The person at your organization who administers Essbase

Integration Services and develops drill-through reports should provide you with this
information.
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2. Select Esshase > Linked Objectsto openthe Linked ObjectsBrowser dialog
box.

Alternatively, select the Enable Linked Object Browsing check box in the
Esshase Optionsdialog box (Global tab), which enables you to double-click
alinked object cell to open the Linked Objects Browser dialog box. This
option works only with single-cell selection. If you select arange of cells, use
the Essbase > Linked Objects menu command.

Figure 198: Linked Objects Browser Dialog Box with Drill-Through
Entry Selected

i Linked Objects Browser -- Localhost:5ample:0LAP_TBC

Iember Combination:

Linked Objects:

Object Type Object Description Linked Object and Object Created By (L.

Drill-Through e Integration Server  Es Integration Server

« 2

Attach... | Edit. |£i.ew.-"Launc:h| [elete | Help | Lloze |

3. Select the drill-through report entry and click View/L aunch.

The Select Drill Through Report dialog box is displayed.
Note: In the Select Drill Through Report dialog box, if the Customize button is
selectable, then you can customize the report. If more than one drill-through report

is displayed, then you can select from the different drill-through reports. In this
tutorial, only one report, “Measures detail,” is displayed and customizable.
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4. Select the Measures detail report from the Available Reportslist box.

Figure 199: Selecting the Sample Drill-Through Report

Select Drill-Through Report (=[] =]

Available Reports Execute

Customize ...

Lancel

i

Help

5. Click Customize.

Note: The Customize button may be selectable or not selectable for any given
report, depending on how the report was defined in Essbase Integration Services
Console.

Essbase | ntegration Services displays the first screen of the Drill-Through
Wizard.

Figure 200: Drill-Through Wizard Dialog Box, Introductory Screen

Follow these steps to customize the transactional report
related to the OLAP intersections you have selected:

1. Select the columns to retrieve and define their
dizplay order.

2. Define a sort arder for colurmns.

3. Define filkers for columns.

Click the finizh button at any point to generate the report,

< Back Mest » Cancel Help
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6. Click Next to display the Select Columns and Display Order dialog box.
Figure 201: Select Columns and Display Order Dialog Box

Select Columns and Display Order E

Fepart Mame

IMeasures detail

Availal

Selected Columnz

MEASIIRES CHILD
MARKET STATE
PRODUCT.SkU
SCEMARIO.SCENARID
Time. TRANSDATE
SALES AMOUNT

MARKET
7 PRODUCT
7 SCEMARID
7 Time

7 GALES

ove llp

> Move Qownl

Bl =[]

<€

< Back

Mest » | Finizh I Cancel | Help |

7. Follow the steps in the next section, “ Selecting and Ordering Columns” on
page 241, to select and order rows for the customized report.

Selecting and Ordering Columns

Using the Drill-Through Wizard, you can customize predefined drill-through
reports. Thefirst task in the Drill-Through Wizard is selecting and ordering
columns to retrieve from the relational database. These columns contain detailed
information that is not available in the Essbase database.

In the Select Columns and Display Order dialog box, you can select which
columns you want Essbase I ntegration Servicesto retrieve from therelational data
source. From this dialog box, you can also specify how the columns are displayed
in the resulting report.

The Available Columns list box displays alist of columns available from the
relational data source for this report (as defined in Essbase Integration Services
Console). The Selected Columnslist box displaysthe columns from the Available
Columns list box in expanded form. Y ou can remove columns from the Selected
Columns list box to exclude them from the drill-through report.
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In this exampl e, the columns from the Available Columnsist box are selected for
inclusion in the sample Measures detail report. These columns are displayed in
expanded form in the Selected Columns list box.

» To remove one of the selected columns from the drill-through report:

1. Inthe Selected Columnslist box, select the MARKET.STATE column.
Note: To select multiple columns in the list that are not adjacent to each other, hold
down the Ctrl key and select each column. To select a range of columns, hold down

the Shift key and click the first and last columns in the list, which also selects all
columns in between them.

Figure 202: Selecting Columns to Remove From the Drill-Through Report

Select Columns and Display Order E

Fepart Mame

IMeasures detail

Available Columns Selected Columnz
ME&SLIRES MEASLIRES CHILD
iMARKET STATE

PRODUCT.SkU
SCEMARIO.SCENARID

Time. TRANSDATE
SALES.AMOUNT
Move Up |
> Move Qownl

Bl =[]

<€

< Back Mest » | Finizh I Cancel Help
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2. Click to move the selected column from the Selected Columns list box
back to the Available Columns list box.

Note: To move a column from one list box to another, click or . To move
all columns from one list box to another, click or .

3. Click Next to display the Select Data Sort Order dialog box, and follow
the stepsin the following section, “Ordering Data” on page 243 to further
customize the report.

Note: When you finish customizing the report, click Finish at any time to generate
the report and view the results in a new sheet. The new sheet is placed before the
current sheet.

Ordering Data

In the Select Data Sort Order dialog box, you can select an ascending or
descending sort order for the datain a column. Sort order determines the order in
which rowswill be displayed in the drill-through report. For example, you can sort
the contents of the Time. TRANSDATE column, which represents the transaction
dates, in ascending order in the drill-through report.

» To define the sort order of rows in the drill-through report:
1. IntheAvailable Columnslist box, select the Time. TRANSDATE column.

The columnsinthe Available Columnslist box are those that you selected in
“Selecting and Ordering Columns” on page 241. The columnsin the Column
list box are those for which a sort order has already been defined in Essbase
Integration Services Console.

If adata sort order was selected when the report was created in Essbase
Integration Services Console, the Order By list box displays that selection.
Otherwise, the default sort order is Ascending.
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2. Click to movethe Time. TRANSDATE columnto the Column list box so
that you can define a sort order for the column.

Note: To move a column from one list box to another, click or . To move
all columns from one list box to another, click or .
Figure 203: Moving a Column to the Column List Box for Sorting

Select Data Sort Order E
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3. Inthe Column list box, double-click the Time. TRANSDATE column to
change the data sort order from Ascending to Descending so that transaction
date values are displayed in reverse chronological order in the drill-through
report.

Figure 204: Selecting the Data Sort Order

Select Data Sort Order E

Fepart Mame

IMeasures detail

Available Columns I
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PRODUCT.SKU
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4. Click Next to display the Select Data Filter s dialog box, and follow the steps
inthefollowing section, “Filtering Data” on page 247 to further customizethe
report.

To change the data sort order for multiple columns at one time, perform these

tasks:
1. Hold down the Ctrl key and select the desired columns from the Column list
box.

2. Click Order By.

Essbase Integration Services displays the Order By dialog box.
Figure 205: Order By Dialog Box

Item | oK |
_ Corcel |

Aszcending
[escending

Cancel

Help |

3. Sedlect Ascending or Descending and click OK toreturn to the Selecting Data
Sort Order dialog box.
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Filtering Data

Y ou can apply filtersto determine what Essbase I ntegration Servicesretrieves for
the drill-through report. For any given column, you may want to retrieve only data
that meets certain conditions. For example, the MEASURES.CHILD columnin
the sample database containsall children of the M easuresdimension. Inthe sample
drill-through report, if you did not apply afilter to thislist of measures, Essbase
Integration Serviceswould retrieveall children from therelational source, because
the sampl e drill-through report appliesto all children of Measures. In this section,
you will apply afilter to the MEASURES.CHILD column so that al children of
Measures, except Misc, are included in the report.

Note: When you apply a filter on a non-level 0 member using Essbase Integration
Services, the filter may return more members than expected. To work around this
problem, use the Drill-Through Wizard.

» To define afilter:
1. Select the MEASURES.CHILD column from the Column list box.

The columnsin the Column list box are those that you selected in “ Selecting
and Ordering Columns’ on page 241.

Figure 206: Select Data Filters Dialog Box

Select Data Filters E
Colurnn | Condition | Add |
ME&SURES.CHILD
MARKET.STATE
PRODUCT SKU ﬂl
SCEMARIO.SCENARIO
Time. TRANSDATE Clear &l |
SALES.AMOUNT

Condition
< Back | dEwt | Finizh I Cancel | Help |

Note: If there is a filter already attached to the column, it is displayed in the
Condition list box. The full string of the filter is displayed in the lower Condition
text box.
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2. With the MEASURES.CHILD column selected, click Add.
The Set Filter on Column dialog box is displayed.

Figure 207: Set Filter on Column Dialog Box

Set Filter On Column : CHILD E
Filters |

Colurnm: Operator: Condition:

[cHiLD -] [E——] | [
fdd | Add Type

 And
@ 0r

Filters:

¥
4 ¥

QK I Cancel | Help |

3. Select CHILD from the Column drop-down list box.

The column displayed in the Column drop-down list box is the one that you
selected in “Filtering Data” on page 247.

4. Select the <> operator, which represents not equal to, from the Oper ator
drop-down list box.

Note: You can select multiple values at one time only if you have selected In or
Not In as the filter operator. For more information on filter operators, see the
Drill-Through online help.
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5. Click the Browse El button to open the Select Filter Valuesfrom the List

dialog box, which lists all possible values for that column.
The Select Filter Valuesfrom the List dialog box is displayed.

Note: Essbase Integration Services retrieves these values directly from the
relational data source. If the relational data source contains many values, Essbase
Integration Services confirms if you want to view them all before it retrieves them

from the data source.

6. Inthe Select Filter Valuesfrom the List dialog box, select Misc and click

OK. The Set Filter On Column dialog box is displayed.

Figure 208: Selecting Filter Values from the List

Select Filter ¥alues from the List
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7. Click Add to add the condition to the Filter slist box.

Note: For information on using multiple filter conditions, see the Intergration

Server Drill-Through online help.

The Set Filter on Column dialog box should now look like this:

Figure 209: Defining a Filter for a Column

Set Filter On Column : CHILD

Filters |
Colurnm: Operator: Condition:
|cHILD =l e =
 And
@ 0r
Filters:

MEASURES.CHILD <> Misc’

il

Cancel | Help |

Thefilter defined above causes all children of Measures, except Misc data, to

show in the drill-through report.

Note: The Add button becomes unselectable after creating the first filter, but
becomes selectable when you create another filter. In this tutorial, you are creating
only one filter. The And and Or options are used when combining multiple filters.
The default value is Or, which means that Essbase Integration Services applies the
filter if any of the conditions you specify are met. If you select And, Essbase
Integration Services applies the filter only if all the conditions are met.
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8. Click OK toreturnto the Select Data Filter sdiaog box. Notice that thefilter
defined in the Set Filter on Column dialog box is displayed in the Condition
list box and text box of the Select Data Filters dialog box.

Figure 210: Result of Defining a Filter for a Column

Select Data Filters

Colurnn | Condition

MEASURES.CHILD
MARKET STATE
PRODUCT.SKU
SCEMARIO.SCENARIOD

MEASURES.CHILD <> Misc’

LClear |
Clear Al |

< Back | dEwt |

Time. TRANSDATE
SALES.AMOUNT
Condition
ME&SURES.CHILD <> Misc' ;l
Finizh | Cancel | Help

Note: You can also create a filter by typing the filter conditions directly into the
Filters list box of the Set Filter on Column dialog box. For more information, see

the Drill-Through online help.

To delete a filter, select the filter and click Clear. To delete all filters, click Clear All.
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9. Click Finish.

Essbase | ntegration Services generates the customized drill-through report
and displaystheresultsin anew spreadsheet. The new spreadsheet isadded to
the workbook before the current spreadsheet.

Figure 211: Customized Drill-Through Report

A | B | C [ 1] [ | F |

1_[CHILD ISkl SCENARIO TRANSDATE AMOUNT
| 2 |Additions 100-10 | Actuzl 2000-12-09 00:00:00000 | 12397
| 3 [cocs 100-10 | Actuzl 2000-12-09 00:00:00000 | 5159
| 4 |Marketing 100-10 | Actuzl 2000-12-09 00:00:00.000 16.94
| 5 |Payrall 100-10 | Actuzl 2000-12-09 00:00:00000 | 2387
| & [Sales 100-10 Actuzl 2000-12-09 00:00:00000 | 3927
| 7 |Additions 100-10 Actuzl 2000-12-04 00:00:00000 | 37.03
| &8 [coGs 100-10 Actuzl 2000-12-04 00:00:00.000 1541
| 3 [Marketing 100-10 Actuzl 2000-12-04 00:00:00.000 506
|10 [Payrall 100-10 Actuzl 2000-12-04 00:00:00.000 7.13
| 11 [sales 100-10 Actuzl 2000-12-04 00:00:00.000 117.3
| 12 [Additions 100-10 Actuzl 2000-11-28 0000:00000 | 5382
|13 |coGs 100-10 Actuzl 2000-11-28 00:00:00.000 19.5
| 14 [Marketing 100-10 Actuzl 2000-11-28 00:00:00.000 £.24
| 15 [Payrall 100-10 Actuzl 2000-11-28 00:00:00.000 8.06
| 16 [Sales 100-10 Actuzl 2000-11-28 00:00:00000 | 118.04
| 17 |Additions 100-10 Actuzl 2000-11-19 00:00:00000 | 153.18
|18 |coGs 100-10 Actuzl 2000-11-19 00:00:00.000 555
| 19 [Marketing 100-10 Actuzl 2000-11-19 00:00:00.000 1776
| 20 [Payrall 100-10 Actuzl 2000-11-1900:00:00000 | 2294
| 21 [3ales 100-10 Actuzl 2000-11-19 00:00:00000 | 33596
| 22 |Additions 100-10 Actuzl 2000-10-16 00:00:00.000 191
| 23|coGs 100-10 Actuzl 2000-10-16 00:00:00.000 72

In this sample, the customized drill-through report reflects the specifications that
you set using the Drill-Through Wizard:

e TheTime TRANSDATE columnissorted in descending order, displaying the
transaction dates in reverse chronologica order.

e All children of Measures, Additions, COGS, Marketing, Payroll, Sales, and
Opening Inventory, except Misc, aredisplayed asyou specified in thefiltering
part of the Drill-Through Wizard.
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Disconnecting from Essbase

When you finish using drill-through, disconnect from the Essbase server to free up
aport on the server for other Essbase Spreadsheet Add-in users.

» To disconnect from the server:
1. Select Esshbase > Disconnect.

Esshase displays the Esshase Disconnect dialog box, where you can
disconnect any spreadsheet that is connected to a database.

Figure 212: Essbase Disconnect Dialog Box

Essbase Disconnect

Sheet ServerApplication-> D atabase

Disconnect

Cloze

Help

1.

K — i

Note: Essbase may return an error
message when you attempt to disconnect after using drill-through. If an error
message is returned, select Essbase > Retrieve from the sheet and then
disconnect.

2. Select a sheet name from the list and click Disconnect.
Repeat Step 2 until you have disconnected from all active sheets.

4. Click Closeto close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by closing Excel. An abnormal
termination of an Excel session, such as a power loss or system failure, does not
disconnect your server connection.
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Symbols

#Missing strings, suppressing, 72
#NOA ccess strings, suppressing, 72
* wildcard character, 113
?wildcard character, 113

A

access
to databases, 47, 124
to Esshase data, 47, 124
to linked partitions, 194
to linked reporting objects, 185
to multiple databases, 193
to online help, 37
using Essbase commands, 45
with drill-through, 226
Acrobat Reader. See Adobe Acrobat Reader
ad hoc reports, 17, 49, 147, 211
Add button, 248
Add-in Manager, 30
adding members. See members, adding
adjusting columns. See columns, adjusting width
administrators, 18
Adobe Acrobat Reader, ix
advanced interpretation engine, 167
Advanced Interpretation mode, 167, 174
aliases
definition of, 85
displaying
process of, 85
with member names, 87
with Query Designer results, 109
in tables, 85

Essbase Spreadsheet Add-in for Excel

aternate dimensions. See dimensions, aternate
alternate names. See aliases
ancestors, definition of, 27
AND operators, 110
API, 22
application designer, 18
application partitions. See linked partitions
application programming interface, 22
applications/databases

Sample Basic, 30, 46, 48, 125

sample for drill-through, 224

Sample Interntl, 207

Sample Xchgrate, 207
ascending sort order

with drill-through, 243

with Query Designer, 138
asymmetric reports

definition of, 141

pivoting, 143

retrieving datainto, 141
Attach Linked Object dialog box, 178, 181, 183
attaching reporting objects to cells. Seelinking
attaching to databases. See connecting
atributes, drill down, 54
auditing updates, 199
auto logouts, 121
Auto Sort Rows option, 170

B

blank

columns, 143

rows, 143
blocks, locking data, 197
Boolean operators, 110, 114
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C

Calculation command, 199
Calculation dialog box, 200
caculations
database status, 200
databases, 160, 199
dynamic, 160
reducing calculation time, 160
scripts, 200
specifying latest time period, 163
substitution variables, 165
with Dynamic Time Series, 163
with EssCell, 159
cancdling dataretrievals, 51
Cascade command, 201
Cascade Information page, 202
Cascade Options dialog box, 202
cascading sheets
creating table of contents, 205
destination, 203
format, 205
level of detail, 202
names, 204
output type, 203
cell notes
accessing linked, 187
linking to cells, 181
cell ranges
keeping, 64
removing, 67
retrieving, 153
selecting nonadjacent, 66
with drill-through, 231
cells
accessing linked partitions, 194
applying styles, 75, 82
attaching reports. Seelinking
attaching URLs. Seelinking
EssCell function in, 156
formatting, 75, 82, 180
in datacells, 82
of dimension members, 79

of Dynamic Calculation members, 160

of parent members, 76
formulasin, 143, 146, 149, 156
linked reporting objects, 177, 182

256 W

linking filesto, 177
linking notesto, 181
linking URLsto, 182
retrieving arange, 153
retrieving single values, 156
selecting nonadjacent, 66
with nondatabase values, 143
Change Password dialog box, 49
changing
passwords, 49
row and column orientation, 60
spreadsheet format, 75
styles, 75
children (defined), 27
Clear All button, 251
Clear button, 251
Clear command, 51
clearing styles, 84
click (defined), 38
client
components, 19
software, 29
upgrading with server, xv
client-server environment, 19
collapsing data views. Seedrill
colors, setting, 75
columns
adjusting width, 45, 145
blank, 143
displaying asrows, 60
displaying selected, 64
filtering by, 132
keeping selected, 64
nested, 53
pivoting, 60
removing selected, 67
retrieving into, 53
columns, drill-through
choosing, 241
selecting display order, 241

selecting for retrieval from relational source, 241

sorting, 243

commands
Calculation, 199
Cascade, 201
Clear, 51
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Connect, 47, 124, 193

Currency Report, 207, 211

Disconnect, 120

FlashBack, 51

Keep Only, 64

Linked Objects, 177, 182

Lock, 197

Member Selection, 111

Navigate Without Data, 67, 71

new in release 6, xvi

Pivot, 60

Remove Only, 67

Retrieve, 50

Retrieve & Lock, 197

Send, 197

Undo, 51

Unlock, 198

Zoom In, 52

Zoom Out, 56
comparison operators, 110, 133
computing environment, vii
concurrent

database access, 48, 193

updates to server, 197
conditional retrievals, 130
Connect button, 34
Connect command, 47, 124, 193
connecting

to adatabase, 47, 124

to arelationd data source, 214, 226, 238

to Esshase, 48, 124

to Esshase Integration Server, 226, 238

to multiple databases, 193

viewing current connections, 194
connecting. See also disconnecting
Connection Information text box, 194, 200
consolidations (defined), 28
conversions, currency, 207
creating queries, 93
creating reports. See reports, creating
Currency Conversion product, 22
currency conversions

modifying exchange rates, 211

reporting, 211

sample databases, 208

settings, 211
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Currency Report command, 207, 211
Currency Report dialog box, 211

current time period. See Dynamic Time Series
cursors (Esshase), 50

custom applications, 22

Customize button, 240

customizing drill-through reports, 234

D

data
calculating, 199
changing orientation, 60
comparison operators, 133
displaying, 24, 50
dynamically calculating, 160
filtering, 130
filtering, with drill-through, 251
formatting, 75
locking, 197
missing, 72
modifying, 197
navigating, 28, 67
pivoting, 60
relational, with drill-through, 213
removing subsets, 67
retaining subsets, 64
retrieving. See retrieving
sorting, 130
unlocking, 198
updating, 197, 199
data sort order, with drill-through, 243
data source, relational, 238
databases
calculating. See calculations
connecting. See connecting
consolidations, 28
defined, 23
dimensions, 26
disconnecting from, 120
linked. See linked partitions
loading, 49, 126
locking, 197
members, 26
organization, 25
outlines, 28
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queries. See queries, 91

restoring previous views, 51

rules, 25

sample, 46, 207, 224

selecting. See connecting

switching, 193

viewing connections, 194
deleting

filters, drill-through, 251

selected members, 67

styles, 84
descendants (defined), 27
descending sort order

with drill-through, 243

with Query Designer, 138
Destination Options page, 203
destinations

cascaded sheets, 203

Query Designer queries, 102
detaching. See disconnecting, 120
dialog boxes, Help buttons, 37
dimensions

dternate, 23

applying styles, 79

currency conversion and, 207

described, 23, 26

drilling down on, 52, 53

drilling up on, 56

naming elements, 26

pivoting, 60
disabling data retrieval. See navigating without data
Disconnect

command, 120

dialog box, 120
disconnecting

forced logouts, 121

from Essbase, 120

from Esshase I ntegration Server, 253
discontinuous rows and columns, 66
disk space, effect on Dynamic Calculation, 160
display

options, 75

order of columns, drill-through, 241
Display page (Essbase Options dialog box), 40, 219
Display Unknown Member option, 146, 148
displaying data, 24, 50
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distributed sheets. See cascading sheets
double-clicking
defined, 38
enabling
for drilling, 39
for linked object browsing, 185, 194, 232, 239
downloading Acrobat Reader, ix
drag, defined, 38
drag-and-drop operations, 60
drill
by double-clicking, 38
down on attributes, 54, 55
down on consolidations, 28
Formula Fill, 149
retain formulas during, 149
to less detail, 56
drill-through
accessing, 215, 226
cells, defining styles for, 226
described, 213, 214
installing, 217
multiple reports, 215
requirements, 217
sample
database, 224
drill-through report, 224
file, 226, 227
stylesfor cells, 215
tutorial guidelines, 218
Drill-Through Wizard
diaog box, 240
introductory screen, 240
duplicating sheets. See cascading sheets, 201
Dynamic Calculation members, applying stylesto,
160, 161
Dynamic Time Series
defined, 163
specifying latest time period, 164, 165

E

Edit Cell Note dialog box, 188
Edit menu, 51
Edit URL dialog box, 191
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editing
cell notes, 187
linked files, 186
URLs, 189, 191
editing in cells, 38
enabling
Essbase toolbar, 33
FlashBack setting, 52
mouse actions, 38, 185, 194
Navigate Without Data, 68
environment (computing), vii
Essbase
API, 22
architecture, 19
Cascade Options dialog box, 202
computing environment, vii
connecting to. See connecting
Disconnect dialog box, 120
disconnecting from. See disconnecting
Member Selection dialog box, 111, 117
Member Selection dialog box, from Query
Designer, 95
menu, 32
migration information, xv
new features, xvi
Options dialog box, 40, 126, 219
starting a session, 32
System Login dialog box, 47, 124
toolbar
described, 34
installing, 33
upgrades, xv
Essbase Integration Server, 22, 213
Essbase Integration Server drill-through. See
drill-through
EssCell function, 156
error messages, 159
syntax, 157
Excel
Add-in Manager, installing Essbase menu, 30
clearing formats, 51, 84
manually adding Spreadsheet Add-in, 30
mouse actions, 38
sample tutorial files, 123
status bar, 32
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Excel Spreadsheet Add-in. See Hyperion Esshase
Spreadsheet Add-in

exchange rates, 207

Execute button, 240

executing drill-through reports, 233, 234

expanding data views. See drill down

expanding formulas when drilling, 150

external files, 177

F

features, Spreadsheet Add-in, xvi
files
accessing linked, 185
destinations
cascaded sheets, 203
Query Designer queries, 103
linking to data cells, 177
sample for tutorial, ix, 123
filtering data, 130
filters
operators, 248
with drill-through, 251
Find Member dialog box, 113
finding members, 110, 113
FlashBack button, 36
FlashBack command, 51
font
formats, 77
stylelist, 78
Font dialog box, 78
forced logouts, 121
formatted sheets
pivoting in, 147
retrieving datainto, 143
formatting
datacells
linked objects, 180, 194
read/write, 82
read-only, 82
dimension members, 79
displaying diases, 85
displaying aiases and names, 87
Dynamic Calculation members, 160
enabling styles, 78
linked object cells, 180, 194
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options for cascaded sheets, 205
parent members, 76
repeating member labels, 88
spreadsheets, 75
text and cell styles, 82
FormulaFill option, 150, 152
Formula Preservation mode
FormulaFill, 149
pivoting in, 147
restrictions with, 147, 150
Retain on Keep and Remove Only, 149
Retain on Retrieval, 146, 149
formulas
EssCell, 156
expanding when drilling, 150
incells, 143, 150
preservation
effects on other operations, 150
enabling, 146, 149
restrictions with, 147
free-form reporting
entering generation and level namesin, 174
in Advanced Interpretation mode, 167
in Free-Form mode, 170
retrieving data, 167
Free-Form retrieval mode, 170
guidelines, 170
functions. See macro functions

G

generations

defined, 27

entering names in spreadsheet, 174
Global page (Esshase Options dialog box), 39

H

Help buttons, 37

Help, accessing, 37

Hyperion Essbase
intended audience, 18
products of, 21

Hyperion Essbase Spreadsheet Add-in
accessing drill-through from, 226
installing toolbar, 33
installing, manually adding, 30
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logging data updates, 199
retrieval cursors, 50
starting, 32

users, described, 18

in-cell editing, 38

installation
manually adding Spreadsheet Add-in, 30
toolbar, 33

installation, drill-through, 217

Integration Server drill-through. See drill-through

Internet, linking cellsto URLs, 182

Interntl sample database, 208

K

Keep Only button, 35
Keep Only command
described, 64
in Formula Preservation mode, 149

L

labels
applying styles, 79
displaying with aliases, 87
entering in spreadsheet, 167, 170
member names. See member names
repeating, 88
LAN. See networks
Latest Time Period option, 164
latest time period, specifying, 163
levels
cascading by, 202
defined, 27
drilling down, 57
drillingin, 57
entering names, 174
linked objects
partitions. See linked partitions
reporting objects. See linked reporting objects
Linked Objects Browser dialog box, 192, 195, 232,
239
LROs, 177
Linked Objects command, 178, 181, 183
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linked partitions
access privileges, 196
accessing from spreadsheet, 194
cells, applying styles, 194
Linked Reporting Objects
accessing from spreadsheet, 185
applying styles, 180
cell notes, 181
creating, 177
external files, 177
URLs, 182
linking
cell notes, 181
external files, 177
partitions, 194
URLsto datacells, 182
list, cascaded sheets, 205
local area network. See networks
Lock command, 197
locking data blocks, with multiple users, 197
logging
off of Essbase. See disconnecting
on to arelational data source, 238
on to Essbase Integration Server, 238
on to Essbase. See connecting, 47
logging data updates from spreadsheet, 199
logical operators, 115
logouts, forced or auto, 121

M

macro functions
EssCell, 156
Spreadsheet Toolkit, ix, 21, 37
main menu (Esshase), 32
manual calculation mode, 159
Member Information dialog box, 112
member names
aliasesfor, 85
alternate. See aliases, 85
applying styles, 76
displaying with aliases, 87
entering in spreadsheet, 167, 170
formatted sheets, 143
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indenting, 28

repeating, 88

with EssCdll function, 157
Member Preview dialog box, 116, 117
Member Retention option, 58
Member Selection button, 36
Member Selection command, 111
Member Selection dialog box, 111
Member Selection Preview dialog box, 100
Member Selection, with Query Designer, 95
members

adding, 95

aliasesfor, 85

ancestors, 27

applying styles, 76, 79

children, 27

collapsing, 56

defined, 26

deleting, 67

descendants, 27

deselecting, 118

drilling down on, 53

drilling up on, 56

Dynamic Calculation, 160

Dynamic Time Series, 163

finding, 110, 113

generations, 27

levels, 27

names. See member names

parents, 27

retaining, 64

selecting, 96, 110

siblings, 27
menu, Essbase, 32
messages (Essbase)

database calculation status, 200

display options, 148

EssCell, 159

unknown member, 146
migrating to release 6, xv
missing vaues

suppressing, 72

suppressing disabled, 150
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missing values, suppressing
in cascaded sheets, 205
unavailable, 150
M ode page (Essbase Options dialog box), 42, 128,
150
money. See currency conversions
mouse actions, enabling, 38
moving
rows and columns. See pivot
through worksheets, 67
multidimensional databases. See databases
multiple filter conditions, with drill-through, 250

N

Named Pipes protocol, 20
names
aternate. See aliases
applying styles, 76
displaying with aliases, 87
entering generation, 174
entering level, 174
repeating, 88
Navigate With or Without Data button, 34
Navigate Without Data command, 67, 71
nested columns or rows, 53
networks, 20
Next Level option, 57, 202
nonadjacent cells, 66
notes, linking to data cells, 181
null values, 157
numeric values, preserving, 144

O

Objects product, 22
ODBC dlients, 21
OLAP
defined, 17
server. See server
online analytical processing, 17
online help
displaying for spreadsheet, 37
opening
Essbase, 32
operating systems, 20
operators, comparison, 110, 133
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options
Cascade, 202
Display, 40, 126, 219
Global, 39, 43, 129, 222
Mode, 42, 128, 150, 220
settings for advanced tutorial, 126
settings for basic tutorial, 40
settings for drill-through tutorial, 219
Style, 77
Zoom, 41, 57, 127, 220
Options button, 36
Options dialog box, 40, 219
OR operators, 110
Order By dialog box, 246
ordering
columns, drill-through, 241
rows, drill-through, 243
outlines
consolidations, 28
described, 25
dimensions, 26
Dynamic Calculation members, 160
Dynamic Time Series members, 163
members, 26
output, cascaded sheets, 202
overlapping styles, 83

P

parent members
applying stylesto, 76
defined, 27
Partitioning product. See linked partitions
partitions. See linked partitions
passwords
changing, 49
entering, 125
pattern matching, 115
pivot
asymmetric reports and, 143
by dragging, 61
described, 38, 60
effect on text, 145
formatted sheets and, 147
formula preservation and, 147
rows or columns, 60, 143
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unavailable, 144
without retrieving data, 69
Pivot command, 60
power loss, 120
preferences. See options, 39
preserving formulas, 146, 153
primary mouse button, 38
printer destination, cascaded sheets, 203
programming interface, 22

Q

queries
applying styles, 104
creating, 93
defining, 91
deleting, 105
retrieving, 91
saving, 102

Query Designer
applying option settings, 109
connecting to multiple databases, 108
creating queries, 94
datafiltering panel, 132
data sorting panel, 138
filtering data, 130
hint panel, 91
layout panel, 95
messages, 141
messages and confirmations, 105
navigation panel, 91
properties panel, 91
save as query dialog box, 102
sorting data, 138

Query Designer icon, 36

R

read/write cells, 82

read-only cdlls, 82

relational data source, 238

relational databases, accessing with drill-through,
214

release 6.2 (Esshase), new features, xvi
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remote databases. See linked partitions, 194
Remove Only button, 35
Remove Only command
described, 67
in Formula Preservation mode, 149
Remove Unselected Groups option, 150
removing. See deleting, 67
Repeat Member Labels option, 88
report script commands, 170, 172
reports
ad hoc, 49, 147
ad hoc currency, 211
asymmetric, 141
creating multiple, 201
formatted, 143
free-form, 167
methods of generating, vii
saving, 119
reports, creating
ad hoc, 211
Cascade, 201
Member Selection, 110
methods, vii
Query Designer, 91
reports, drill-through
accessing, 226
customizing, 216, 234
disconnecting from, 253
executing, 233
selecting to view or customize, 234
restoring database views, 51
restrictions, with Formula Preservation, 150
Retain on Keep and Remove Only option, 150
Retain on Retrieval option
disabled, 150
enabled, 146, 150
Retain on Zooms option, 150, 152
retaining
data subsets, 64
formulas, 143, 144
when drilling, 149
when retaining data, 149
when retrieving, 146, 149
selected members, 64
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Retrieve & Lock command, 197
Retrieve button, 35
Retrieve command, 50
retrieving
Advanced Interpretation mode and, 167
canceling, 51
conditional, 130
currency conversion, 207
cursors, 50
data, 46
Dynamic Cal culation members, 160
formula preservation and, 149
Free-Form mode and, 170
functions, 156
increasing speed, 84, 141, 153, 160
into asymmetric reports, 141
into columns, 53
into formatted sheets, 143
rulesfor, 144
into rows, 53
less detail, 56
modes, 167
more detail, 52
performance impact, 84, 141, 160
range of cells, 153
retaining formulas and, 146, 149
selected cells, 153
starting process and, 49
suppressing data and, 67
reverting to previous database view, 51
rows
blank, 143
deleting during pivot, 143
displaying as columns, 60
displaying selected, 64
filtering by, 132
keeping discontinuous, 66
nested, 53
pivoting, 60
removing selected, 67
retrieving into, 53
sorting within, 138
suppressing valuesin, 72, 205
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S

sample
databases
connecting to, 48, 208
described, ix, 46, 207
databases, in drill-through, 224
files for tutorial, location, 123
Sample Basic
connecting to, 48
described, 46
Sample directory, 123
Save As command, 119
Save command, 119
saving
queries, 102
worksheets, 119
secondary mouse button, 38
select (defined), 38
Select Calc Script option, 200
Select Columns and Display Order dialog box, 241,
242
Select Data Filters dialog box, 247
Select Data Sort Order dialog box, 243
Select Drill-Through Report dialog box, 233, 240
Select Filter Vaues from the List dialog box, 249
selecting
cellsto keep, 64
cellsto remove, 67
latest time period, 163
members, 110
nonadjacent cells, 66
range of cellsfor retrieval, 153
Send command, 197
sending
datato server, 197
log file, 199
server, 19
changing password, 49
client-server environment, 19
connecting to, 48, 124
described, 20
disconnecting from, 120
Essbase Integration Server, 22, 213
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Essbase OLAP, described, 20
logging updates to, 197
migrating to release 5, with client, xv
name, 48, 124
on network, 20
sending datato, 197
Set Filter on Column dialog box, 248
shared members, applying stylesto, 77
sheet destination, Cascade option, 203
sheets. See worksheets
shortcuts, mouse actions, 38
shortcuts, toolbar buttons, 34
siblings (defined), 27
sort order
with drill-through, 243
with Query Designer, 138
sorting criteria, 130
Spreadsheet Toolkit product, 21
spreadsheets
applying styles, 75
cascading, 201
creating multiple, 201
data update log file, 199
described, 23
displaying aiases, 85, 87
displaying member names, 87
distributing, 201
drilling options, 57
global options, 39, 52, 148
mode options, 149, 167
preserving formulas, 149
repeating member labels, 88
retrieving data, 46
saving, 119
setting options, 40
style options, 75
suppressing missing and zero values, 72
zoom options, 57
SQL Interface, 21
starting
dataretrieval, 50
drill-through, 226
Hyperion Essbase, 32
Hyperion Essbase Spreadsheet Add-in, 32
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status bar, enabling and disabling, 32
status of database connections, 194
Style page (Essbase Options dialog box), 77
styles
applying
to datacells, 82
to dimension members, 79
to dimensions, 79
to drill-through cells, 226
to linked partition cells, 194
to linked reporting object cells, 180
to members, 76
to parent members, 76
to Query Designer results, 109
to shared members, 77
clearing, 84
defining, 76, 77
hierarchy of, 83
overlapping, 83
removing, 84
selecting members, 77
stored in ESSBASE.INI, 81
turning off, 84
turning on, 78
Subset dialog box, 114, 116
subsets
defining members, 114
removing, 67
retaining, 64
substitution variables, 165, 166
suppressing
dataretrieval, 67
disabled, 150
missing and zero values, 72
underscore characters, 72
symmetric reports, 141
system administrator, 18
system failure, 120

T

table of contents, with Cascade, 205

TCP/IP protocol, 20

terminating database connections. See disconnecting
termination, abnormal, 120
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text
entering free-form, 167
formatting, 78
hierarchy of styles, 83
pivoting. See pivot
preserving formatted, 144
time periods, 163
title members, with drill-down, 53
to-date calculations, specifying, 163
toolbar (Essbase), 36
buttons on, 34
installing, 33
tracking data updates, 199
transaction-level data, accessing with drill-through,
214
transparent partitions. See linked partitions
transport protocol, 20
tutorial
basic tasks, 29
guidelines, 44
preparing for, 40

U

UDA. See user-defined attributes, 114
underscore characters, suppressing, 74
Undo command. See FlashBack command
undoing actions, 51
Unlock command, 198
unlocking data blocks, 198
Update Mode, 197
updating
data, 197
log file, 199
upgrading, xv
up-to-date calculations, 163
URLs
accessing linked, 189
editing, 191
length limits, 184
linking to data cells, 182
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Use Aliases option, 85

Use Both Member Names and Aliases option, 87
Use Sheet Options with Query Designer option, 109
Use Styles option, 78

User-Defined Attributes, 114

username, entering, 125

users, 18

\Y

V2.x mode, 170

VBA functions, ix

viewing
active connections, 194
diases, 85
dliases and names, 87
datain spreadsheet, 49
Dynamic Calculation members, 160
Essbhase menu, 32
Essbase toolbar, 33
fewer members. Seedrill
linked partitions, 194
linked reporting objects, 185
more members. See drill
multidimensional data, 24
online help, 37
repeated member labels, 88
spreadsheet without data, 67
styles, 78
toolbar, 33

views, restoring, 51

Visual Basic for Applications. See VBA functions

visua cues. See styles

w

Web resources, linking to data cells, 182
wildcard characters, 113
Windows NT Registry, changesto, 30
Within Selected Group option, 59, 141
worksheets

formatting, 75

navigating without datain, 67
World Wide Web, linking to data cells, 182
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Xchgrate sample database, 208

Z

zero values
suppressing, 72, 74
suppressing disabled, 150
Zoom commands, customizing, 57
Zoom In button, 35
Zoom In command
drilling down options, 52
selecting levels, 57
Zoom Out button, 36
Zoom Out command, drilling up options, 56

Zoom page (Essbhase Options dialog box), 41, 57
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